compiler/tests/extras/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Tue, 08 Sep 2015 01:24:23 +0100
changeset 539 610131174c0f
parent 524 f6f68d32de73
child 525 751532c8f3db
permissions -rw-r--r--
Updated splicemaps.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_goodies_petitparser_compiler_tests_extras.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=goodies/petitparser/compiler/tests/extras
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	PPCLRPNode \
	PPCLRPParser \
	PPExpressionGrammar \
	PPLL1ExpressionGrammar \
	stx_goodies_petitparser_compiler_tests_extras \
	PPCLRPAction \
	PPCLRPContainedElement \
	PPCLRPSpawn \
	PPCLRPComment \
	PPCLRPErrorNode \
	PPCLRPEvent \
	PPCLRPMachine \
	PPCLRPOnEntry \
	PPCLRPOnExit \
	PPCLRPRunning \
	PPCLRPState \
	PPCLRPTransition \
	PPCLRPVariable \
	PPCLRPEpsilonTransition \
	PPCLRPTimeoutTransition \
	PPCLRPWildcardTransition \




COMMON_OBJS= \
    $(OUTDIR_SLASH)PPCLRPNode.$(O) \
    $(OUTDIR_SLASH)PPCLRPParser.$(O) \
    $(OUTDIR_SLASH)PPExpressionGrammar.$(O) \
    $(OUTDIR_SLASH)PPLL1ExpressionGrammar.$(O) \
    $(OUTDIR_SLASH)stx_goodies_petitparser_compiler_tests_extras.$(O) \
    $(OUTDIR_SLASH)PPCLRPAction.$(O) \
    $(OUTDIR_SLASH)PPCLRPContainedElement.$(O) \
    $(OUTDIR_SLASH)PPCLRPSpawn.$(O) \
    $(OUTDIR_SLASH)PPCLRPComment.$(O) \
    $(OUTDIR_SLASH)PPCLRPErrorNode.$(O) \
    $(OUTDIR_SLASH)PPCLRPEvent.$(O) \
    $(OUTDIR_SLASH)PPCLRPMachine.$(O) \
    $(OUTDIR_SLASH)PPCLRPOnEntry.$(O) \
    $(OUTDIR_SLASH)PPCLRPOnExit.$(O) \
    $(OUTDIR_SLASH)PPCLRPRunning.$(O) \
    $(OUTDIR_SLASH)PPCLRPState.$(O) \
    $(OUTDIR_SLASH)PPCLRPTransition.$(O) \
    $(OUTDIR_SLASH)PPCLRPVariable.$(O) \
    $(OUTDIR_SLASH)PPCLRPEpsilonTransition.$(O) \
    $(OUTDIR_SLASH)PPCLRPTimeoutTransition.$(O) \
    $(OUTDIR_SLASH)PPCLRPWildcardTransition.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \