Make.spec
changeset 1638 ba6a5298054c
parent 1464 d089b4f792c0
child 1730 07607c7fb2fa
equal deleted inserted replaced
1637:39e2c06afe6c 1638:ba6a5298054c
    20 # Argument(s) to the stc compiler (stc --usage).
    20 # Argument(s) to the stc compiler (stc --usage).
    21 #  -headerDir=. : create header files locally
    21 #  -headerDir=. : create header files locally
    22 #                (if removed, they will be created as common
    22 #                (if removed, they will be created as common
    23 #  -Pxxx       : defines the package
    23 #  -Pxxx       : defines the package
    24 #  -Zxxx       : a prefix for variables within the classLib
    24 #  -Zxxx       : a prefix for variables within the classLib
    25 #  -Dxxx       : defines passed to to CC for inline C-code
    25 #  -Dxxx       : defines passed to CC for inline C-code
    26 #  -Ixxx       : include path passed to CC for inline C-code
    26 #  -Ixxx       : include path passed to CC for inline C-code
    27 #  +optspace   : optimized for space
    27 #  +optspace   : optimized for space
    28 #  +optspace2  : optimized more for space
    28 #  +optspace2  : optimized more for space
    29 #  +optspace3  : optimized even more for space
    29 #  +optspace3  : optimized even more for space
    30 #  +optinline  : generate inline code for some ST constructs
    30 #  +optinline  : generate inline code for some ST constructs
    40 # Argument(s) to the stc compiler (stc --usage).
    40 # Argument(s) to the stc compiler (stc --usage).
    41 #  -warn            : no warnings
    41 #  -warn            : no warnings
    42 #  -warnNonStandard : no warnings about ST/X extensions
    42 #  -warnNonStandard : no warnings about ST/X extensions
    43 #  -warnEOLComments : no warnings about EOL comment extension
    43 #  -warnEOLComments : no warnings about EOL comment extension
    44 #  -warnPrivacy     : no warnings about privateClass extension
    44 #  -warnPrivacy     : no warnings about privateClass extension
       
    45 #  -warnUnused      : no warnings about unused variables
    45 #
    46 #
    46 # ********** OPTIONAL: MODIFY the next line(s) ***
    47 # ********** OPTIONAL: MODIFY the next line(s) ***
    47 # STCWARNINGS=-warn
    48 # STCWARNINGS=-warn
    48 # STCWARNINGS=-warnNonStandard
    49 # STCWARNINGS=-warnNonStandard
    49 # STCWARNINGS=-warnEOLComments
    50 # STCWARNINGS=-warnEOLComments
    54 
    55 
    55 
    56 
    56 
    57 
    57 
    58 
    58 COMMON_OBJS= \
    59 COMMON_OBJS= \
    59     $(OUTDIR_SLASH)stx_goodies_regression.$(O) \
    60     $(OUTDIR)stx_goodies_regression.$(O) \
    60 
    61 
    61 
    62 
    62 
    63