Make.spec
author Patrik Svestka <patrik.svestka@gmail.com>
Mon, 10 Dec 2018 15:24:26 +0100
branchjv
changeset 2078 9d76442a61bb
parent 1567 e17701a073f9
permissions -rwxr-xr-x
Issue #250: Tests for Unicode read: with and without enumeration, remote registry, empty data values, non-string names - Adding regression tests for #Win32OperatingSystemTest. - Adding a template example - unicodeRegistryExample which is an example registry file. Adding contents of the file to registry via setUp and deleting it via tearDown. - Added unicode tests for expecially valueNamed: and for ValueNamesAndValuesDo:. All tests are testing Unicode (UTF-16) read for all available registry types. - added testReadSubKeyAtIndex_01 which tests #subKeyAtIndex: (which is zero based) - unicodeRegistryExample contains also max path to test the limits - Testing unicode read and unicode read with enumeration - Testing unicode reading of remote registry - adding to the file template a string with only digits - adding tests with empty data values - adding tests with non-string names

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_goodies_regression.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=goodies/regression
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	stx_goodies_regression \




COMMON_OBJS= \
    $(OUTDIR)stx_goodies_regression.$(O) \