Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Wed, 02 Sep 2015 18:29:03 +0100
changeset 5 5cc2caa88b23
parent 0 43cb9f3e345e
permissions -rw-r--r--
SOme fixes in containes

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_goodies_ring.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=goodies/ring
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	RGDefinition \
	stx_goodies_ring \
	RGAbstractContainer \
	RGElementDefinition \
	RGGlobalDefinition \
	RGBehaviorDefinition \
	RGCommentDefinition \
	RGContainer \
	RGGlobalVariableDefinition \
	RGMethodDefinition \
	RGOrganization \
	RGVariableDefinition \
	RGClassDescriptionDefinition \
	RGClassInstanceVariableDefinition \
	RGClassVariableDefinition \
	RGInstanceVariableDefinition \
	RGNamespace \
	RGPackage \
	RGPoolVariableDefinition \
	RGSlice \
	RGTraitDescriptionDefinition \
	RGClassDefinition \
	RGMetaclassDefinition \
	RGMetatraitDefinition \
	RGTraitDefinition \




COMMON_OBJS= \
    $(OUTDIR_SLASH)RGDefinition.$(O) \
    $(OUTDIR_SLASH)stx_goodies_ring.$(O) \
    $(OUTDIR_SLASH)RGAbstractContainer.$(O) \
    $(OUTDIR_SLASH)RGElementDefinition.$(O) \
    $(OUTDIR_SLASH)RGGlobalDefinition.$(O) \
    $(OUTDIR_SLASH)RGBehaviorDefinition.$(O) \
    $(OUTDIR_SLASH)RGCommentDefinition.$(O) \
    $(OUTDIR_SLASH)RGContainer.$(O) \
    $(OUTDIR_SLASH)RGGlobalVariableDefinition.$(O) \
    $(OUTDIR_SLASH)RGMethodDefinition.$(O) \
    $(OUTDIR_SLASH)RGOrganization.$(O) \
    $(OUTDIR_SLASH)RGVariableDefinition.$(O) \
    $(OUTDIR_SLASH)RGClassDescriptionDefinition.$(O) \
    $(OUTDIR_SLASH)RGClassInstanceVariableDefinition.$(O) \
    $(OUTDIR_SLASH)RGClassVariableDefinition.$(O) \
    $(OUTDIR_SLASH)RGInstanceVariableDefinition.$(O) \
    $(OUTDIR_SLASH)RGNamespace.$(O) \
    $(OUTDIR_SLASH)RGPackage.$(O) \
    $(OUTDIR_SLASH)RGPoolVariableDefinition.$(O) \
    $(OUTDIR_SLASH)RGSlice.$(O) \
    $(OUTDIR_SLASH)RGTraitDescriptionDefinition.$(O) \
    $(OUTDIR_SLASH)RGClassDefinition.$(O) \
    $(OUTDIR_SLASH)RGMetaclassDefinition.$(O) \
    $(OUTDIR_SLASH)RGMetatraitDefinition.$(O) \
    $(OUTDIR_SLASH)RGTraitDefinition.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \