Make.spec
changeset 830 1a88f5e65fe2
parent 824 e05a8e8035f9
--- a/Make.spec	Mon May 11 06:44:29 2015 +0100
+++ b/Make.spec	Mon May 11 09:30:28 2015 +0100
@@ -51,139 +51,139 @@
 STCWARNINGS=-warnNonStandard
 
 COMMON_CLASSES= \
-	CustomChangeManager \
-	CustomClassQuery \
-	CustomCodeGeneratorOrRefactoring \
-	CustomContext \
-	CustomDialog \
-	CustomManager \
-	CustomMenuBuilder \
-	CustomMock \
-	CustomNamespace \
-	CustomParseTreeRewriter \
-	CustomPerspective \
-	CustomRefactoryBuilder \
-	CustomSourceCodeFormatter \
-	CustomSourceCodeGenerator \
-	CustomSourceCodeSelection \
-	CustomTestCaseHelper \
+	SmallSense::CustomChangeManager \
+	SmallSense::CustomClassQuery \
+	SmallSense::CustomCodeGeneratorOrRefactoring \
+	SmallSense::CustomContext \
+	SmallSense::CustomDialog \
+	SmallSense::CustomManager \
+	SmallSense::CustomMenuBuilder \
+	SmallSense::CustomMock \
+	SmallSense::CustomNamespace \
+	SmallSense::CustomParseTreeRewriter \
+	SmallSense::CustomPerspective \
+	SmallSense::CustomRefactoryBuilder \
+	SmallSense::CustomSourceCodeFormatter \
+	SmallSense::CustomSourceCodeGenerator \
+	SmallSense::CustomSourceCodeSelection \
+	SmallSense::CustomTestCaseHelper \
 	jn_refactoring_custom \
-	CustomBrowserChangeManager \
-	CustomBrowserContext \
-	CustomCodeGenerator \
-	CustomLocalChangeManager \
-	CustomNoneSourceCodeFormatter \
-	CustomRBLocalSourceCodeFormatter \
-	CustomRefactoring \
-	CustomSilentDialog \
-	CustomSubContext \
-	CustomUserDialog \
-	CustomAccessMethodsCodeGenerator \
-	CustomCodeSelectionRefactoring \
-	CustomInspectorTabCodeGenerator \
-	CustomIsAbstractCodeGenerator \
-	CustomJavaSimpleSetterMethodsCodeGenerator \
-	CustomNewClassGenerator \
-	CustomReplaceIfNilWithIfTrueRefactoring \
-	CustomSubclassResponsibilityCodeGenerator \
-	CustomTestCaseCodeGenerator \
-	CustomTestCaseMethodCodeGenerator \
-	CustomTestCaseSetUpCodeGenerator \
-	CustomTestCaseTearDownCodeGenerator \
-	CustomUpdateTestCaseCategoryRefactoring \
-	CustomVisitorCodeGenerator \
-	CustomChangeNotificationAccessMethodsCodeGenerator \
-	CustomChangeNotificationSetterMethodsCodeGenerator \
-	CustomCodeGeneratorClassGenerator \
-	CustomCodeGeneratorOrRefactoringTestCaseCodeGenerator \
-	CustomCodeSelectionToResourceTranslation \
-	CustomDefaultGetterMethodsCodeGenerator \
-	CustomLazyInitializationAccessMethodsCodeGenerator \
-	CustomLazyInitializationGetterMethodsCodeGenerator \
-	CustomMultiSetterMethodsCodeGenerator \
-	CustomPrintCodeSelectionRefactoring \
-	CustomRefactoringClassGenerator \
-	CustomSimpleAccessMethodsCodeGenerator \
-	CustomSimpleGetterMethodsCodeGenerator \
-	CustomSimpleSetterMethodsCodeGenerator \
-	CustomUITestCaseCodeGenerator \
-	CustomUITestCaseSetUpCodeGenerator \
-	CustomValueHolderAccessMethodsCodeGenerator \
-	CustomValueHolderGetterMethodsCodeGenerator \
-	CustomValueHolderWithChangeNotificationAccessMethodsCodeGenerator \
-	CustomValueHolderWithChangeNotificationGetterMethodsCodeGenerator \
-	CustomValueHolderWithChangeNotificationSetterMethodsCodeGenerator \
-	CustomVisitorCodeGeneratorAcceptVisitor \
-	CustomJavaScriptSimpleSetterMethodsCodeGenerator \
+	SmallSense::CustomBrowserChangeManager \
+	SmallSense::CustomBrowserContext \
+	SmallSense::CustomCodeGenerator \
+	SmallSense::CustomLocalChangeManager \
+	SmallSense::CustomNoneSourceCodeFormatter \
+	SmallSense::CustomRBLocalSourceCodeFormatter \
+	SmallSense::CustomRefactoring \
+	SmallSense::CustomSilentDialog \
+	SmallSense::CustomSubContext \
+	SmallSense::CustomUserDialog \
+	SmallSense::CustomAccessMethodsCodeGenerator \
+	SmallSense::CustomCodeSelectionRefactoring \
+	SmallSense::CustomInspectorTabCodeGenerator \
+	SmallSense::CustomIsAbstractCodeGenerator \
+	SmallSense::CustomJavaSimpleSetterMethodsCodeGenerator \
+	SmallSense::CustomNewClassGenerator \
+	SmallSense::CustomReplaceIfNilWithIfTrueRefactoring \
+	SmallSense::CustomSubclassResponsibilityCodeGenerator \
+	SmallSense::CustomTestCaseCodeGenerator \
+	SmallSense::CustomTestCaseMethodCodeGenerator \
+	SmallSense::CustomTestCaseSetUpCodeGenerator \
+	SmallSense::CustomTestCaseTearDownCodeGenerator \
+	SmallSense::CustomUpdateTestCaseCategoryRefactoring \
+	SmallSense::CustomVisitorCodeGenerator \
+	SmallSense::CustomChangeNotificationAccessMethodsCodeGenerator \
+	SmallSense::CustomChangeNotificationSetterMethodsCodeGenerator \
+	SmallSense::CustomCodeGeneratorClassGenerator \
+	SmallSense::CustomCodeGeneratorOrRefactoringTestCaseCodeGenerator \
+	SmallSense::CustomCodeSelectionToResourceTranslation \
+	SmallSense::CustomDefaultGetterMethodsCodeGenerator \
+	SmallSense::CustomLazyInitializationAccessMethodsCodeGenerator \
+	SmallSense::CustomLazyInitializationGetterMethodsCodeGenerator \
+	SmallSense::CustomMultiSetterMethodsCodeGenerator \
+	SmallSense::CustomPrintCodeSelectionRefactoring \
+	SmallSense::CustomRefactoringClassGenerator \
+	SmallSense::CustomSimpleAccessMethodsCodeGenerator \
+	SmallSense::CustomSimpleGetterMethodsCodeGenerator \
+	SmallSense::CustomSimpleSetterMethodsCodeGenerator \
+	SmallSense::CustomUITestCaseCodeGenerator \
+	SmallSense::CustomUITestCaseSetUpCodeGenerator \
+	SmallSense::CustomValueHolderAccessMethodsCodeGenerator \
+	SmallSense::CustomValueHolderGetterMethodsCodeGenerator \
+	SmallSense::CustomValueHolderWithChangeNotificationAccessMethodsCodeGenerator \
+	SmallSense::CustomValueHolderWithChangeNotificationGetterMethodsCodeGenerator \
+	SmallSense::CustomValueHolderWithChangeNotificationSetterMethodsCodeGenerator \
+	SmallSense::CustomVisitorCodeGeneratorAcceptVisitor \
+	SmallSense::CustomJavaScriptSimpleSetterMethodsCodeGenerator \
 
 
 
 
 COMMON_OBJS= \
-    $(OUTDIR_SLASH)CustomChangeManager.$(O) \
-    $(OUTDIR_SLASH)CustomClassQuery.$(O) \
-    $(OUTDIR_SLASH)CustomCodeGeneratorOrRefactoring.$(O) \
-    $(OUTDIR_SLASH)CustomContext.$(O) \
-    $(OUTDIR_SLASH)CustomDialog.$(O) \
-    $(OUTDIR_SLASH)CustomManager.$(O) \
-    $(OUTDIR_SLASH)CustomMenuBuilder.$(O) \
-    $(OUTDIR_SLASH)CustomMock.$(O) \
-    $(OUTDIR_SLASH)CustomNamespace.$(O) \
-    $(OUTDIR_SLASH)CustomParseTreeRewriter.$(O) \
-    $(OUTDIR_SLASH)CustomPerspective.$(O) \
-    $(OUTDIR_SLASH)CustomRefactoryBuilder.$(O) \
-    $(OUTDIR_SLASH)CustomSourceCodeFormatter.$(O) \
-    $(OUTDIR_SLASH)CustomSourceCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomSourceCodeSelection.$(O) \
-    $(OUTDIR_SLASH)CustomTestCaseHelper.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomChangeManager.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomClassQuery.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomCodeGeneratorOrRefactoring.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomContext.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomDialog.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomManager.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomMenuBuilder.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomMock.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomNamespace.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomParseTreeRewriter.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomPerspective.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomRefactoryBuilder.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomSourceCodeFormatter.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomSourceCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomSourceCodeSelection.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomTestCaseHelper.$(O) \
     $(OUTDIR_SLASH)jn_refactoring_custom.$(O) \
-    $(OUTDIR_SLASH)CustomBrowserChangeManager.$(O) \
-    $(OUTDIR_SLASH)CustomBrowserContext.$(O) \
-    $(OUTDIR_SLASH)CustomCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomLocalChangeManager.$(O) \
-    $(OUTDIR_SLASH)CustomNoneSourceCodeFormatter.$(O) \
-    $(OUTDIR_SLASH)CustomRBLocalSourceCodeFormatter.$(O) \
-    $(OUTDIR_SLASH)CustomRefactoring.$(O) \
-    $(OUTDIR_SLASH)CustomSilentDialog.$(O) \
-    $(OUTDIR_SLASH)CustomSubContext.$(O) \
-    $(OUTDIR_SLASH)CustomUserDialog.$(O) \
-    $(OUTDIR_SLASH)CustomAccessMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomCodeSelectionRefactoring.$(O) \
-    $(OUTDIR_SLASH)CustomInspectorTabCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomIsAbstractCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomJavaSimpleSetterMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomNewClassGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomReplaceIfNilWithIfTrueRefactoring.$(O) \
-    $(OUTDIR_SLASH)CustomSubclassResponsibilityCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomTestCaseCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomTestCaseMethodCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomTestCaseSetUpCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomTestCaseTearDownCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomUpdateTestCaseCategoryRefactoring.$(O) \
-    $(OUTDIR_SLASH)CustomVisitorCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomChangeNotificationAccessMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomChangeNotificationSetterMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomCodeGeneratorClassGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomCodeGeneratorOrRefactoringTestCaseCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomCodeSelectionToResourceTranslation.$(O) \
-    $(OUTDIR_SLASH)CustomDefaultGetterMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomLazyInitializationAccessMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomLazyInitializationGetterMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomMultiSetterMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomPrintCodeSelectionRefactoring.$(O) \
-    $(OUTDIR_SLASH)CustomRefactoringClassGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomSimpleAccessMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomSimpleGetterMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomSimpleSetterMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomUITestCaseCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomUITestCaseSetUpCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomValueHolderAccessMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomValueHolderGetterMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomValueHolderWithChangeNotificationAccessMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomValueHolderWithChangeNotificationGetterMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomValueHolderWithChangeNotificationSetterMethodsCodeGenerator.$(O) \
-    $(OUTDIR_SLASH)CustomVisitorCodeGeneratorAcceptVisitor.$(O) \
-    $(OUTDIR_SLASH)CustomJavaScriptSimpleSetterMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomBrowserChangeManager.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomBrowserContext.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomLocalChangeManager.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomNoneSourceCodeFormatter.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomRBLocalSourceCodeFormatter.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomRefactoring.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomSilentDialog.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomSubContext.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomUserDialog.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomAccessMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomCodeSelectionRefactoring.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomInspectorTabCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomIsAbstractCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomJavaSimpleSetterMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomNewClassGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomReplaceIfNilWithIfTrueRefactoring.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomSubclassResponsibilityCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomTestCaseCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomTestCaseMethodCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomTestCaseSetUpCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomTestCaseTearDownCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomUpdateTestCaseCategoryRefactoring.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomVisitorCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomChangeNotificationAccessMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomChangeNotificationSetterMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomCodeGeneratorClassGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomCodeGeneratorOrRefactoringTestCaseCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomCodeSelectionToResourceTranslation.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomDefaultGetterMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomLazyInitializationAccessMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomLazyInitializationGetterMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomMultiSetterMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomPrintCodeSelectionRefactoring.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomRefactoringClassGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomSimpleAccessMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomSimpleGetterMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomSimpleSetterMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomUITestCaseCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomUITestCaseSetUpCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomValueHolderAccessMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomValueHolderGetterMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomValueHolderWithChangeNotificationAccessMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomValueHolderWithChangeNotificationGetterMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomValueHolderWithChangeNotificationSetterMethodsCodeGenerator.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomVisitorCodeGeneratorAcceptVisitor.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CustomJavaScriptSimpleSetterMethodsCodeGenerator.$(O) \
     $(OUTDIR_SLASH)extensions.$(O) \