Make.spec
changeset 107 abe4dc4fe5ca
parent 104 3b05b2d777dd
child 108 71471dc81e77
--- a/Make.spec	Thu Sep 26 09:36:14 2013 +0100
+++ b/Make.spec	Thu Sep 26 13:26:46 2013 +0100
@@ -52,7 +52,8 @@
 COMMON_CLASSES= \
 	SmallSense::CodeHighlightingService \
 	SmallSense::CodeNavigationService \
-	SmallSense::CompletionResultSet \
+	SmallSense::CompletionContext \
+	SmallSense::CompletionResult \
 	SmallSense::CompletionWindow \
 	SmallSense::CriticsWindow \
 	SmallSense::EditService \
@@ -61,7 +62,6 @@
 	SmallSense::Manager \
 	SmallSense::PO \
 	SmallSense::ParseNodeInspector \
-	SmallSense::ParseNodePosition \
 	SmallSense::ParseTreeIndex \
 	SmallSense::ParseTreeIndexEntry \
 	SmallSense::SelectorNode \
@@ -101,7 +101,8 @@
 COMMON_OBJS= \
     $(OUTDIR_SLASH)SmallSense__CodeHighlightingService.$(O) \
     $(OUTDIR_SLASH)SmallSense__CodeNavigationService.$(O) \
-    $(OUTDIR_SLASH)SmallSense__CompletionResultSet.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CompletionContext.$(O) \
+    $(OUTDIR_SLASH)SmallSense__CompletionResult.$(O) \
     $(OUTDIR_SLASH)SmallSense__CompletionWindow.$(O) \
     $(OUTDIR_SLASH)SmallSense__CriticsWindow.$(O) \
     $(OUTDIR_SLASH)SmallSense__EditService.$(O) \
@@ -110,7 +111,6 @@
     $(OUTDIR_SLASH)SmallSense__Manager.$(O) \
     $(OUTDIR_SLASH)SmallSense__PO.$(O) \
     $(OUTDIR_SLASH)SmallSense__ParseNodeInspector.$(O) \
-    $(OUTDIR_SLASH)SmallSense__ParseNodePosition.$(O) \
     $(OUTDIR_SLASH)SmallSense__ParseTreeIndex.$(O) \
     $(OUTDIR_SLASH)SmallSense__ParseTreeIndexEntry.$(O) \
     $(OUTDIR_SLASH)SmallSense__SelectorNode.$(O) \