Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Mon, 02 Sep 2013 14:45:35 +0100
changeset 78 16cd76c8d70c
parent 73 c4d090b63d05
child 80 10d72b51e05e
permissions -rw-r--r--
Fix in SmallSense::Recognizer: use customized SmalltalkParser to parse smalltalk code. SmalltalkParser can do some basic error-recovery and thus provides better tree for completion.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: jv_smallsense.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=jv
MODULE_DIR=smallsense
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	SmallSense::CompletionWindow \
	SmallSense::CriticsWindow \
	SmallSense::EditService \
	SmallSense::EditSupport \
	SmallSense::Info \
	SmallSense::Manager \
	SmallSense::PO \
	SmallSense::ParseNodeInspector \
	SmallSense::ParseNodeVisitor \
	SmallSense::ParseTreeIndex \
	SmallSense::ParseTreeIndexEntry \
	SmallSense::Position \
	SmallSense::Recognizer \
	SmallSense::ResultSet \
	SmallSense::SelectorNode \
	SmallSense::SettingsAppl \
	SmallSense::SmalltalkChecker \
	SmallSense::SmalltalkLintService \
	SmallSense::SmalltalkParser \
	SmallSense::SmalltalkQuickFixer \
	SmallSense::SmalltalkSyntaxHighlighter \
	SmallSense::SmalltalkUnacceptedMethodEnvironment \
	SmallSense::SyntaxHighlightingService \
	SmallSense::Type \
	SmallSense::TypeHolder \
	jv_smallsense \
	SmallSense::ClassInfo \
	SmallSense::ClassPO \
	SmallSense::ClassType \
	SmallSense::ConstantPO \
	SmallSense::Finder \
	SmallSense::GenericEditSupport \
	SmallSense::JavaEditSupport \
	SmallSense::MethodInfo \
	SmallSense::MethodPO \
	SmallSense::SmalltalkEditSupport \
	SmallSense::SmalltalkInferencer \
	SmallSense::SnippetPO \
	SmallSense::UnionType \
	SmallSense::UnknownType \
	SmallSense::VariablePO \




COMMON_OBJS= \
    $(OUTDIR_SLASH)SmallSense__CompletionWindow.$(O) \
    $(OUTDIR_SLASH)SmallSense__CriticsWindow.$(O) \
    $(OUTDIR_SLASH)SmallSense__EditService.$(O) \
    $(OUTDIR_SLASH)SmallSense__EditSupport.$(O) \
    $(OUTDIR_SLASH)SmallSense__Info.$(O) \
    $(OUTDIR_SLASH)SmallSense__Manager.$(O) \
    $(OUTDIR_SLASH)SmallSense__PO.$(O) \
    $(OUTDIR_SLASH)SmallSense__ParseNodeInspector.$(O) \
    $(OUTDIR_SLASH)SmallSense__ParseNodeVisitor.$(O) \
    $(OUTDIR_SLASH)SmallSense__ParseTreeIndex.$(O) \
    $(OUTDIR_SLASH)SmallSense__ParseTreeIndexEntry.$(O) \
    $(OUTDIR_SLASH)SmallSense__Position.$(O) \
    $(OUTDIR_SLASH)SmallSense__Recognizer.$(O) \
    $(OUTDIR_SLASH)SmallSense__ResultSet.$(O) \
    $(OUTDIR_SLASH)SmallSense__SelectorNode.$(O) \
    $(OUTDIR_SLASH)SmallSense__SettingsAppl.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkChecker.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkLintService.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkParser.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkQuickFixer.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkSyntaxHighlighter.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkUnacceptedMethodEnvironment.$(O) \
    $(OUTDIR_SLASH)SmallSense__SyntaxHighlightingService.$(O) \
    $(OUTDIR_SLASH)SmallSense__Type.$(O) \
    $(OUTDIR_SLASH)SmallSense__TypeHolder.$(O) \
    $(OUTDIR_SLASH)jv_smallsense.$(O) \
    $(OUTDIR_SLASH)SmallSense__ClassInfo.$(O) \
    $(OUTDIR_SLASH)SmallSense__ClassPO.$(O) \
    $(OUTDIR_SLASH)SmallSense__ClassType.$(O) \
    $(OUTDIR_SLASH)SmallSense__ConstantPO.$(O) \
    $(OUTDIR_SLASH)SmallSense__Finder.$(O) \
    $(OUTDIR_SLASH)SmallSense__GenericEditSupport.$(O) \
    $(OUTDIR_SLASH)SmallSense__JavaEditSupport.$(O) \
    $(OUTDIR_SLASH)SmallSense__MethodInfo.$(O) \
    $(OUTDIR_SLASH)SmallSense__MethodPO.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkEditSupport.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkInferencer.$(O) \
    $(OUTDIR_SLASH)SmallSense__SnippetPO.$(O) \
    $(OUTDIR_SLASH)SmallSense__UnionType.$(O) \
    $(OUTDIR_SLASH)SmallSense__UnknownType.$(O) \
    $(OUTDIR_SLASH)SmallSense__VariablePO.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \