Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Mon, 02 Apr 2012 13:11:56 +0100
changeset 20 65bee305e13f
parent 19 3b7fd62bf51c
child 21 ab990a292878
permissions -rw-r--r--
Added UserPreferences>>smallSenseEnabled:

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libtool_smallsense at 2012-04-02 13:12:40.771.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libtool/smallsense
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	SmallSenseParseNodeVisitor \
	SmallSenseParser \
	SmallSenseRecognizer \
	SmallSenseResultItem \
	SmallSenseResultSet \
	SmallSenseSelectorNode \
	SmallSenseService \
	SmallSenseTypeCollector \
	SmallSenseTypeCollectorCache \
	stx_libtool_smallsense \
	SmallSenseAbstractInstvarInterfaceExtractor \
	SmallSenseClass \
	SmallSenseConstant \
	SmallSenseMethod \
	SmallSenseSnippet \
	SmallSenseVariable \
	SmallSenseInstvarInterfaceExtractor \
	SmallSenseParseNodeInspector \
	SmallSenseFinder \
	SmallSensePosition \
	SmallSenseType \
	SmallSenseInferencer \
	SmallSenseInfo \
	SmallSenseManager \
	SmallSenseMethodInfo \
	SmallSenseClassInfo \
	SmallSenseTypeHolder \
	SmallSenseClassType \
	SmallSenseUnionType \
	SmallSenseUnknownType \
	SmallSenseCompletionWindow \
	SmallSenseCriticsWindow \
	SmallSenseUnacceptedMethodEnvironment \
	SmallSenseQuickFixer \
	SmallSenseSettingsAppl \
	SmallSenseChecker \




COMMON_OBJS= \
    $(OUTDIR)SmallSenseParseNodeVisitor.$(O) \
    $(OUTDIR)SmallSenseParser.$(O) \
    $(OUTDIR)SmallSenseRecognizer.$(O) \
    $(OUTDIR)SmallSenseResultItem.$(O) \
    $(OUTDIR)SmallSenseResultSet.$(O) \
    $(OUTDIR)SmallSenseSelectorNode.$(O) \
    $(OUTDIR)SmallSenseService.$(O) \
    $(OUTDIR)SmallSenseTypeCollector.$(O) \
    $(OUTDIR)SmallSenseTypeCollectorCache.$(O) \
    $(OUTDIR)stx_libtool_smallsense.$(O) \
    $(OUTDIR)SmallSenseAbstractInstvarInterfaceExtractor.$(O) \
    $(OUTDIR)SmallSenseClass.$(O) \
    $(OUTDIR)SmallSenseConstant.$(O) \
    $(OUTDIR)SmallSenseMethod.$(O) \
    $(OUTDIR)SmallSenseSnippet.$(O) \
    $(OUTDIR)SmallSenseVariable.$(O) \
    $(OUTDIR)SmallSenseInstvarInterfaceExtractor.$(O) \
    $(OUTDIR)SmallSenseParseNodeInspector.$(O) \
    $(OUTDIR)SmallSenseFinder.$(O) \
    $(OUTDIR)SmallSensePosition.$(O) \
    $(OUTDIR)SmallSenseType.$(O) \
    $(OUTDIR)SmallSenseInferencer.$(O) \
    $(OUTDIR)SmallSenseInfo.$(O) \
    $(OUTDIR)SmallSenseManager.$(O) \
    $(OUTDIR)SmallSenseMethodInfo.$(O) \
    $(OUTDIR)SmallSenseClassInfo.$(O) \
    $(OUTDIR)SmallSenseTypeHolder.$(O) \
    $(OUTDIR)SmallSenseClassType.$(O) \
    $(OUTDIR)SmallSenseUnionType.$(O) \
    $(OUTDIR)SmallSenseUnknownType.$(O) \
    $(OUTDIR)SmallSenseCompletionWindow.$(O) \
    $(OUTDIR)SmallSenseCriticsWindow.$(O) \
    $(OUTDIR)SmallSenseUnacceptedMethodEnvironment.$(O) \
    $(OUTDIR)SmallSenseQuickFixer.$(O) \
    $(OUTDIR)SmallSenseSettingsAppl.$(O) \
    $(OUTDIR)SmallSenseChecker.$(O) \
    $(OUTDIR)extensions.$(O) \