Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Thu, 25 Jul 2013 11:34:26 +0100
changeset 39 748389119d0a
parent 34 5be71b1d52ec
child 42 48307f46ff8e
permissions -rw-r--r--
Initial support for per-language edit support. Some work on Smalltalk edit support, namely on electric blocks. Works fine, but need more work to make it usable but not too intrusive.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: jv_smallsense.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=jv
MODULE_DIR=smallsense
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	SmallSenseChecker \
	SmallSenseCompletionWindow \
	SmallSenseCriticsWindow \
	SmallSenseEditSupport \
	SmallSenseInfo \
	SmallSenseManager \
	SmallSensePO \
	SmallSenseParseNodeInspector \
	SmallSenseParseNodeVisitor \
	SmallSenseParser \
	SmallSensePosition \
	SmallSenseQuickFixer \
	SmallSenseRecognizer \
	SmallSenseResultSet \
	SmallSenseSelectorNode \
	SmallSenseService \
	SmallSenseSettingsAppl \
	SmallSenseType \
	SmallSenseTypeCollector \
	SmallSenseTypeCollectorCache \
	SmallSenseTypeHolder \
	SmallSenseUnacceptedMethodEnvironment \
	jv_smallsense \
	SmallSenseAbstractInstvarInterfaceExtractor \
	SmallSenseClassInfo \
	SmallSenseClassPO \
	SmallSenseClassType \
	SmallSenseConstantPO \
	SmallSenseFinder \
	SmallSenseGenericEditSupport \
	SmallSenseInferencer \
	SmallSenseMethodInfo \
	SmallSenseMethodPO \
	SmallSenseSmalltalkEditSupport \
	SmallSenseSnippetPO \
	SmallSenseUnionType \
	SmallSenseUnknownType \
	SmallSenseVariablePO \
	SmallSenseInstvarInterfaceExtractor \




COMMON_OBJS= \
    $(OUTDIR_SLASH)SmallSenseChecker.$(O) \
    $(OUTDIR_SLASH)SmallSenseCompletionWindow.$(O) \
    $(OUTDIR_SLASH)SmallSenseCriticsWindow.$(O) \
    $(OUTDIR_SLASH)SmallSenseEditSupport.$(O) \
    $(OUTDIR_SLASH)SmallSenseInfo.$(O) \
    $(OUTDIR_SLASH)SmallSenseManager.$(O) \
    $(OUTDIR_SLASH)SmallSensePO.$(O) \
    $(OUTDIR_SLASH)SmallSenseParseNodeInspector.$(O) \
    $(OUTDIR_SLASH)SmallSenseParseNodeVisitor.$(O) \
    $(OUTDIR_SLASH)SmallSenseParser.$(O) \
    $(OUTDIR_SLASH)SmallSensePosition.$(O) \
    $(OUTDIR_SLASH)SmallSenseQuickFixer.$(O) \
    $(OUTDIR_SLASH)SmallSenseRecognizer.$(O) \
    $(OUTDIR_SLASH)SmallSenseResultSet.$(O) \
    $(OUTDIR_SLASH)SmallSenseSelectorNode.$(O) \
    $(OUTDIR_SLASH)SmallSenseService.$(O) \
    $(OUTDIR_SLASH)SmallSenseSettingsAppl.$(O) \
    $(OUTDIR_SLASH)SmallSenseType.$(O) \
    $(OUTDIR_SLASH)SmallSenseTypeCollector.$(O) \
    $(OUTDIR_SLASH)SmallSenseTypeCollectorCache.$(O) \
    $(OUTDIR_SLASH)SmallSenseTypeHolder.$(O) \
    $(OUTDIR_SLASH)SmallSenseUnacceptedMethodEnvironment.$(O) \
    $(OUTDIR_SLASH)jv_smallsense.$(O) \
    $(OUTDIR_SLASH)SmallSenseAbstractInstvarInterfaceExtractor.$(O) \
    $(OUTDIR_SLASH)SmallSenseClassInfo.$(O) \
    $(OUTDIR_SLASH)SmallSenseClassPO.$(O) \
    $(OUTDIR_SLASH)SmallSenseClassType.$(O) \
    $(OUTDIR_SLASH)SmallSenseConstantPO.$(O) \
    $(OUTDIR_SLASH)SmallSenseFinder.$(O) \
    $(OUTDIR_SLASH)SmallSenseGenericEditSupport.$(O) \
    $(OUTDIR_SLASH)SmallSenseInferencer.$(O) \
    $(OUTDIR_SLASH)SmallSenseMethodInfo.$(O) \
    $(OUTDIR_SLASH)SmallSenseMethodPO.$(O) \
    $(OUTDIR_SLASH)SmallSenseSmalltalkEditSupport.$(O) \
    $(OUTDIR_SLASH)SmallSenseSnippetPO.$(O) \
    $(OUTDIR_SLASH)SmallSenseUnionType.$(O) \
    $(OUTDIR_SLASH)SmallSenseUnknownType.$(O) \
    $(OUTDIR_SLASH)SmallSenseVariablePO.$(O) \
    $(OUTDIR_SLASH)SmallSenseInstvarInterfaceExtractor.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \