Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Thu, 17 Oct 2013 01:41:47 +0100
changeset 132 7c23c51d2cfd
parent 120 4fefce92f5bb
child 133 bd659b67811c
permissions -rw-r--r--
Completion insertion refactoring. Added language and codeView into CompletionContext. Added context slot into PO so the PO itself know the completion context and can tweak its presentation accordingly. Also, actual text insertion is now delegated to the PO so the PO can insert proper text according to the context (especially - language)

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: jv_smallsense.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=jv
MODULE_DIR=smallsense
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	SmallSense::CodeHighlightingService \
	SmallSense::CodeNavigationService \
	SmallSense::CompletionContext \
	SmallSense::CompletionController \
	SmallSense::CompletionEngine \
	SmallSense::CompletionResult \
	SmallSense::CompletionView \
	SmallSense::CriticsWindow \
	SmallSense::EditService \
	SmallSense::EditSupport \
	SmallSense::Info \
	SmallSense::Manager \
	SmallSense::PO \
	SmallSense::ParseNodeInspector \
	SmallSense::ParseTreeIndex \
	SmallSense::ParseTreeIndexEntry \
	SmallSense::SelectorNode \
	SmallSense::SettingsAppl \
	SmallSense::SmalltalkChecker \
	SmallSense::SmalltalkLintAnnotation \
	SmallSense::SmalltalkLintHighlighter \
	SmallSense::SmalltalkLintService \
	SmallSense::SmalltalkParseNodeVisitor \
	SmallSense::SmalltalkParser \
	SmallSense::SmalltalkQuickFixer \
	SmallSense::SmalltalkSyntaxHighlighter \
	SmallSense::SmalltalkUnacceptedMethodEnvironment \
	SmallSense::Type \
	SmallSense::TypeHolder \
	jv_smallsense \
	SmallSense::ClassInfo \
	SmallSense::ClassPO \
	SmallSense::ClassType \
	SmallSense::ConstantPO \
	SmallSense::GenericEditSupport \
	SmallSense::JavaCompletionEngineSimple \
	SmallSense::JavaEditSupport \
	SmallSense::MethodInfo \
	SmallSense::MethodPO \
	SmallSense::SmalltalkCompletionEngine \
	SmallSense::SmalltalkEditSupport \
	SmallSense::SmalltalkInferencer \
	SmallSense::SmalltalkParseNodeFinder \
	SmallSense::SnippetPO \
	SmallSense::UnionType \
	SmallSense::UnknownType \
	SmallSense::VariablePO \
	SmallSense::GroovyCompletionEngineSimple \
	SmallSense::GroovyEditSupport \




COMMON_OBJS= \
    $(OUTDIR_SLASH)SmallSense__CodeHighlightingService.$(O) \
    $(OUTDIR_SLASH)SmallSense__CodeNavigationService.$(O) \
    $(OUTDIR_SLASH)SmallSense__CompletionContext.$(O) \
    $(OUTDIR_SLASH)SmallSense__CompletionController.$(O) \
    $(OUTDIR_SLASH)SmallSense__CompletionEngine.$(O) \
    $(OUTDIR_SLASH)SmallSense__CompletionResult.$(O) \
    $(OUTDIR_SLASH)SmallSense__CompletionView.$(O) \
    $(OUTDIR_SLASH)SmallSense__CriticsWindow.$(O) \
    $(OUTDIR_SLASH)SmallSense__EditService.$(O) \
    $(OUTDIR_SLASH)SmallSense__EditSupport.$(O) \
    $(OUTDIR_SLASH)SmallSense__Info.$(O) \
    $(OUTDIR_SLASH)SmallSense__Manager.$(O) \
    $(OUTDIR_SLASH)SmallSense__PO.$(O) \
    $(OUTDIR_SLASH)SmallSense__ParseNodeInspector.$(O) \
    $(OUTDIR_SLASH)SmallSense__ParseTreeIndex.$(O) \
    $(OUTDIR_SLASH)SmallSense__ParseTreeIndexEntry.$(O) \
    $(OUTDIR_SLASH)SmallSense__SelectorNode.$(O) \
    $(OUTDIR_SLASH)SmallSense__SettingsAppl.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkChecker.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkLintAnnotation.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkLintHighlighter.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkLintService.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkParseNodeVisitor.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkParser.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkQuickFixer.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkSyntaxHighlighter.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkUnacceptedMethodEnvironment.$(O) \
    $(OUTDIR_SLASH)SmallSense__Type.$(O) \
    $(OUTDIR_SLASH)SmallSense__TypeHolder.$(O) \
    $(OUTDIR_SLASH)jv_smallsense.$(O) \
    $(OUTDIR_SLASH)SmallSense__ClassInfo.$(O) \
    $(OUTDIR_SLASH)SmallSense__ClassPO.$(O) \
    $(OUTDIR_SLASH)SmallSense__ClassType.$(O) \
    $(OUTDIR_SLASH)SmallSense__ConstantPO.$(O) \
    $(OUTDIR_SLASH)SmallSense__GenericEditSupport.$(O) \
    $(OUTDIR_SLASH)SmallSense__JavaCompletionEngineSimple.$(O) \
    $(OUTDIR_SLASH)SmallSense__JavaEditSupport.$(O) \
    $(OUTDIR_SLASH)SmallSense__MethodInfo.$(O) \
    $(OUTDIR_SLASH)SmallSense__MethodPO.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkCompletionEngine.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkEditSupport.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkInferencer.$(O) \
    $(OUTDIR_SLASH)SmallSense__SmalltalkParseNodeFinder.$(O) \
    $(OUTDIR_SLASH)SmallSense__SnippetPO.$(O) \
    $(OUTDIR_SLASH)SmallSense__UnionType.$(O) \
    $(OUTDIR_SLASH)SmallSense__UnknownType.$(O) \
    $(OUTDIR_SLASH)SmallSense__VariablePO.$(O) \
    $(OUTDIR_SLASH)SmallSense__GroovyCompletionEngineSimple.$(O) \
    $(OUTDIR_SLASH)SmallSense__GroovyEditSupport.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \