Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Sun, 01 Dec 2013 00:31:23 +0000
changeset 500 8c2b58d6b2d5
parent 495 685a2fc308b5
child 502 4f90bc3ddf5b
child 504 3525d97ae194
permissions -rw-r--r--
Code reogranization, Defined CustomContext & basic API. Created/factored abstract CustomCodeGeneratorOrRefactoring with two API methods: #availableInContext: & #executeInContext:. Test context class CustomContext is currently void, but will contain all required context data - basically it will serve as an facade to browser NavigationState.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: jn_refactoring_custom.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=jn
MODULE_DIR=refactoring_custom
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	CustomCodeGeneratorAndRefactoringManager \
	CustomCodeGeneratorOrRefactoring \
	CustomContext \
	jn_refactoring_custom \
	CustomCodeGenerator \
	CustomRefactoring \
	CustomVisitorCodeGenerator \
	DummyCodeGenerator \




COMMON_OBJS= \
    $(OUTDIR_SLASH)CustomCodeGeneratorAndRefactoringManager.$(O) \
    $(OUTDIR_SLASH)CustomCodeGeneratorOrRefactoring.$(O) \
    $(OUTDIR_SLASH)CustomContext.$(O) \
    $(OUTDIR_SLASH)jn_refactoring_custom.$(O) \
    $(OUTDIR_SLASH)CustomCodeGenerator.$(O) \
    $(OUTDIR_SLASH)CustomRefactoring.$(O) \
    $(OUTDIR_SLASH)CustomVisitorCodeGenerator.$(O) \
    $(OUTDIR_SLASH)DummyCodeGenerator.$(O) \