Make.spec
author Jakub Nesveda <jakubnesveda@seznam.cz>
Mon, 17 Mar 2014 23:45:05 +0100
changeset 512 a527e7f19b30
parent 510 a5f57fac79ee
child 513 13f1e84aa656
permissions -rw-r--r--
work in progress - remove duplicate code in code generation methods - CustomRefactoring class: CustomRefactoring - CustomContext class: CustomContext - CustomDummyTests class: CustomDummyTests - TestClass class: TestClass added: #inst: - CustomCodeGeneratorOrRefactoring class: CustomCodeGeneratorOrRefactoring - CustomPerspective class: CustomPerspective - CustomManager class: CustomManager - jn_refactoring_custom class: jn_refactoring_custom comment/format in: #excludedFromPreRequisites #extensionMethodNames #referencedPreRequisites changed: #classNamesAndAttributes #mandatoryPreRequisites - CustomFooBarBazCodeGenerator class: CustomFooBarBazCodeGenerator - CustomCodeGenerator class: CustomCodeGenerator class definition added: #addMethod #initialize - MockCustomContext class: MockCustomContext - CustomSourceCodeBuilder class: CustomSourceCodeBuilder added: #buildedMethod #method comment/format in: #source: - CustomVisitorCodeGeneratorTests class: CustomVisitorCodeGeneratorTests changed: #test_dummy - CustomMenuBuilder class: CustomMenuBuilder - CustomAccessMethodsCodeGeneratorTests class: CustomAccessMethodsCodeGeneratorTests added: #test_dummy #test_getter_method_source_created - CustomVisitorCodeGenerator class: CustomVisitorCodeGenerator changed: #createAcceptVisitorMethod:in:withParameter: - CustomVisitorCodeGeneratorAcceptVisitor class: CustomVisitorCodeGeneratorAcceptVisitor - CustomAccessMethodsCodeGenerator class: CustomAccessMethodsCodeGenerator class definition added:9 methods - extensions ...

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: jn_refactoring_custom.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=jn
MODULE_DIR=refactoring_custom
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	CustomCodeGeneratorOrRefactoring \
	CustomContext \
	CustomManager \
	CustomMenuBuilder \
	CustomPerspective \
	CustomSourceCodeBuilder \
	TestClass \
	jn_refactoring_custom \
	CustomCodeGenerator \
	CustomRefactoring \
	MockCustomContext \
	CustomAccessMethodsCodeGenerator \
	CustomFooBarBazCodeGenerator \
	CustomVisitorCodeGenerator \
	CustomVisitorCodeGeneratorAcceptVisitor \




COMMON_OBJS= \
    $(OUTDIR_SLASH)CustomCodeGeneratorOrRefactoring.$(O) \
    $(OUTDIR_SLASH)CustomContext.$(O) \
    $(OUTDIR_SLASH)CustomManager.$(O) \
    $(OUTDIR_SLASH)CustomMenuBuilder.$(O) \
    $(OUTDIR_SLASH)CustomPerspective.$(O) \
    $(OUTDIR_SLASH)CustomSourceCodeBuilder.$(O) \
    $(OUTDIR_SLASH)TestClass.$(O) \
    $(OUTDIR_SLASH)jn_refactoring_custom.$(O) \
    $(OUTDIR_SLASH)CustomCodeGenerator.$(O) \
    $(OUTDIR_SLASH)CustomRefactoring.$(O) \
    $(OUTDIR_SLASH)MockCustomContext.$(O) \
    $(OUTDIR_SLASH)CustomAccessMethodsCodeGenerator.$(O) \
    $(OUTDIR_SLASH)CustomFooBarBazCodeGenerator.$(O) \
    $(OUTDIR_SLASH)CustomVisitorCodeGenerator.$(O) \
    $(OUTDIR_SLASH)CustomVisitorCodeGeneratorAcceptVisitor.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \