Make.spec
branchjv
changeset 664 e31b2e7b658d
parent 588 0d69293eb505
--- a/Make.spec	Wed Aug 31 17:38:43 2016 +0100
+++ b/Make.spec	Sat Sep 03 09:08:25 2016 +0100
@@ -1,4 +1,4 @@
-# $Header: /cvs/stx/stx/goodies/sunit/Make.spec,v 1.24 2014-03-23 21:08:48 cg Exp $
+# $Header$
 #
 # DO NOT EDIT
 # automagically generated from the projectDefinition: stx_goodies_sunit.
@@ -22,7 +22,7 @@
 #                (if removed, they will be created as common
 #  -Pxxx       : defines the package
 #  -Zxxx       : a prefix for variables within the classLib
-#  -Dxxx       : defines passed to to CC for inline C-code
+#  -Dxxx       : defines passed to CC for inline C-code
 #  -Ixxx       : include path passed to CC for inline C-code
 #  +optspace   : optimized for space
 #  +optspace2  : optimized more for space
@@ -42,6 +42,7 @@
 #  -warnNonStandard : no warnings about ST/X extensions
 #  -warnEOLComments : no warnings about EOL comment extension
 #  -warnPrivacy     : no warnings about privateClass extension
+#  -warnUnused      : no warnings about unused variables
 #
 # ********** OPTIONAL: MODIFY the next line(s) ***
 # STCWARNINGS=-warn
@@ -50,9 +51,12 @@
 STCWARNINGS=-warnNonStandard
 
 COMMON_CLASSES= \
+	MetricsReporter \
 	SUnitDelay \
 	SUnitNameResolver \
 	TestAsserter \
+	TestCaseOutcome \
+	TestCoverageReporter \
 	TestFailure \
 	TestResult \
 	TestResultReporter \
@@ -62,22 +66,22 @@
 	stx_goodies_sunit \
 	ResumableTestFailure \
 	TestCase \
-	TestCaseWithArguments \
 	TestResource \
-	TestCaseOutcome \
 	TestResultStX \
+	TestSkipped \
+	TestCaseWithArguments \
 	TestResultForRunWithDebug \
-	TestCoverageReporter \
-	MetricsReporter \
-	TestSkipped \
 
 
 
 
 COMMON_OBJS= \
+    $(OUTDIR_SLASH)MetricsReporter.$(O) \
     $(OUTDIR_SLASH)SUnitDelay.$(O) \
     $(OUTDIR_SLASH)SUnitNameResolver.$(O) \
     $(OUTDIR_SLASH)TestAsserter.$(O) \
+    $(OUTDIR_SLASH)TestCaseOutcome.$(O) \
+    $(OUTDIR_SLASH)TestCoverageReporter.$(O) \
     $(OUTDIR_SLASH)TestFailure.$(O) \
     $(OUTDIR_SLASH)TestResult.$(O) \
     $(OUTDIR_SLASH)TestResultReporter.$(O) \
@@ -87,14 +91,11 @@
     $(OUTDIR_SLASH)stx_goodies_sunit.$(O) \
     $(OUTDIR_SLASH)ResumableTestFailure.$(O) \
     $(OUTDIR_SLASH)TestCase.$(O) \
-    $(OUTDIR_SLASH)TestCaseWithArguments.$(O) \
     $(OUTDIR_SLASH)TestResource.$(O) \
-    $(OUTDIR_SLASH)TestCaseOutcome.$(O) \
     $(OUTDIR_SLASH)TestResultStX.$(O) \
+    $(OUTDIR_SLASH)TestSkipped.$(O) \
+    $(OUTDIR_SLASH)TestCaseWithArguments.$(O) \
     $(OUTDIR_SLASH)TestResultForRunWithDebug.$(O) \
-    $(OUTDIR_SLASH)TestCoverageReporter.$(O) \
-    $(OUTDIR_SLASH)MetricsReporter.$(O) \
-    $(OUTDIR_SLASH)TestSkipped.$(O) \
     $(OUTDIR_SLASH)extensions.$(O) \