Make.spec
changeset 142 f68ea471214b
parent 134 d66d5a9e1993
child 151 4def7d87b08f
--- a/Make.spec	Thu Sep 21 10:46:52 2006 +0200
+++ b/Make.spec	Thu Sep 21 10:46:53 2006 +0200
@@ -1,35 +1,65 @@
-# $Header: /cvs/stx/stx/goodies/sunit/Make.spec,v 1.1 2006-08-18 14:37:49 cg Exp $
+# $Header: /cvs/stx/stx/goodies/sunit/Make.spec,v 1.2 2006-09-21 08:46:53 stefan Exp $
+#
+# DO NOT EDIT 
+# automagically generated from the projectDefinition: stx_goodies_sunit.
 #
-# --- Automatically created Make.spec
+# Warning: once you modify this file, do not rerun
+# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
+#
+# This file contains specifications which are common to all platforms.
+#
 
-TOP=../..
-SUBDIRS=
-
-
-# ***************************** modify the next line ***
-LIBNAME=libstx_goodies_sunit
+# Do NOT CHANGE THESE DEFINITIONS
+# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
+#  to find the source code of a class and to find the library for a package)
+MODULE=stx
+MODULE_DIR=goodies/sunit
+PACKAGE=$(MODULE):$(MODULE_DIR)
 
 
-EXTRA_TARGTES=
+# Argument(s) to the stc compiler (stc --usage).
+#  -H.         : create header files locally
+#                (if removed, they will be created as common
+#  -Pxxx       : defines the package
+#  -Zxxx       : a prefix for variables within the classLib
+#  -Dxxx       : defines passed to to CC for inline C-code
+#  -Ixxx       : include path passed to CC for inline C-code
+#  +optspace   : optimized for space
+#  +optspace2  : optimized more for space
+#  +optspace3  : optimized even more for space
+#  +optinline  : generate inline code for some ST constructs
+#  +inlineNew  : additionally inline new
+#  +inlineMath : additionally inline some floatPnt math stuff
+#
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
+# STCLOCALOPTIMIZATIONS=+optspace3
+STCLOCALOPTIMIZATIONS=+optspace3
+
 
-OBJS=  \
-    ExampleSetTest.$(O) \
-    ExampleTestResource.$(O) \
-    ResumableTestFailure.$(O) \
-    ResumableTestFailureTestCase.$(O) \
-    SUnitDelay.$(O) \
-    SUnitNameResolver.$(O) \
-    SUnitTest.$(O) \
-    SimpleTestResourceTestCase.$(O) \
-    TestCase.$(O) \
-    TestFailure.$(O) \
-    TestResource.$(O) \
-    TestResult.$(O) \
-    TestRunner.$(O) \
-    TestSuite.$(O) \
-    TestSuitesCompoundScriptTest.$(O) \
-    TestSuitesHierarchyScriptTest.$(O) \
-    TestSuitesScriptTest.$(O) \
-    TestSuitesScripter.$(O) \
-    extensions.$(O)
+# Argument(s) to the stc compiler (stc --usage).
+#  -warn            : no warnings
+#  -warnNonStandard : no warnings about ST/X extensions
+#  -warnEOLComments : no warnings about EOL comment extension
+#  -warnPrivacy     : no warnings about privateClass extension
+#
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCWARNINGS=-warn
+# STCWARNINGS=-warnNonStandard
+# STCWARNINGS=-warnEOLComments
+STCWARNINGS=-warnNonStandard
 
+COMMON_OBJS= \
+    $(OUTDIR)TestFailure.$(O) \
+    $(OUTDIR)SUnitDelay.$(O) \
+    $(OUTDIR)SUnitNameResolver.$(O) \
+    $(OUTDIR)TestCase.$(O) \
+    $(OUTDIR)ResumableTestFailure.$(O) \
+    $(OUTDIR)TestResource.$(O) \
+    $(OUTDIR)TestResult.$(O) \
+    $(OUTDIR)TestRunner.$(O) \
+    $(OUTDIR)TestSuite.$(O) \
+    $(OUTDIR)TestSuitesScripter.$(O) \
+    $(OUTDIR)stx_goodies_sunit.$(O) \
+
+