Make.spec
author vrany
Mon, 16 Jan 2012 21:46:11 +0100
changeset 439 c61cd2a45ee0
parent 422 22a9f6e18144
child 466 630061e17f86
permissions -rw-r--r--
initial checkin

# $Header: /cvs/stx/stx/goodies/sunit/Make.spec,v 1.18 2011-08-21 15:28:07 cg Exp $
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_goodies_sunit.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=goodies/sunit
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -H.         : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	SUnitDelay \
	SUnitNameResolver \
	TestAsserter \
	TestFailure \
	TestResult \
	TestRunner \
	TestSuite \
	TestSuitesScripter \
	stx_goodies_sunit \
	ResumableTestFailure \
	TestCase \
	TestCaseWithArguments \
	TestResource \
	TestCaseOutcome \
	TestResultStX \
	TestResultForRunWithDebug \




COMMON_OBJS= \
    $(OUTDIR)SUnitDelay.$(O) \
    $(OUTDIR)SUnitNameResolver.$(O) \
    $(OUTDIR)TestAsserter.$(O) \
    $(OUTDIR)TestFailure.$(O) \
    $(OUTDIR)TestResult.$(O) \
    $(OUTDIR)TestRunner.$(O) \
    $(OUTDIR)TestSuite.$(O) \
    $(OUTDIR)TestSuitesScripter.$(O) \
    $(OUTDIR)stx_goodies_sunit.$(O) \
    $(OUTDIR)ResumableTestFailure.$(O) \
    $(OUTDIR)TestCase.$(O) \
    $(OUTDIR)TestCaseWithArguments.$(O) \
    $(OUTDIR)TestResource.$(O) \
    $(OUTDIR)TestCaseOutcome.$(O) \
    $(OUTDIR)TestResultStX.$(O) \
    $(OUTDIR)TestResultForRunWithDebug.$(O) \
    $(OUTDIR)extensions.$(O) \