Make.spec
branchjv
changeset 17766 0acf634e6550
parent 17763 019bb9c842c5
child 17767 a4a32df3aa5e
--- a/Make.spec	Tue May 18 14:31:21 2010 +0100
+++ b/Make.spec	Thu May 20 14:35:23 2010 +0100
@@ -1,4 +1,4 @@
-# $Header: /cvs/stx/stx/libbasic/Make.spec,v 1.107 2010/04/27 08:10:27 stefan Exp $
+# $Header$
 #
 # DO NOT EDIT 
 # automagically generated from the projectDefinition: stx_libbasic.
@@ -58,7 +58,6 @@
 	Autoload \
 	Object \
 	ProtoObject \
-	AbstractDesktop \
 	AbstractOperatingSystem \
 	AbstractSourceFileReader \
 	Behavior \
@@ -66,8 +65,6 @@
 	CharacterEncoder \
 	ClassBuilder \
 	ClassCategoryReader \
-	CmdLineOption \
-	CmdLineParser \
 	Collection \
 	Context \
 	Continuation \
@@ -140,14 +137,11 @@
 	SequenceableCollection \
 	Set \
 	SmalltalkChunkFileSourceReader \
-	SmalltalkDesktop \
 	SmalltalkLanguage \
 	True \
-	UnixDesktop \
 	UnixFilename \
 	UserNotification \
 	WeakInterestConverter \
-	WindowsDesktop \
 	ActivityNotification \
 	ArrayedCollection \
 	Association \
@@ -191,7 +185,6 @@
 	UserInformation \
 	UserInterrupt \
 	Warning \
-	XDGDesktop \
 	YesToAllConfirmation \
 	stx_libbasic \
 	AbortAllOperationRequest \
@@ -200,13 +193,11 @@
 	BreakPointInterrupt \
 	CheapBlock \
 	Class \
-	CmdLineOptionError \
 	ClassBuildError \
 	DoubleArray \
 	ElementBoundsError \
 	FloatArray \
 	Fraction \
-	GNOMEDesktop \
 	IdentityDictionary \
 	InlineObjectClassDescription \
 	Integer \
@@ -342,6 +333,8 @@
 	Lookup \
 	OSProcess \
 	BuiltinLookup \
+	Annotation \
+	NamespaceAwareLookup \
 
 WIN32_CLASSES= \
 	Win32Process \
@@ -366,7 +359,6 @@
     $(OUTDIR)Autoload.$(O) \
     $(OUTDIR)Object.$(O) \
     $(OUTDIR)ProtoObject.$(O) \
-    $(OUTDIR)AbstractDesktop.$(O) \
     $(OUTDIR)AbstractOperatingSystem.$(O) \
     $(OUTDIR)AbstractSourceFileReader.$(O) \
     $(OUTDIR)Behavior.$(O) \
@@ -374,8 +366,6 @@
     $(OUTDIR)CharacterEncoder.$(O) \
     $(OUTDIR)ClassBuilder.$(O) \
     $(OUTDIR)ClassCategoryReader.$(O) \
-    $(OUTDIR)CmdLineOption.$(O) \
-    $(OUTDIR)CmdLineParser.$(O) \
     $(OUTDIR)Collection.$(O) \
     $(OUTDIR)Context.$(O) \
     $(OUTDIR)Continuation.$(O) \
@@ -448,14 +438,11 @@
     $(OUTDIR)SequenceableCollection.$(O) \
     $(OUTDIR)Set.$(O) \
     $(OUTDIR)SmalltalkChunkFileSourceReader.$(O) \
-    $(OUTDIR)SmalltalkDesktop.$(O) \
     $(OUTDIR)SmalltalkLanguage.$(O) \
     $(OUTDIR)True.$(O) \
-    $(OUTDIR)UnixDesktop.$(O) \
     $(OUTDIR)UnixFilename.$(O) \
     $(OUTDIR)UserNotification.$(O) \
     $(OUTDIR)WeakInterestConverter.$(O) \
-    $(OUTDIR)WindowsDesktop.$(O) \
     $(OUTDIR)ActivityNotification.$(O) \
     $(OUTDIR)ArrayedCollection.$(O) \
     $(OUTDIR)Association.$(O) \
@@ -499,7 +486,6 @@
     $(OUTDIR)UserInformation.$(O) \
     $(OUTDIR)UserInterrupt.$(O) \
     $(OUTDIR)Warning.$(O) \
-    $(OUTDIR)XDGDesktop.$(O) \
     $(OUTDIR)YesToAllConfirmation.$(O) \
     $(OUTDIR)stx_libbasic.$(O) \
     $(OUTDIR)AbortAllOperationRequest.$(O) \
@@ -508,13 +494,11 @@
     $(OUTDIR)BreakPointInterrupt.$(O) \
     $(OUTDIR)CheapBlock.$(O) \
     $(OUTDIR)Class.$(O) \
-    $(OUTDIR)CmdLineOptionError.$(O) \
     $(OUTDIR)ClassBuildError.$(O) \
     $(OUTDIR)DoubleArray.$(O) \
     $(OUTDIR)ElementBoundsError.$(O) \
     $(OUTDIR)FloatArray.$(O) \
     $(OUTDIR)Fraction.$(O) \
-    $(OUTDIR)GNOMEDesktop.$(O) \
     $(OUTDIR)IdentityDictionary.$(O) \
     $(OUTDIR)InlineObjectClassDescription.$(O) \
     $(OUTDIR)Integer.$(O) \
@@ -650,6 +634,8 @@
     $(OUTDIR)Lookup.$(O) \
     $(OUTDIR)OSProcess.$(O) \
     $(OUTDIR)BuiltinLookup.$(O) \
+    $(OUTDIR)Annotation.$(O) \
+    $(OUTDIR)NamespaceAwareLookup.$(O) \
 
 WIN32_OBJS= \
     $(OUTDIR)Win32Process.$(O) \
@@ -664,4 +650,3 @@
 
 
 
-