Make.spec
branchjv
changeset 17928 8e8dad2e6269
parent 17921 4069fe8e9039
child 17940 985e22966acb
--- a/Make.spec	Tue Mar 13 15:46:50 2012 +0000
+++ b/Make.spec	Wed Mar 21 17:45:38 2012 +0000
@@ -1,7 +1,7 @@
-# $Header: /cvs/stx/stx/libbasic/Make.spec,v 1.126 2012/01/24 16:51:55 cg Exp $
+# $Header: /cvs/stx/stx/libbasic/Make.spec,v 1.129 2012/03/01 15:58:53 stefan Exp $
 #
 # DO NOT EDIT
-# automagically generated from the projectDefinition: stx_libbasic at 2012-01-24 17:16:17.029.
+# automagically generated from the projectDefinition: stx_libbasic at 2012-03-01 13:51:23.335.
 #
 # Warning: once you modify this file, do not rerun
 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
@@ -18,7 +18,7 @@
 
 
 # Argument(s) to the stc compiler (stc --usage).
-#  --headerDir=. : create header files locally
+#  -headerDir=. : create header files locally
 #                (if removed, they will be created as common
 #  -Pxxx       : defines the package
 #  -Zxxx       : a prefix for variables within the classLib
@@ -49,11 +49,6 @@
 # STCWARNINGS=-warnEOLComments
 STCWARNINGS=-warnNonStandard
 
-UNIX_CLASSES= \
-	UnixFileDescriptorHandle \
-	UnixFileHandle \
-	UnixOperatingSystem \
-
 COMMON_CLASSES= \
 	Autoload \
 	Object \
@@ -76,14 +71,12 @@
 	Filename \
 	GenericException \
 	Geometric \
-	Magnitude \
 	InlineObject \
 	InterestConverter \
 	Link \
 	Lookup \
-	ArithmeticValue \
+	Magnitude \
 	Message \
-	Number \
 	MiniDebugger \
 	MiniInspector \
 	NameSpace \
@@ -102,8 +95,6 @@
 	SharedPool \
 	Signal \
 	Smalltalk \
-	MetaNumber \
-	SomeNumber \
 	StandaloneStartup \
 	Stream \
 	SystemChangeNotifier \
@@ -112,6 +103,7 @@
 	Visitor \
 	AbstractTime \
 	ApplicationDefinition \
+	ArithmeticValue \
 	AspectVisitor \
 	AutoDeletedFilename \
 	Bag \
@@ -152,7 +144,7 @@
 	UnixFilename \
 	WeakInterestConverter \
 	ArrayedCollection \
-	AbstractNumberVector \
+	UninterpretedBytes \
 	Association \
 	Block \
 	CharacterEncoderImplementations::ASCII \
@@ -162,7 +154,6 @@
 	CharacterEncoderImplementations::ISO8859_2 \
 	CharacterEncoderImplementations::ISO8859_5 \
 	CharacterEncoderImplementations::ISO8859_7 \
-	CharacterEncoderImplementations::JIS0208_to_SJIS \
 	CharacterEncoderImplementations::MS_Ansi \
 	ClassDescription \
 	ControlRequest \
@@ -178,6 +169,9 @@
 	MD5Stream \
 	Method \
 	MethodDictionary \
+	Number \
+	MetaNumber \
+	SomeNumber \
 	Infinity \
 	OSFileHandle \
 	ObjectCoder \
@@ -203,7 +197,7 @@
 	CheapBlock \
 	Class \
 	ClassBuildError \
-	DoubleArray \
+	AbstractNumberVector \
 	ElementBoundsError \
 	FileDirectory \
 	FloatArray \
@@ -228,7 +222,7 @@
 	SortedCollection \
 	StringCollection \
 	TerminateProcessRequest \
-	UninterpretedBytes \
+	DoubleArray \
 	UserConfirmation \
 	UserInformation \
 	VMInternalError \
@@ -352,6 +346,11 @@
 	MiniLogger \
 	PolymorphicInlineCache \
 
+UNIX_CLASSES= \
+	UnixFileDescriptorHandle \
+	UnixFileHandle \
+	UnixOperatingSystem \
+
 WIN32_CLASSES= \
 	Win32Process \
 	PCFilename \
@@ -366,11 +365,6 @@
 
 
 
-UNIX_OBJS= \
-    $(OUTDIR)UnixFileDescriptorHandle.$(O) \
-    $(OUTDIR)UnixFileHandle.$(O) \
-    $(OUTDIR)UnixOperatingSystem.$(O) \
-
 COMMON_OBJS= \
     $(OUTDIR)Autoload.$(O) \
     $(OUTDIR)Object.$(O) \
@@ -393,14 +387,12 @@
     $(OUTDIR)Filename.$(O) \
     $(OUTDIR)GenericException.$(O) \
     $(OUTDIR)Geometric.$(O) \
-    $(OUTDIR)Magnitude.$(O) \
     $(OUTDIR)InlineObject.$(O) \
     $(OUTDIR)InterestConverter.$(O) \
     $(OUTDIR)Link.$(O) \
     $(OUTDIR)Lookup.$(O) \
-    $(OUTDIR)ArithmeticValue.$(O) \
+    $(OUTDIR)Magnitude.$(O) \
     $(OUTDIR)Message.$(O) \
-    $(OUTDIR)Number.$(O) \
     $(OUTDIR)MiniDebugger.$(O) \
     $(OUTDIR)MiniInspector.$(O) \
     $(OUTDIR)NameSpace.$(O) \
@@ -419,8 +411,6 @@
     $(OUTDIR)SharedPool.$(O) \
     $(OUTDIR)Signal.$(O) \
     $(OUTDIR)Smalltalk.$(O) \
-    $(OUTDIR)MetaNumber.$(O) \
-    $(OUTDIR)SomeNumber.$(O) \
     $(OUTDIR)StandaloneStartup.$(O) \
     $(OUTDIR)Stream.$(O) \
     $(OUTDIR)SystemChangeNotifier.$(O) \
@@ -429,6 +419,7 @@
     $(OUTDIR)Visitor.$(O) \
     $(OUTDIR)AbstractTime.$(O) \
     $(OUTDIR)ApplicationDefinition.$(O) \
+    $(OUTDIR)ArithmeticValue.$(O) \
     $(OUTDIR)AspectVisitor.$(O) \
     $(OUTDIR)AutoDeletedFilename.$(O) \
     $(OUTDIR)Bag.$(O) \
@@ -469,7 +460,7 @@
     $(OUTDIR)UnixFilename.$(O) \
     $(OUTDIR)WeakInterestConverter.$(O) \
     $(OUTDIR)ArrayedCollection.$(O) \
-    $(OUTDIR)AbstractNumberVector.$(O) \
+    $(OUTDIR)UninterpretedBytes.$(O) \
     $(OUTDIR)Association.$(O) \
     $(OUTDIR)Block.$(O) \
     $(OUTDIR)CharacterEncoderImplementations__ASCII.$(O) \
@@ -479,7 +470,6 @@
     $(OUTDIR)CharacterEncoderImplementations__ISO8859_2.$(O) \
     $(OUTDIR)CharacterEncoderImplementations__ISO8859_5.$(O) \
     $(OUTDIR)CharacterEncoderImplementations__ISO8859_7.$(O) \
-    $(OUTDIR)CharacterEncoderImplementations__JIS0208_to_SJIS.$(O) \
     $(OUTDIR)CharacterEncoderImplementations__MS_Ansi.$(O) \
     $(OUTDIR)ClassDescription.$(O) \
     $(OUTDIR)ControlRequest.$(O) \
@@ -495,6 +485,9 @@
     $(OUTDIR)MD5Stream.$(O) \
     $(OUTDIR)Method.$(O) \
     $(OUTDIR)MethodDictionary.$(O) \
+    $(OUTDIR)Number.$(O) \
+    $(OUTDIR)MetaNumber.$(O) \
+    $(OUTDIR)SomeNumber.$(O) \
     $(OUTDIR)Infinity.$(O) \
     $(OUTDIR)OSFileHandle.$(O) \
     $(OUTDIR)ObjectCoder.$(O) \
@@ -520,7 +513,7 @@
     $(OUTDIR)CheapBlock.$(O) \
     $(OUTDIR)Class.$(O) \
     $(OUTDIR)ClassBuildError.$(O) \
-    $(OUTDIR)DoubleArray.$(O) \
+    $(OUTDIR)AbstractNumberVector.$(O) \
     $(OUTDIR)ElementBoundsError.$(O) \
     $(OUTDIR)FileDirectory.$(O) \
     $(OUTDIR)FloatArray.$(O) \
@@ -545,7 +538,7 @@
     $(OUTDIR)SortedCollection.$(O) \
     $(OUTDIR)StringCollection.$(O) \
     $(OUTDIR)TerminateProcessRequest.$(O) \
-    $(OUTDIR)UninterpretedBytes.$(O) \
+    $(OUTDIR)DoubleArray.$(O) \
     $(OUTDIR)UserConfirmation.$(O) \
     $(OUTDIR)UserInformation.$(O) \
     $(OUTDIR)VMInternalError.$(O) \
@@ -669,6 +662,11 @@
     $(OUTDIR)MiniLogger.$(O) \
     $(OUTDIR)PolymorphicInlineCache.$(O) \
 
+UNIX_OBJS= \
+	$(OUTDIR)UnixFileDescriptorHandle.$(O) \
+	$(OUTDIR)UnixFileHandle.$(O) \
+	$(OUTDIR)UnixOperatingSystem.$(O) \
+
 WIN32_OBJS= \
     $(OUTDIR)Win32Process.$(O) \
     $(OUTDIR)PCFilename.$(O) \
@@ -680,3 +678,5 @@
     $(OUTDIR)Win32Constants.$(O) \
     $(OUTDIR)Win32OperatingSystem.$(O) \
 
+
+