Make.spec
branchjv
changeset 18120 e3a375d5f6a8
parent 18110 b0740d62ff1e
parent 17501 fb3795dfe1cb
child 18555 7cc0ec139c8d
--- a/Make.spec	Tue Feb 04 21:09:59 2014 +0100
+++ b/Make.spec	Wed Apr 01 10:20:10 2015 +0100
@@ -1,4 +1,4 @@
-# $Header$
+# $Header: /cvs/stx/stx/libbasic/Make.spec,v 1.173 2015-02-18 18:14:41 cg Exp $
 #
 # DO NOT EDIT
 # automagically generated from the projectDefinition: stx_libbasic.
@@ -42,23 +42,13 @@
 #  -warnNonStandard : no warnings about ST/X extensions
 #  -warnEOLComments : no warnings about EOL comment extension
 #  -warnPrivacy     : no warnings about privateClass extension
+#  -warnUnused      : no warnings about unused variables
 #
 # ********** OPTIONAL: MODIFY the next line(s) ***
 # STCWARNINGS=-warn
 # STCWARNINGS=-warnNonStandard
 # STCWARNINGS=-warnEOLComments
-STCWARNINGS=-warnNonStandard
-
-VMS_CLASSES= \
-	OpenVMSFileHandle \
-	OpenVMSFilename \
-	OpenVMSOperatingSystem \
-
-UNIX_CLASSES= \
-	UnixFileDescriptorHandle \
-	UnixFileHandle \
-	UnixOperatingSystem \
-	OSXOperatingSystem \
+STCWARNINGS=-warnNonStandard -warnUnused
 
 COMMON_CLASSES= \
 	Autoload \
@@ -72,6 +62,8 @@
 	CharacterEncoder \
 	ClassBuilder \
 	ClassCategoryReader \
+	CmdLineOption \
+	CmdLineParser \
 	Collection \
 	ConfigurableFeatures \
 	Context \
@@ -134,9 +126,11 @@
 	Exception \
 	ExternalFunction \
 	False \
+	FolderForProjectsDefinition \
 	HandleRegistry \
 	HashStream \
 	InlineObjectPrototype \
+	JavaPackage \
 	KeyedCollection \
 	LibraryDefinition \
 	LookupKey \
@@ -180,6 +174,7 @@
 	CharacterEncoderImplementations::ISO8859_7 \
 	CharacterEncoderImplementations::ISO8859_8 \
 	CharacterEncoderImplementations::KOI8_R \
+	CharacterEncoderImplementations::MAC_Roman \
 	CharacterEncoderImplementations::MS_Ansi \
 	CharacterEncoderImplementations::MS_Arabic \
 	CharacterEncoderImplementations::MS_Baltic \
@@ -204,6 +199,7 @@
 	MD5Stream \
 	Method \
 	MethodDictionary \
+	NaiveRomanNumberFormatNotification \
 	Number \
 	OSFileHandle \
 	ObjectCoder \
@@ -231,12 +227,14 @@
 	Array \
 	BreakPointInterrupt \
 	CharacterEncoderImplementations::ISO10646_to_UTF16LE \
+	CharacterEncoderImplementations::ISO10646_to_UTF8_MAC \
+	CharacterEncoderImplementations::ISO10646_to_XMLUTF8 \
 	CharacterEncoderImplementations::ISO8859_9 \
 	CharacterEncoderImplementations::KOI8_U \
 	CheapBlock \
 	ClassBuildError \
+	CmdLineOptionError \
 	ElementBoundsError \
-	FileDirectory \
 	Fraction \
 	GetOpt \
 	IdentityDictionary \
@@ -245,6 +243,7 @@
 	Interval \
 	IsDebuggingQuery \
 	LimitedPrecisionReal \
+	LoadInProgressQuery \
 	MeasurementValue \
 	MetaNumber \
 	Metaclass \
@@ -264,7 +263,9 @@
 	SnapshotError \
 	SortedCollection \
 	StringCollection \
+	TZTimestamp \
 	TerminateProcessRequest \
+	TimeDuration \
 	UninterpretedBytes \
 	UserInformation \
 	UtcTimestamp \
@@ -286,6 +287,8 @@
 	CharacterArray \
 	CharacterWriteStream \
 	Class \
+	ClassBuildWarning \
+	ClassLoadInProgressQuery \
 	ContextError \
 	ConversionError \
 	DeepCopyError \
@@ -310,6 +313,8 @@
 	OsNoResourcesError \
 	OsNotification \
 	OsTransferFaultError \
+	PackageLoadError \
+	PackageLoadInProgressQuery \
 	PrivateMetaclass \
 	ProceedError \
 	ReadWriteStream \
@@ -325,6 +330,7 @@
 	UserPreferences \
 	VarArgCheapBlock \
 	WeakIdentityDictionary \
+	WeakValueIdentityDictionary \
 	ArgumentError \
 	CannotResumeError \
 	CannotReturnError \
@@ -347,7 +353,9 @@
 	MallocFailure \
 	MethodNotAppropriateError \
 	NonBooleanReceiverError \
+	NumberConversionError \
 	OpenError \
+	PackageNotFoundError \
 	PositionError \
 	PositionOutOfBoundsError \
 	PrimitiveFailure \
@@ -377,7 +385,10 @@
 	NoByteCodeError \
 	NonIntegerIndexError \
 	NonPositionableExternalStream \
+	NumberFormatError \
 	OverflowError \
+	PTYOpenError \
+	PackageNotCompatibleError \
 	SubscriptOutOfBoundsError \
 	Symbol \
 	UnderflowError \
@@ -388,6 +399,7 @@
 	DirectoryStream \
 	InvalidEncodingError \
 	PipeStream \
+	RomanNumberFormatError \
 
 WIN32_CLASSES= \
 	PCFilename \
@@ -397,19 +409,19 @@
 	Win32OperatingSystem \
 	Win32Process \
 
+UNIX_CLASSES= \
+	UnixFileDescriptorHandle \
+	UnixFileHandle \
+	UnixOperatingSystem \
+	OSXOperatingSystem \
+
+VMS_CLASSES= \
+	OpenVMSFileHandle \
+	OpenVMSFilename \
+	OpenVMSOperatingSystem \
 
 
 
-VMS_OBJS= \
-    $(OUTDIR_SLASH)OpenVMSFileHandle.$(O) \
-    $(OUTDIR_SLASH)OpenVMSFilename.$(O) \
-    $(OUTDIR_SLASH)OpenVMSOperatingSystem.$(O) \
-
-UNIX_OBJS= \
-    $(OUTDIR_SLASH)UnixFileDescriptorHandle.$(O) \
-    $(OUTDIR_SLASH)UnixFileHandle.$(O) \
-    $(OUTDIR_SLASH)UnixOperatingSystem.$(O) \
-    $(OUTDIR_SLASH)OSXOperatingSystem.$(O) \
 
 COMMON_OBJS= \
     $(OUTDIR_SLASH)Autoload.$(O) \
@@ -423,6 +435,8 @@
     $(OUTDIR_SLASH)CharacterEncoder.$(O) \
     $(OUTDIR_SLASH)ClassBuilder.$(O) \
     $(OUTDIR_SLASH)ClassCategoryReader.$(O) \
+    $(OUTDIR_SLASH)CmdLineOption.$(O) \
+    $(OUTDIR_SLASH)CmdLineParser.$(O) \
     $(OUTDIR_SLASH)Collection.$(O) \
     $(OUTDIR_SLASH)ConfigurableFeatures.$(O) \
     $(OUTDIR_SLASH)Context.$(O) \
@@ -485,9 +499,11 @@
     $(OUTDIR_SLASH)Exception.$(O) \
     $(OUTDIR_SLASH)ExternalFunction.$(O) \
     $(OUTDIR_SLASH)False.$(O) \
+    $(OUTDIR_SLASH)FolderForProjectsDefinition.$(O) \
     $(OUTDIR_SLASH)HandleRegistry.$(O) \
     $(OUTDIR_SLASH)HashStream.$(O) \
     $(OUTDIR_SLASH)InlineObjectPrototype.$(O) \
+    $(OUTDIR_SLASH)JavaPackage.$(O) \
     $(OUTDIR_SLASH)KeyedCollection.$(O) \
     $(OUTDIR_SLASH)LibraryDefinition.$(O) \
     $(OUTDIR_SLASH)LookupKey.$(O) \
@@ -531,6 +547,7 @@
     $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_7.$(O) \
     $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_8.$(O) \
     $(OUTDIR_SLASH)CharacterEncoderImplementations__KOI8_R.$(O) \
+    $(OUTDIR_SLASH)CharacterEncoderImplementations__MAC_Roman.$(O) \
     $(OUTDIR_SLASH)CharacterEncoderImplementations__MS_Ansi.$(O) \
     $(OUTDIR_SLASH)CharacterEncoderImplementations__MS_Arabic.$(O) \
     $(OUTDIR_SLASH)CharacterEncoderImplementations__MS_Baltic.$(O) \
@@ -555,6 +572,7 @@
     $(OUTDIR_SLASH)MD5Stream.$(O) \
     $(OUTDIR_SLASH)Method.$(O) \
     $(OUTDIR_SLASH)MethodDictionary.$(O) \
+    $(OUTDIR_SLASH)NaiveRomanNumberFormatNotification.$(O) \
     $(OUTDIR_SLASH)Number.$(O) \
     $(OUTDIR_SLASH)OSFileHandle.$(O) \
     $(OUTDIR_SLASH)ObjectCoder.$(O) \
@@ -582,12 +600,14 @@
     $(OUTDIR_SLASH)Array.$(O) \
     $(OUTDIR_SLASH)BreakPointInterrupt.$(O) \
     $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO10646_to_UTF16LE.$(O) \
+    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO10646_to_UTF8_MAC.$(O) \
+    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO10646_to_XMLUTF8.$(O) \
     $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_9.$(O) \
     $(OUTDIR_SLASH)CharacterEncoderImplementations__KOI8_U.$(O) \
     $(OUTDIR_SLASH)CheapBlock.$(O) \
     $(OUTDIR_SLASH)ClassBuildError.$(O) \
+    $(OUTDIR_SLASH)CmdLineOptionError.$(O) \
     $(OUTDIR_SLASH)ElementBoundsError.$(O) \
-    $(OUTDIR_SLASH)FileDirectory.$(O) \
     $(OUTDIR_SLASH)Fraction.$(O) \
     $(OUTDIR_SLASH)GetOpt.$(O) \
     $(OUTDIR_SLASH)IdentityDictionary.$(O) \
@@ -596,6 +616,7 @@
     $(OUTDIR_SLASH)Interval.$(O) \
     $(OUTDIR_SLASH)IsDebuggingQuery.$(O) \
     $(OUTDIR_SLASH)LimitedPrecisionReal.$(O) \
+    $(OUTDIR_SLASH)LoadInProgressQuery.$(O) \
     $(OUTDIR_SLASH)MeasurementValue.$(O) \
     $(OUTDIR_SLASH)MetaNumber.$(O) \
     $(OUTDIR_SLASH)Metaclass.$(O) \
@@ -615,7 +636,9 @@
     $(OUTDIR_SLASH)SnapshotError.$(O) \
     $(OUTDIR_SLASH)SortedCollection.$(O) \
     $(OUTDIR_SLASH)StringCollection.$(O) \
+    $(OUTDIR_SLASH)TZTimestamp.$(O) \
     $(OUTDIR_SLASH)TerminateProcessRequest.$(O) \
+    $(OUTDIR_SLASH)TimeDuration.$(O) \
     $(OUTDIR_SLASH)UninterpretedBytes.$(O) \
     $(OUTDIR_SLASH)UserInformation.$(O) \
     $(OUTDIR_SLASH)UtcTimestamp.$(O) \
@@ -637,6 +660,8 @@
     $(OUTDIR_SLASH)CharacterArray.$(O) \
     $(OUTDIR_SLASH)CharacterWriteStream.$(O) \
     $(OUTDIR_SLASH)Class.$(O) \
+    $(OUTDIR_SLASH)ClassBuildWarning.$(O) \
+    $(OUTDIR_SLASH)ClassLoadInProgressQuery.$(O) \
     $(OUTDIR_SLASH)ContextError.$(O) \
     $(OUTDIR_SLASH)ConversionError.$(O) \
     $(OUTDIR_SLASH)DeepCopyError.$(O) \
@@ -661,6 +686,8 @@
     $(OUTDIR_SLASH)OsNoResourcesError.$(O) \
     $(OUTDIR_SLASH)OsNotification.$(O) \
     $(OUTDIR_SLASH)OsTransferFaultError.$(O) \
+    $(OUTDIR_SLASH)PackageLoadError.$(O) \
+    $(OUTDIR_SLASH)PackageLoadInProgressQuery.$(O) \
     $(OUTDIR_SLASH)PrivateMetaclass.$(O) \
     $(OUTDIR_SLASH)ProceedError.$(O) \
     $(OUTDIR_SLASH)ReadWriteStream.$(O) \
@@ -676,6 +703,7 @@
     $(OUTDIR_SLASH)UserPreferences.$(O) \
     $(OUTDIR_SLASH)VarArgCheapBlock.$(O) \
     $(OUTDIR_SLASH)WeakIdentityDictionary.$(O) \
+    $(OUTDIR_SLASH)WeakValueIdentityDictionary.$(O) \
     $(OUTDIR_SLASH)ArgumentError.$(O) \
     $(OUTDIR_SLASH)CannotResumeError.$(O) \
     $(OUTDIR_SLASH)CannotReturnError.$(O) \
@@ -698,7 +726,9 @@
     $(OUTDIR_SLASH)MallocFailure.$(O) \
     $(OUTDIR_SLASH)MethodNotAppropriateError.$(O) \
     $(OUTDIR_SLASH)NonBooleanReceiverError.$(O) \
+    $(OUTDIR_SLASH)NumberConversionError.$(O) \
     $(OUTDIR_SLASH)OpenError.$(O) \
+    $(OUTDIR_SLASH)PackageNotFoundError.$(O) \
     $(OUTDIR_SLASH)PositionError.$(O) \
     $(OUTDIR_SLASH)PositionOutOfBoundsError.$(O) \
     $(OUTDIR_SLASH)PrimitiveFailure.$(O) \
@@ -728,7 +758,10 @@
     $(OUTDIR_SLASH)NoByteCodeError.$(O) \
     $(OUTDIR_SLASH)NonIntegerIndexError.$(O) \
     $(OUTDIR_SLASH)NonPositionableExternalStream.$(O) \
+    $(OUTDIR_SLASH)NumberFormatError.$(O) \
     $(OUTDIR_SLASH)OverflowError.$(O) \
+    $(OUTDIR_SLASH)PTYOpenError.$(O) \
+    $(OUTDIR_SLASH)PackageNotCompatibleError.$(O) \
     $(OUTDIR_SLASH)SubscriptOutOfBoundsError.$(O) \
     $(OUTDIR_SLASH)Symbol.$(O) \
     $(OUTDIR_SLASH)UnderflowError.$(O) \
@@ -739,6 +772,7 @@
     $(OUTDIR_SLASH)DirectoryStream.$(O) \
     $(OUTDIR_SLASH)InvalidEncodingError.$(O) \
     $(OUTDIR_SLASH)PipeStream.$(O) \
+    $(OUTDIR_SLASH)RomanNumberFormatError.$(O) \
 
 WIN32_OBJS= \
     $(OUTDIR_SLASH)PCFilename.$(O) \
@@ -748,5 +782,16 @@
     $(OUTDIR_SLASH)Win32OperatingSystem.$(O) \
     $(OUTDIR_SLASH)Win32Process.$(O) \
 
+UNIX_OBJS= \
+    $(OUTDIR_SLASH)UnixFileDescriptorHandle.$(O) \
+    $(OUTDIR_SLASH)UnixFileHandle.$(O) \
+    $(OUTDIR_SLASH)UnixOperatingSystem.$(O) \
+    $(OUTDIR_SLASH)OSXOperatingSystem.$(O) \
+
+VMS_OBJS= \
+    $(OUTDIR_SLASH)OpenVMSFileHandle.$(O) \
+    $(OUTDIR_SLASH)OpenVMSFilename.$(O) \
+    $(OUTDIR_SLASH)OpenVMSOperatingSystem.$(O) \
 
 
+