Make.spec
author Claus Gittinger <cg@exept.de>
Tue, 09 Jul 2019 20:55:17 +0200
changeset 24417 03b083548da2
parent 23809 a8aebde37622
child 24526 cafea70df1c4
permissions -rw-r--r--
#REFACTORING by exept class: Smalltalk class changed: #recursiveInstallAutoloadedClassesFrom:rememberIn:maxLevels:noAutoload:packageTop:showSplashInLevels: Transcript showCR:(... bindWith:...) -> Transcript showCR:... with:...

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libbasic.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libbasic
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optinline +optinline2


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard -warnUnused

UNIX_CLASSES= \
	UnixSyslogInterface \
	UnixFileDescriptorHandle \
	UnixFileHandle \
	UnixOperatingSystem \
	OSXOperatingSystem \

VMS_CLASSES= \
	OpenVMSFileHandle \
	OpenVMSFilename \
	OpenVMSOperatingSystem \

COMMON_CLASSES= \
	Autoload \
	Object \
	ProtoObject \
	AbstractOperatingSystem \
	AbstractSourceFileReader \
	Annotation \
	Behavior \
	Boolean \
	CharacterEncoder \
	ClassBuilder \
	ClassCategoryReader \
	CmdLineOption \
	CmdLineParser \
	Collection \
	ConfigurableFeatures \
	Context \
	Continuation \
	Delay \
	EOFObject \
	ExecutableFunction \
	ExternalAddress \
	ExternalLibrary \
	Filename \
	GenericException \
	Geometric \
	InlineObject \
	InterestConverter \
	Link \
	Lookup \
	Magnitude \
	Message \
	MiniDebugger \
	MiniInspector \
	NameSpace \
	OSErrorHolder \
	OSProcess \
	ObjectMemory \
	PackageId \
	PolymorphicInlineCache \
	ProcessorScheduler \
	ProgrammingLanguage \
	Project \
	ProjectDefinition \
	ReadEvalPrintLoop \
	Semaphore \
	SharedPool \
	Signal \
	Smalltalk \
	StandaloneStartup \
	Stream \
	SystemChangeNotifier \
	TimePeriod \
	UndefinedObject \
	UserMessage \
	Visitor \
	VoidObject \
	AbstractTime \
	ApplicationDefinition \
	ArithmeticValue \
	AspectVisitor \
	AutoDeletedFilename \
	Bag \
	BlockContext \
	BuiltinLookup \
	Character \
	CharacterEncoderImplementations::FixedBytesEncoder \
	CharacterEncoderImplementations::ISO10646_1 \
	CharacterEncoderImplementations::VariableBytesEncoder \
	CompiledCode \
	ControlInterrupt \
	Date \
	EventSemaphore \
	Exception \
	ExternalFunction \
	False \
	FolderForProjectsDefinition \
	HashStream \
	JavaPackage \
	KeyedCollection \
	LibraryDefinition \
	LookupKey \
	MessageSend \
	MiniLogger \
	NamespaceAwareLookup \
	NoHandlerError \
	Notification \
	OSHandle \
	PeekableStream \
	Process \
	QuerySignal \
	Rectangle \
	RecursionLock \
	SequenceableCollection \
	Set \
	SmalltalkChunkFileSourceReader \
	SmalltalkLanguage \
	StandaloneStartupHeadless \
	True \
	UnixFilename \
	WeakInterestConverter \
	ArrayedCollection \
	Association \
	Block \
	CascadingNotification \
	CharacterEncoderImplementations::ISO10646_to_UTF16BE \
	CharacterEncoderImplementations::ISO10646_to_UTF8 \
	CharacterEncoderImplementations::MS_Ansi \
	CharacterEncoderImplementations::SingleByteEncoder \
	CharacterEncoderImplementations::TwoByteEncoder \
	ClassDescription \
	ControlRequest \
	Dictionary \
	EncodedStream \
	EndOfStreamNotification \
	Error \
	ExternalFunctionCallback \
	ExternalLibraryFunction \
	HaltInterrupt \
	IdentitySet \
	LinkedList \
	MD5Stream \
	Method \
	MethodDictionary \
	NaiveRomanNumberFormatNotification \
	Number \
	OSFileHandle \
	ObjectCoder \
	OrderedCollection \
	OrderedSet \
	Point \
	PositionableStream \
	ProceedingNotification \
	Query \
	ReadOnlySequenceableCollection \
	RecursiveStoreError \
	SHA1Stream \
	SmallDictionary \
	Time \
	TimeoutNotification \
	Timestamp \
	UnhandledAttributeInLiteralArrayErrorSignal \
	UserConfirmation \
	UserInterrupt \
	UserNotification \
	YesToAllConfirmation \
	stx_libbasic \
	AbortAllOperationRequest \
	AbortAllOperationWantedQuery \
	AbstractSourceFileWriter \
	ActivityNotification \
	Array \
	BitArray \
	BreakPointInterrupt \
	CharacterEncoderImplementations::ASCII \
	CharacterEncoderImplementations::CP437 \
	CharacterEncoderImplementations::EBCDIC \
	CharacterEncoderImplementations::ISO10646_to_UTF16LE \
	CharacterEncoderImplementations::ISO10646_to_UTF8_MAC \
	CharacterEncoderImplementations::ISO10646_to_XMLUTF8 \
	CharacterEncoderImplementations::ISO8859_1 \
	CharacterEncoderImplementations::ISO8859_10 \
	CharacterEncoderImplementations::ISO8859_11 \
	CharacterEncoderImplementations::ISO8859_13 \
	CharacterEncoderImplementations::ISO8859_14 \
	CharacterEncoderImplementations::ISO8859_15 \
	CharacterEncoderImplementations::ISO8859_16 \
	CharacterEncoderImplementations::ISO8859_2 \
	CharacterEncoderImplementations::ISO8859_3 \
	CharacterEncoderImplementations::ISO8859_4 \
	CharacterEncoderImplementations::ISO8859_5 \
	CharacterEncoderImplementations::ISO8859_6 \
	CharacterEncoderImplementations::ISO8859_7 \
	CharacterEncoderImplementations::ISO8859_8 \
	CharacterEncoderImplementations::KOI8_R \
	CharacterEncoderImplementations::MAC_Roman \
	CharacterEncoderImplementations::MS_Arabic \
	CharacterEncoderImplementations::MS_Baltic \
	CharacterEncoderImplementations::MS_CP1252 \
	CharacterEncoderImplementations::MS_Cyrillic \
	CharacterEncoderImplementations::MS_EastEuropean \
	CharacterEncoderImplementations::MS_Greek \
	CharacterEncoderImplementations::MS_Hebrew \
	CharacterEncoderImplementations::MS_Symbol \
	CharacterEncoderImplementations::MS_Turkish \
	CheapBlock \
	CmdLineOptionError \
	Complex \
	Fraction \
	GetOpt \
	IdentityDictionary \
	InlineObjectClassDescription \
	Integer \
	Interval \
	IsDebuggingQuery \
	LimitedPrecisionReal \
	LoadInProgressQuery \
	MeasurementValue \
	MetaNumber \
	Metaclass \
	MethodWithBreakpoints \
	ObsoleteMethodCallWarning \
	OrderedDictionary \
	OsError \
	PluginSupport \
	ProceedableError \
	QueryWithoutDefault \
	ReadStream \
	RecursionError \
	RecursiveExceptionError \
	RestartProcessRequest \
	SameForAllNotification \
	SemaphoreSet \
	SignalSet \
	SnapshotError \
	SortedCollection \
	StringCollection \
	TZTimestamp \
	TerminateProcessRequest \
	TimeDuration \
	UninterpretedBytes \
	UserInformation \
	UtcTimestamp \
	VMInternalError \
	VarArgBlock \
	Warning \
	WeakArray \
	WeakIdentitySet \
	WeakValueDictionary \
	WriteStream \
	AbortOperationRequest \
	AbstractNumberVector \
	AllocationFailure \
	AutoloadMetaclass \
	BooleanArray \
	ByteArray \
	CharacterArray \
	CharacterEncoderImplementations::ISO8859_9 \
	CharacterEncoderImplementations::KOI8_U \
	CharacterWriteStream \
	Class \
	ClassBuildWarning \
	ClassLoadInProgressQuery \
	ConversionError \
	DeepCopyError \
	ExceptionHandlerSet \
	ExecutionError \
	ExternalBytes \
	FixedPoint \
	Float \
	ImmutableArray \
	Infinity \
	InvalidPatchError \
	LargeInteger \
	LongFloat \
	NotANumber \
	OSSignalInterrupt \
	OsIllegalOperation \
	OsInaccessibleError \
	OsInvalidArgumentsError \
	OsNeedRetryError \
	OsNoResourcesError \
	OsNotification \
	OsTransferFaultError \
	PackageLoadError \
	PackageLoadInProgressQuery \
	PrivateMetaclass \
	ProceedError \
	ReadWriteStream \
	ShortFloat \
	SmallInteger \
	SmalltalkChunkFileSourceWriter \
	SomeNumber \
	StreamError \
	TimeoutError \
	UserPreferences \
	VarArgCheapBlock \
	WeakIdentityDictionary \
	WeakValueIdentityDictionary \
	AmbiguousMessage \
	ArgumentError \
	ArithmeticError \
	AssertionFailedError \
	CharacterEncoderError \
	ClassBuildError \
	ContextError \
	DateConversionError \
	ElementBoundsError \
	EndOfStreamError \
	ExternalStream \
	ExternalStructure \
	ImmutableByteArray \
	IncompleteNextCountError \
	InvalidCodeError \
	InvalidModeError \
	InvalidOperationError \
	InvalidTypeError \
	MallocFailure \
	MessageNotUnderstood \
	MethodNotAppropriateError \
	NoModificationError \
	NonBooleanReceiverError \
	NotFoundError \
	NumberConversionError \
	OpenError \
	PackageNotFoundError \
	PositionError \
	PositionOutOfBoundsError \
	PrimitiveFailure \
	ReadError \
	Registry \
	SignalError \
	SignedByteArray \
	StreamIOError \
	StreamNotOpenError \
	String \
	SubclassResponsibilityError \
	TimeConversionError \
	TwoByteString \
	UnboxedFloatArray \
	UnboxedIntegerArray \
	UnimplementedFunctionalityError \
	UnprotectedExternalBytes \
	WeakDependencyDictionary \
	WriteError \
	AbstractClassInstantiationError \
	BadLiteralsError \
	CachingRegistry \
	CannotResumeError \
	CannotReturnError \
	DecodingError \
	DomainError \
	DoubleArray \
	EncodingError \
	FileDoesNotExistException \
	FileStream \
	FloatArray \
	HandleRegistry \
	ImmutableString \
	IndexNotFoundError \
	IntegerArray \
	InvalidByteCodeError \
	InvalidInstructionError \
	InvalidReadError \
	InvalidWriteError \
	KeyNotFoundError \
	LongIntegerArray \
	MissingClassInLiteralArrayErrorSignal \
	NoByteCodeError \
	NonPositionableExternalStream \
	NumberFormatError \
	PTYOpenError \
	PackageNotCompatibleError \
	RangeError \
	SignedIntegerArray \
	SignedLongIntegerArray \
	SignedWordArray \
	Symbol \
	Unicode16String \
	UnorderedNumbersError \
	WordArray \
	WrongNumberOfArgumentsError \
	WrongProceedabilityError \
	CharacterRangeError \
	DirectoryStream \
	ImaginaryResultError \
	InfiniteResultError \
	InvalidEncodingError \
	NonIntegerIndexError \
	OverflowError \
	PipeStream \
	RomanNumberFormatError \
	SubscriptOutOfBoundsError \
	UnderflowError \
	ZeroDivide \
	BadRomanNumberFormatError \

WIN32_CLASSES= \
	PCFilename \
	Win32Constants \
	Win32Handle \
	Win32FILEHandle \
	Win32OperatingSystem \




UNIX_OBJS= \
    $(OUTDIR)UnixSyslogInterface.$(O) \
    $(OUTDIR)UnixFileDescriptorHandle.$(O) \
    $(OUTDIR)UnixFileHandle.$(O) \
    $(OUTDIR)UnixOperatingSystem.$(O) \
    $(OUTDIR)OSXOperatingSystem.$(O) \

VMS_OBJS= \
    $(OUTDIR)OpenVMSFileHandle.$(O) \
    $(OUTDIR)OpenVMSFilename.$(O) \
    $(OUTDIR)OpenVMSOperatingSystem.$(O) \

COMMON_OBJS= \
    $(OUTDIR)Autoload.$(O) \
    $(OUTDIR)Object.$(O) \
    $(OUTDIR)ProtoObject.$(O) \
    $(OUTDIR)AbstractOperatingSystem.$(O) \
    $(OUTDIR)AbstractSourceFileReader.$(O) \
    $(OUTDIR)Annotation.$(O) \
    $(OUTDIR)Behavior.$(O) \
    $(OUTDIR)Boolean.$(O) \
    $(OUTDIR)CharacterEncoder.$(O) \
    $(OUTDIR)ClassBuilder.$(O) \
    $(OUTDIR)ClassCategoryReader.$(O) \
    $(OUTDIR)CmdLineOption.$(O) \
    $(OUTDIR)CmdLineParser.$(O) \
    $(OUTDIR)Collection.$(O) \
    $(OUTDIR)ConfigurableFeatures.$(O) \
    $(OUTDIR)Context.$(O) \
    $(OUTDIR)Continuation.$(O) \
    $(OUTDIR)Delay.$(O) \
    $(OUTDIR)EOFObject.$(O) \
    $(OUTDIR)ExecutableFunction.$(O) \
    $(OUTDIR)ExternalAddress.$(O) \
    $(OUTDIR)ExternalLibrary.$(O) \
    $(OUTDIR)Filename.$(O) \
    $(OUTDIR)GenericException.$(O) \
    $(OUTDIR)Geometric.$(O) \
    $(OUTDIR)InlineObject.$(O) \
    $(OUTDIR)InterestConverter.$(O) \
    $(OUTDIR)Link.$(O) \
    $(OUTDIR)Lookup.$(O) \
    $(OUTDIR)Magnitude.$(O) \
    $(OUTDIR)Message.$(O) \
    $(OUTDIR)MiniDebugger.$(O) \
    $(OUTDIR)MiniInspector.$(O) \
    $(OUTDIR)NameSpace.$(O) \
    $(OUTDIR)OSErrorHolder.$(O) \
    $(OUTDIR)OSProcess.$(O) \
    $(OUTDIR)ObjectMemory.$(O) \
    $(OUTDIR)PackageId.$(O) \
    $(OUTDIR)PolymorphicInlineCache.$(O) \
    $(OUTDIR)ProcessorScheduler.$(O) \
    $(OUTDIR)ProgrammingLanguage.$(O) \
    $(OUTDIR)Project.$(O) \
    $(OUTDIR)ProjectDefinition.$(O) \
    $(OUTDIR)ReadEvalPrintLoop.$(O) \
    $(OUTDIR)Semaphore.$(O) \
    $(OUTDIR)SharedPool.$(O) \
    $(OUTDIR)Signal.$(O) \
    $(OUTDIR)Smalltalk.$(O) \
    $(OUTDIR)StandaloneStartup.$(O) \
    $(OUTDIR)Stream.$(O) \
    $(OUTDIR)SystemChangeNotifier.$(O) \
    $(OUTDIR)TimePeriod.$(O) \
    $(OUTDIR)UndefinedObject.$(O) \
    $(OUTDIR)UserMessage.$(O) \
    $(OUTDIR)Visitor.$(O) \
    $(OUTDIR)VoidObject.$(O) \
    $(OUTDIR)AbstractTime.$(O) \
    $(OUTDIR)ApplicationDefinition.$(O) \
    $(OUTDIR)ArithmeticValue.$(O) \
    $(OUTDIR)AspectVisitor.$(O) \
    $(OUTDIR)AutoDeletedFilename.$(O) \
    $(OUTDIR)Bag.$(O) \
    $(OUTDIR)BlockContext.$(O) \
    $(OUTDIR)BuiltinLookup.$(O) \
    $(OUTDIR)Character.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__FixedBytesEncoder.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO10646_1.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__VariableBytesEncoder.$(O) \
    $(OUTDIR)CompiledCode.$(O) \
    $(OUTDIR)ControlInterrupt.$(O) \
    $(OUTDIR)Date.$(O) \
    $(OUTDIR)EventSemaphore.$(O) \
    $(OUTDIR)Exception.$(O) \
    $(OUTDIR)ExternalFunction.$(O) \
    $(OUTDIR)False.$(O) \
    $(OUTDIR)FolderForProjectsDefinition.$(O) \
    $(OUTDIR)HashStream.$(O) \
    $(OUTDIR)JavaPackage.$(O) \
    $(OUTDIR)KeyedCollection.$(O) \
    $(OUTDIR)LibraryDefinition.$(O) \
    $(OUTDIR)LookupKey.$(O) \
    $(OUTDIR)MessageSend.$(O) \
    $(OUTDIR)MiniLogger.$(O) \
    $(OUTDIR)NamespaceAwareLookup.$(O) \
    $(OUTDIR)NoHandlerError.$(O) \
    $(OUTDIR)Notification.$(O) \
    $(OUTDIR)OSHandle.$(O) \
    $(OUTDIR)PeekableStream.$(O) \
    $(OUTDIR)Process.$(O) \
    $(OUTDIR)QuerySignal.$(O) \
    $(OUTDIR)Rectangle.$(O) \
    $(OUTDIR)RecursionLock.$(O) \
    $(OUTDIR)SequenceableCollection.$(O) \
    $(OUTDIR)Set.$(O) \
    $(OUTDIR)SmalltalkChunkFileSourceReader.$(O) \
    $(OUTDIR)SmalltalkLanguage.$(O) \
    $(OUTDIR)StandaloneStartupHeadless.$(O) \
    $(OUTDIR)True.$(O) \
    $(OUTDIR)UnixFilename.$(O) \
    $(OUTDIR)WeakInterestConverter.$(O) \
    $(OUTDIR)ArrayedCollection.$(O) \
    $(OUTDIR)Association.$(O) \
    $(OUTDIR)Block.$(O) \
    $(OUTDIR)CascadingNotification.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO10646_to_UTF16BE.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO10646_to_UTF8.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__MS_Ansi.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__SingleByteEncoder.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__TwoByteEncoder.$(O) \
    $(OUTDIR)ClassDescription.$(O) \
    $(OUTDIR)ControlRequest.$(O) \
    $(OUTDIR)Dictionary.$(O) \
    $(OUTDIR)EncodedStream.$(O) \
    $(OUTDIR)EndOfStreamNotification.$(O) \
    $(OUTDIR)Error.$(O) \
    $(OUTDIR)ExternalFunctionCallback.$(O) \
    $(OUTDIR)ExternalLibraryFunction.$(O) \
    $(OUTDIR)HaltInterrupt.$(O) \
    $(OUTDIR)IdentitySet.$(O) \
    $(OUTDIR)LinkedList.$(O) \
    $(OUTDIR)MD5Stream.$(O) \
    $(OUTDIR)Method.$(O) \
    $(OUTDIR)MethodDictionary.$(O) \
    $(OUTDIR)NaiveRomanNumberFormatNotification.$(O) \
    $(OUTDIR)Number.$(O) \
    $(OUTDIR)OSFileHandle.$(O) \
    $(OUTDIR)ObjectCoder.$(O) \
    $(OUTDIR)OrderedCollection.$(O) \
    $(OUTDIR)OrderedSet.$(O) \
    $(OUTDIR)Point.$(O) \
    $(OUTDIR)PositionableStream.$(O) \
    $(OUTDIR)ProceedingNotification.$(O) \
    $(OUTDIR)Query.$(O) \
    $(OUTDIR)ReadOnlySequenceableCollection.$(O) \
    $(OUTDIR)RecursiveStoreError.$(O) \
    $(OUTDIR)SHA1Stream.$(O) \
    $(OUTDIR)SmallDictionary.$(O) \
    $(OUTDIR)Time.$(O) \
    $(OUTDIR)TimeoutNotification.$(O) \
    $(OUTDIR)Timestamp.$(O) \
    $(OUTDIR)UnhandledAttributeInLiteralArrayErrorSignal.$(O) \
    $(OUTDIR)UserConfirmation.$(O) \
    $(OUTDIR)UserInterrupt.$(O) \
    $(OUTDIR)UserNotification.$(O) \
    $(OUTDIR)YesToAllConfirmation.$(O) \
    $(OUTDIR)stx_libbasic.$(O) \
    $(OUTDIR)AbortAllOperationRequest.$(O) \
    $(OUTDIR)AbortAllOperationWantedQuery.$(O) \
    $(OUTDIR)AbstractSourceFileWriter.$(O) \
    $(OUTDIR)ActivityNotification.$(O) \
    $(OUTDIR)Array.$(O) \
    $(OUTDIR)BitArray.$(O) \
    $(OUTDIR)BreakPointInterrupt.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ASCII.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__CP437.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__EBCDIC.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO10646_to_UTF16LE.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO10646_to_UTF8_MAC.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO10646_to_XMLUTF8.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO8859_1.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO8859_10.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO8859_11.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO8859_13.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO8859_14.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO8859_15.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO8859_16.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO8859_2.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO8859_3.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO8859_4.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO8859_5.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO8859_6.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO8859_7.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO8859_8.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__KOI8_R.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__MAC_Roman.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__MS_Arabic.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__MS_Baltic.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__MS_CP1252.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__MS_Cyrillic.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__MS_EastEuropean.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__MS_Greek.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__MS_Hebrew.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__MS_Symbol.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__MS_Turkish.$(O) \
    $(OUTDIR)CheapBlock.$(O) \
    $(OUTDIR)CmdLineOptionError.$(O) \
    $(OUTDIR)Complex.$(O) \
    $(OUTDIR)Fraction.$(O) \
    $(OUTDIR)GetOpt.$(O) \
    $(OUTDIR)IdentityDictionary.$(O) \
    $(OUTDIR)InlineObjectClassDescription.$(O) \
    $(OUTDIR)Integer.$(O) \
    $(OUTDIR)Interval.$(O) \
    $(OUTDIR)IsDebuggingQuery.$(O) \
    $(OUTDIR)LimitedPrecisionReal.$(O) \
    $(OUTDIR)LoadInProgressQuery.$(O) \
    $(OUTDIR)MeasurementValue.$(O) \
    $(OUTDIR)MetaNumber.$(O) \
    $(OUTDIR)Metaclass.$(O) \
    $(OUTDIR)MethodWithBreakpoints.$(O) \
    $(OUTDIR)ObsoleteMethodCallWarning.$(O) \
    $(OUTDIR)OrderedDictionary.$(O) \
    $(OUTDIR)OsError.$(O) \
    $(OUTDIR)PluginSupport.$(O) \
    $(OUTDIR)ProceedableError.$(O) \
    $(OUTDIR)QueryWithoutDefault.$(O) \
    $(OUTDIR)ReadStream.$(O) \
    $(OUTDIR)RecursionError.$(O) \
    $(OUTDIR)RecursiveExceptionError.$(O) \
    $(OUTDIR)RestartProcessRequest.$(O) \
    $(OUTDIR)SameForAllNotification.$(O) \
    $(OUTDIR)SemaphoreSet.$(O) \
    $(OUTDIR)SignalSet.$(O) \
    $(OUTDIR)SnapshotError.$(O) \
    $(OUTDIR)SortedCollection.$(O) \
    $(OUTDIR)StringCollection.$(O) \
    $(OUTDIR)TZTimestamp.$(O) \
    $(OUTDIR)TerminateProcessRequest.$(O) \
    $(OUTDIR)TimeDuration.$(O) \
    $(OUTDIR)UninterpretedBytes.$(O) \
    $(OUTDIR)UserInformation.$(O) \
    $(OUTDIR)UtcTimestamp.$(O) \
    $(OUTDIR)VMInternalError.$(O) \
    $(OUTDIR)VarArgBlock.$(O) \
    $(OUTDIR)Warning.$(O) \
    $(OUTDIR)WeakArray.$(O) \
    $(OUTDIR)WeakIdentitySet.$(O) \
    $(OUTDIR)WeakValueDictionary.$(O) \
    $(OUTDIR)WriteStream.$(O) \
    $(OUTDIR)AbortOperationRequest.$(O) \
    $(OUTDIR)AbstractNumberVector.$(O) \
    $(OUTDIR)AllocationFailure.$(O) \
    $(OUTDIR)AutoloadMetaclass.$(O) \
    $(OUTDIR)BooleanArray.$(O) \
    $(OUTDIR)ByteArray.$(O) \
    $(OUTDIR)CharacterArray.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__ISO8859_9.$(O) \
    $(OUTDIR)CharacterEncoderImplementations__KOI8_U.$(O) \
    $(OUTDIR)CharacterWriteStream.$(O) \
    $(OUTDIR)Class.$(O) \
    $(OUTDIR)ClassBuildWarning.$(O) \
    $(OUTDIR)ClassLoadInProgressQuery.$(O) \
    $(OUTDIR)ConversionError.$(O) \
    $(OUTDIR)DeepCopyError.$(O) \
    $(OUTDIR)ExceptionHandlerSet.$(O) \
    $(OUTDIR)ExecutionError.$(O) \
    $(OUTDIR)ExternalBytes.$(O) \
    $(OUTDIR)FixedPoint.$(O) \
    $(OUTDIR)Float.$(O) \
    $(OUTDIR)ImmutableArray.$(O) \
    $(OUTDIR)Infinity.$(O) \
    $(OUTDIR)InvalidPatchError.$(O) \
    $(OUTDIR)LargeInteger.$(O) \
    $(OUTDIR)LongFloat.$(O) \
    $(OUTDIR)NotANumber.$(O) \
    $(OUTDIR)OSSignalInterrupt.$(O) \
    $(OUTDIR)OsIllegalOperation.$(O) \
    $(OUTDIR)OsInaccessibleError.$(O) \
    $(OUTDIR)OsInvalidArgumentsError.$(O) \
    $(OUTDIR)OsNeedRetryError.$(O) \
    $(OUTDIR)OsNoResourcesError.$(O) \
    $(OUTDIR)OsNotification.$(O) \
    $(OUTDIR)OsTransferFaultError.$(O) \
    $(OUTDIR)PackageLoadError.$(O) \
    $(OUTDIR)PackageLoadInProgressQuery.$(O) \
    $(OUTDIR)PrivateMetaclass.$(O) \
    $(OUTDIR)ProceedError.$(O) \
    $(OUTDIR)ReadWriteStream.$(O) \
    $(OUTDIR)ShortFloat.$(O) \
    $(OUTDIR)SmallInteger.$(O) \
    $(OUTDIR)SmalltalkChunkFileSourceWriter.$(O) \
    $(OUTDIR)SomeNumber.$(O) \
    $(OUTDIR)StreamError.$(O) \
    $(OUTDIR)TimeoutError.$(O) \
    $(OUTDIR)UserPreferences.$(O) \
    $(OUTDIR)VarArgCheapBlock.$(O) \
    $(OUTDIR)WeakIdentityDictionary.$(O) \
    $(OUTDIR)WeakValueIdentityDictionary.$(O) \
    $(OUTDIR)AmbiguousMessage.$(O) \
    $(OUTDIR)ArgumentError.$(O) \
    $(OUTDIR)ArithmeticError.$(O) \
    $(OUTDIR)AssertionFailedError.$(O) \
    $(OUTDIR)CharacterEncoderError.$(O) \
    $(OUTDIR)ClassBuildError.$(O) \
    $(OUTDIR)ContextError.$(O) \
    $(OUTDIR)DateConversionError.$(O) \
    $(OUTDIR)ElementBoundsError.$(O) \
    $(OUTDIR)EndOfStreamError.$(O) \
    $(OUTDIR)ExternalStream.$(O) \
    $(OUTDIR)ExternalStructure.$(O) \
    $(OUTDIR)ImmutableByteArray.$(O) \
    $(OUTDIR)IncompleteNextCountError.$(O) \
    $(OUTDIR)InvalidCodeError.$(O) \
    $(OUTDIR)InvalidModeError.$(O) \
    $(OUTDIR)InvalidOperationError.$(O) \
    $(OUTDIR)InvalidTypeError.$(O) \
    $(OUTDIR)MallocFailure.$(O) \
    $(OUTDIR)MessageNotUnderstood.$(O) \
    $(OUTDIR)MethodNotAppropriateError.$(O) \
    $(OUTDIR)NoModificationError.$(O) \
    $(OUTDIR)NonBooleanReceiverError.$(O) \
    $(OUTDIR)NotFoundError.$(O) \
    $(OUTDIR)NumberConversionError.$(O) \
    $(OUTDIR)OpenError.$(O) \
    $(OUTDIR)PackageNotFoundError.$(O) \
    $(OUTDIR)PositionError.$(O) \
    $(OUTDIR)PositionOutOfBoundsError.$(O) \
    $(OUTDIR)PrimitiveFailure.$(O) \
    $(OUTDIR)ReadError.$(O) \
    $(OUTDIR)Registry.$(O) \
    $(OUTDIR)SignalError.$(O) \
    $(OUTDIR)SignedByteArray.$(O) \
    $(OUTDIR)StreamIOError.$(O) \
    $(OUTDIR)StreamNotOpenError.$(O) \
    $(OUTDIR)String.$(O) \
    $(OUTDIR)SubclassResponsibilityError.$(O) \
    $(OUTDIR)TimeConversionError.$(O) \
    $(OUTDIR)TwoByteString.$(O) \
    $(OUTDIR)UnboxedFloatArray.$(O) \
    $(OUTDIR)UnboxedIntegerArray.$(O) \
    $(OUTDIR)UnimplementedFunctionalityError.$(O) \
    $(OUTDIR)UnprotectedExternalBytes.$(O) \
    $(OUTDIR)WeakDependencyDictionary.$(O) \
    $(OUTDIR)WriteError.$(O) \
    $(OUTDIR)AbstractClassInstantiationError.$(O) \
    $(OUTDIR)BadLiteralsError.$(O) \
    $(OUTDIR)CachingRegistry.$(O) \
    $(OUTDIR)CannotResumeError.$(O) \
    $(OUTDIR)CannotReturnError.$(O) \
    $(OUTDIR)DecodingError.$(O) \
    $(OUTDIR)DomainError.$(O) \
    $(OUTDIR)DoubleArray.$(O) \
    $(OUTDIR)EncodingError.$(O) \
    $(OUTDIR)FileDoesNotExistException.$(O) \
    $(OUTDIR)FileStream.$(O) \
    $(OUTDIR)FloatArray.$(O) \
    $(OUTDIR)HandleRegistry.$(O) \
    $(OUTDIR)ImmutableString.$(O) \
    $(OUTDIR)IndexNotFoundError.$(O) \
    $(OUTDIR)IntegerArray.$(O) \
    $(OUTDIR)InvalidByteCodeError.$(O) \
    $(OUTDIR)InvalidInstructionError.$(O) \
    $(OUTDIR)InvalidReadError.$(O) \
    $(OUTDIR)InvalidWriteError.$(O) \
    $(OUTDIR)KeyNotFoundError.$(O) \
    $(OUTDIR)LongIntegerArray.$(O) \
    $(OUTDIR)MissingClassInLiteralArrayErrorSignal.$(O) \
    $(OUTDIR)NoByteCodeError.$(O) \
    $(OUTDIR)NonPositionableExternalStream.$(O) \
    $(OUTDIR)NumberFormatError.$(O) \
    $(OUTDIR)PTYOpenError.$(O) \
    $(OUTDIR)PackageNotCompatibleError.$(O) \
    $(OUTDIR)RangeError.$(O) \
    $(OUTDIR)SignedIntegerArray.$(O) \
    $(OUTDIR)SignedLongIntegerArray.$(O) \
    $(OUTDIR)SignedWordArray.$(O) \
    $(OUTDIR)Symbol.$(O) \
    $(OUTDIR)Unicode16String.$(O) \
    $(OUTDIR)UnorderedNumbersError.$(O) \
    $(OUTDIR)WordArray.$(O) \
    $(OUTDIR)WrongNumberOfArgumentsError.$(O) \
    $(OUTDIR)WrongProceedabilityError.$(O) \
    $(OUTDIR)CharacterRangeError.$(O) \
    $(OUTDIR)DirectoryStream.$(O) \
    $(OUTDIR)ImaginaryResultError.$(O) \
    $(OUTDIR)InfiniteResultError.$(O) \
    $(OUTDIR)InvalidEncodingError.$(O) \
    $(OUTDIR)NonIntegerIndexError.$(O) \
    $(OUTDIR)OverflowError.$(O) \
    $(OUTDIR)PipeStream.$(O) \
    $(OUTDIR)RomanNumberFormatError.$(O) \
    $(OUTDIR)SubscriptOutOfBoundsError.$(O) \
    $(OUTDIR)UnderflowError.$(O) \
    $(OUTDIR)ZeroDivide.$(O) \
    $(OUTDIR)BadRomanNumberFormatError.$(O) \

WIN32_OBJS= \
    $(OUTDIR)PCFilename.$(O) \
    $(OUTDIR)Win32Constants.$(O) \
    $(OUTDIR)Win32Handle.$(O) \
    $(OUTDIR)Win32FILEHandle.$(O) \
    $(OUTDIR)Win32OperatingSystem.$(O) \