Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Tue, 03 Dec 2013 16:30:32 +0000
branchjv
changeset 18110 b0740d62ff1e
parent 18109 0fab3955490e
child 18120 e3a375d5f6a8
permissions -rw-r--r--
Fixed Make.spec, sigh

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libbasic.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libbasic
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optinline +optinline2


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

VMS_CLASSES= \
	OpenVMSFileHandle \
	OpenVMSFilename \
	OpenVMSOperatingSystem \

UNIX_CLASSES= \
	UnixFileDescriptorHandle \
	UnixFileHandle \
	UnixOperatingSystem \
	OSXOperatingSystem \

COMMON_CLASSES= \
	Autoload \
	Object \
	ProtoObject \
	AbstractOperatingSystem \
	AbstractSourceFileReader \
	Annotation \
	Behavior \
	Boolean \
	CharacterEncoder \
	ClassBuilder \
	ClassCategoryReader \
	Collection \
	ConfigurableFeatures \
	Context \
	Continuation \
	Delay \
	ExecutableFunction \
	ExternalAddress \
	ExternalLibrary \
	Filename \
	GenericException \
	Geometric \
	InlineObject \
	InterestConverter \
	Link \
	Lookup \
	Magnitude \
	Message \
	MiniDebugger \
	MiniInspector \
	MiniLogger \
	NameSpace \
	OSErrorHolder \
	OSProcess \
	ObjectMemory \
	PackageId \
	PolymorphicInlineCache \
	ProcessorScheduler \
	ProgrammingLanguage \
	Project \
	ProjectDefinition \
	ReadEvalPrintLoop \
	RecursionLock \
	Registry \
	Semaphore \
	SharedPool \
	Signal \
	Smalltalk \
	StandaloneStartup \
	Stream \
	SystemChangeNotifier \
	UndefinedObject \
	UserMessage \
	Visitor \
	AbstractTime \
	ApplicationDefinition \
	ArithmeticValue \
	AspectVisitor \
	AutoDeletedFilename \
	Bag \
	BlockContext \
	BuiltinLookup \
	CachingRegistry \
	Character \
	CharacterEncoderImplementations::ISO10646_1 \
	CharacterEncoderImplementations::SingleByteEncoder \
	CharacterEncoderImplementations::TwoByteEncoder \
	CompiledCode \
	ControlInterrupt \
	Date \
	Exception \
	ExternalFunction \
	False \
	HandleRegistry \
	HashStream \
	InlineObjectPrototype \
	KeyedCollection \
	LibraryDefinition \
	LookupKey \
	MessageSend \
	NamespaceAwareLookup \
	NoHandlerError \
	Notification \
	OSHandle \
	PeekableStream \
	Process \
	QuerySignal \
	Rectangle \
	SequenceableCollection \
	Set \
	SmalltalkChunkFileSourceReader \
	SmalltalkLanguage \
	True \
	UnixFilename \
	WeakInterestConverter \
	ArrayedCollection \
	Association \
	Block \
	CascadingNotification \
	CharacterEncoderImplementations::ASCII \
	CharacterEncoderImplementations::CP437 \
	CharacterEncoderImplementations::EBCDIC \
	CharacterEncoderImplementations::ISO10646_to_UTF16BE \
	CharacterEncoderImplementations::ISO10646_to_UTF8 \
	CharacterEncoderImplementations::ISO8859_1 \
	CharacterEncoderImplementations::ISO8859_10 \
	CharacterEncoderImplementations::ISO8859_11 \
	CharacterEncoderImplementations::ISO8859_13 \
	CharacterEncoderImplementations::ISO8859_14 \
	CharacterEncoderImplementations::ISO8859_15 \
	CharacterEncoderImplementations::ISO8859_16 \
	CharacterEncoderImplementations::ISO8859_2 \
	CharacterEncoderImplementations::ISO8859_3 \
	CharacterEncoderImplementations::ISO8859_4 \
	CharacterEncoderImplementations::ISO8859_5 \
	CharacterEncoderImplementations::ISO8859_6 \
	CharacterEncoderImplementations::ISO8859_7 \
	CharacterEncoderImplementations::ISO8859_8 \
	CharacterEncoderImplementations::KOI8_R \
	CharacterEncoderImplementations::MS_Ansi \
	CharacterEncoderImplementations::MS_Arabic \
	CharacterEncoderImplementations::MS_Baltic \
	CharacterEncoderImplementations::MS_Cyrillic \
	CharacterEncoderImplementations::MS_EastEuropean \
	CharacterEncoderImplementations::MS_Greek \
	CharacterEncoderImplementations::MS_Hebrew \
	CharacterEncoderImplementations::MS_Symbol \
	CharacterEncoderImplementations::MS_Turkish \
	ClassDescription \
	Complex \
	ControlRequest \
	Dictionary \
	EncodedStream \
	EndOfStreamNotification \
	Error \
	ExternalFunctionCallback \
	ExternalLibraryFunction \
	HaltInterrupt \
	IdentitySet \
	LinkedList \
	MD5Stream \
	Method \
	MethodDictionary \
	Number \
	OSFileHandle \
	ObjectCoder \
	OrderedCollection \
	OrderedSet \
	Point \
	PositionableStream \
	ProceedingNotification \
	Query \
	ReadOnlySequenceableCollection \
	RecursiveStoreError \
	SHA1Stream \
	Time \
	TimeoutNotification \
	Timestamp \
	UserConfirmation \
	UserInterrupt \
	UserNotification \
	YesToAllConfirmation \
	stx_libbasic \
	AbortAllOperationRequest \
	AbortAllOperationWantedQuery \
	AbstractSourceFileWriter \
	ActivityNotification \
	Array \
	BreakPointInterrupt \
	CharacterEncoderImplementations::ISO10646_to_UTF16LE \
	CharacterEncoderImplementations::ISO8859_9 \
	CharacterEncoderImplementations::KOI8_U \
	CheapBlock \
	ClassBuildError \
	ElementBoundsError \
	FileDirectory \
	Fraction \
	GetOpt \
	IdentityDictionary \
	InlineObjectClassDescription \
	Integer \
	Interval \
	IsDebuggingQuery \
	LimitedPrecisionReal \
	MeasurementValue \
	MetaNumber \
	Metaclass \
	MethodWithBreakpoints \
	OrderedDictionary \
	OsError \
	PluginSupport \
	ProceedableError \
	QueryWithoutDefault \
	ReadStream \
	RecursionError \
	RecursiveExceptionError \
	RestartProcessRequest \
	SameForAllNotification \
	SemaphoreSet \
	SignalSet \
	SnapshotError \
	SortedCollection \
	StringCollection \
	TerminateProcessRequest \
	UninterpretedBytes \
	UserInformation \
	UtcTimestamp \
	VMInternalError \
	VarArgBlock \
	Warning \
	WeakArray \
	WeakIdentitySet \
	WeakValueDictionary \
	WriteStream \
	AbortOperationRequest \
	AbstractNumberVector \
	AllocationFailure \
	AmbiguousMessage \
	ArithmeticError \
	AssertionFailedError \
	AutoloadMetaclass \
	ByteArray \
	CharacterArray \
	CharacterWriteStream \
	Class \
	ContextError \
	ConversionError \
	DeepCopyError \
	ExceptionHandlerSet \
	ExecutionError \
	ExternalBytes \
	FixedPoint \
	Float \
	ImmutableArray \
	Infinity \
	InvalidPatchError \
	LargeInteger \
	LongFloat \
	MessageNotUnderstood \
	NoModificationError \
	NotFoundError \
	OSSignalInterrupt \
	OsIllegalOperation \
	OsInaccessibleError \
	OsInvalidArgumentsError \
	OsNeedRetryError \
	OsNoResourcesError \
	OsNotification \
	OsTransferFaultError \
	PrivateMetaclass \
	ProceedError \
	ReadWriteStream \
	ShortFloat \
	SignalError \
	SmallInteger \
	SmalltalkChunkFileSourceWriter \
	SomeNumber \
	StreamError \
	SubclassResponsibilityError \
	TimeoutError \
	UnimplementedFunctionalityError \
	UserPreferences \
	VarArgCheapBlock \
	WeakIdentityDictionary \
	ArgumentError \
	CannotResumeError \
	CannotReturnError \
	CharacterEncoderError \
	DateConversionError \
	DomainError \
	DoubleArray \
	EndOfStreamError \
	ExternalStream \
	ExternalStructure \
	FloatArray \
	ImmutableByteArray \
	IncompleteNextCountError \
	IndexNotFoundError \
	InvalidCodeError \
	InvalidModeError \
	InvalidOperationError \
	InvalidTypeError \
	KeyNotFoundError \
	MallocFailure \
	MethodNotAppropriateError \
	NonBooleanReceiverError \
	OpenError \
	PositionError \
	PositionOutOfBoundsError \
	PrimitiveFailure \
	RangeError \
	ReadError \
	StreamIOError \
	StreamNotOpenError \
	String \
	TimeConversionError \
	TwoByteString \
	UnorderedNumbersError \
	UnprotectedExternalBytes \
	WeakDependencyDictionary \
	WriteError \
	WrongProceedabilityError \
	AbstractClassInstantiationError \
	BadLiteralsError \
	DecodingError \
	EncodingError \
	FileDoesNotExistException \
	FileStream \
	ImmutableString \
	InvalidByteCodeError \
	InvalidInstructionError \
	InvalidReadError \
	InvalidWriteError \
	NoByteCodeError \
	NonIntegerIndexError \
	NonPositionableExternalStream \
	OverflowError \
	SubscriptOutOfBoundsError \
	Symbol \
	UnderflowError \
	Unicode16String \
	WrongNumberOfArgumentsError \
	ZeroDivide \
	CharacterRangeError \
	DirectoryStream \
	InvalidEncodingError \
	PipeStream \

WIN32_CLASSES= \
	PCFilename \
	Win32Constants \
	Win32FILEHandle \
	Win32Handle \
	Win32OperatingSystem \
	Win32Process \




VMS_OBJS= \
    $(OUTDIR_SLASH)OpenVMSFileHandle.$(O) \
    $(OUTDIR_SLASH)OpenVMSFilename.$(O) \
    $(OUTDIR_SLASH)OpenVMSOperatingSystem.$(O) \

UNIX_OBJS= \
    $(OUTDIR_SLASH)UnixFileDescriptorHandle.$(O) \
    $(OUTDIR_SLASH)UnixFileHandle.$(O) \
    $(OUTDIR_SLASH)UnixOperatingSystem.$(O) \
    $(OUTDIR_SLASH)OSXOperatingSystem.$(O) \

COMMON_OBJS= \
    $(OUTDIR_SLASH)Autoload.$(O) \
    $(OUTDIR_SLASH)Object.$(O) \
    $(OUTDIR_SLASH)ProtoObject.$(O) \
    $(OUTDIR_SLASH)AbstractOperatingSystem.$(O) \
    $(OUTDIR_SLASH)AbstractSourceFileReader.$(O) \
    $(OUTDIR_SLASH)Annotation.$(O) \
    $(OUTDIR_SLASH)Behavior.$(O) \
    $(OUTDIR_SLASH)Boolean.$(O) \
    $(OUTDIR_SLASH)CharacterEncoder.$(O) \
    $(OUTDIR_SLASH)ClassBuilder.$(O) \
    $(OUTDIR_SLASH)ClassCategoryReader.$(O) \
    $(OUTDIR_SLASH)Collection.$(O) \
    $(OUTDIR_SLASH)ConfigurableFeatures.$(O) \
    $(OUTDIR_SLASH)Context.$(O) \
    $(OUTDIR_SLASH)Continuation.$(O) \
    $(OUTDIR_SLASH)Delay.$(O) \
    $(OUTDIR_SLASH)ExecutableFunction.$(O) \
    $(OUTDIR_SLASH)ExternalAddress.$(O) \
    $(OUTDIR_SLASH)ExternalLibrary.$(O) \
    $(OUTDIR_SLASH)Filename.$(O) \
    $(OUTDIR_SLASH)GenericException.$(O) \
    $(OUTDIR_SLASH)Geometric.$(O) \
    $(OUTDIR_SLASH)InlineObject.$(O) \
    $(OUTDIR_SLASH)InterestConverter.$(O) \
    $(OUTDIR_SLASH)Link.$(O) \
    $(OUTDIR_SLASH)Lookup.$(O) \
    $(OUTDIR_SLASH)Magnitude.$(O) \
    $(OUTDIR_SLASH)Message.$(O) \
    $(OUTDIR_SLASH)MiniDebugger.$(O) \
    $(OUTDIR_SLASH)MiniInspector.$(O) \
    $(OUTDIR_SLASH)MiniLogger.$(O) \
    $(OUTDIR_SLASH)NameSpace.$(O) \
    $(OUTDIR_SLASH)OSErrorHolder.$(O) \
    $(OUTDIR_SLASH)OSProcess.$(O) \
    $(OUTDIR_SLASH)ObjectMemory.$(O) \
    $(OUTDIR_SLASH)PackageId.$(O) \
    $(OUTDIR_SLASH)PolymorphicInlineCache.$(O) \
    $(OUTDIR_SLASH)ProcessorScheduler.$(O) \
    $(OUTDIR_SLASH)ProgrammingLanguage.$(O) \
    $(OUTDIR_SLASH)Project.$(O) \
    $(OUTDIR_SLASH)ProjectDefinition.$(O) \
    $(OUTDIR_SLASH)ReadEvalPrintLoop.$(O) \
    $(OUTDIR_SLASH)RecursionLock.$(O) \
    $(OUTDIR_SLASH)Registry.$(O) \
    $(OUTDIR_SLASH)Semaphore.$(O) \
    $(OUTDIR_SLASH)SharedPool.$(O) \
    $(OUTDIR_SLASH)Signal.$(O) \
    $(OUTDIR_SLASH)Smalltalk.$(O) \
    $(OUTDIR_SLASH)StandaloneStartup.$(O) \
    $(OUTDIR_SLASH)Stream.$(O) \
    $(OUTDIR_SLASH)SystemChangeNotifier.$(O) \
    $(OUTDIR_SLASH)UndefinedObject.$(O) \
    $(OUTDIR_SLASH)UserMessage.$(O) \
    $(OUTDIR_SLASH)Visitor.$(O) \
    $(OUTDIR_SLASH)AbstractTime.$(O) \
    $(OUTDIR_SLASH)ApplicationDefinition.$(O) \
    $(OUTDIR_SLASH)ArithmeticValue.$(O) \
    $(OUTDIR_SLASH)AspectVisitor.$(O) \
    $(OUTDIR_SLASH)AutoDeletedFilename.$(O) \
    $(OUTDIR_SLASH)Bag.$(O) \
    $(OUTDIR_SLASH)BlockContext.$(O) \
    $(OUTDIR_SLASH)BuiltinLookup.$(O) \
    $(OUTDIR_SLASH)CachingRegistry.$(O) \
    $(OUTDIR_SLASH)Character.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO10646_1.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__SingleByteEncoder.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__TwoByteEncoder.$(O) \
    $(OUTDIR_SLASH)CompiledCode.$(O) \
    $(OUTDIR_SLASH)ControlInterrupt.$(O) \
    $(OUTDIR_SLASH)Date.$(O) \
    $(OUTDIR_SLASH)Exception.$(O) \
    $(OUTDIR_SLASH)ExternalFunction.$(O) \
    $(OUTDIR_SLASH)False.$(O) \
    $(OUTDIR_SLASH)HandleRegistry.$(O) \
    $(OUTDIR_SLASH)HashStream.$(O) \
    $(OUTDIR_SLASH)InlineObjectPrototype.$(O) \
    $(OUTDIR_SLASH)KeyedCollection.$(O) \
    $(OUTDIR_SLASH)LibraryDefinition.$(O) \
    $(OUTDIR_SLASH)LookupKey.$(O) \
    $(OUTDIR_SLASH)MessageSend.$(O) \
    $(OUTDIR_SLASH)NamespaceAwareLookup.$(O) \
    $(OUTDIR_SLASH)NoHandlerError.$(O) \
    $(OUTDIR_SLASH)Notification.$(O) \
    $(OUTDIR_SLASH)OSHandle.$(O) \
    $(OUTDIR_SLASH)PeekableStream.$(O) \
    $(OUTDIR_SLASH)Process.$(O) \
    $(OUTDIR_SLASH)QuerySignal.$(O) \
    $(OUTDIR_SLASH)Rectangle.$(O) \
    $(OUTDIR_SLASH)SequenceableCollection.$(O) \
    $(OUTDIR_SLASH)Set.$(O) \
    $(OUTDIR_SLASH)SmalltalkChunkFileSourceReader.$(O) \
    $(OUTDIR_SLASH)SmalltalkLanguage.$(O) \
    $(OUTDIR_SLASH)True.$(O) \
    $(OUTDIR_SLASH)UnixFilename.$(O) \
    $(OUTDIR_SLASH)WeakInterestConverter.$(O) \
    $(OUTDIR_SLASH)ArrayedCollection.$(O) \
    $(OUTDIR_SLASH)Association.$(O) \
    $(OUTDIR_SLASH)Block.$(O) \
    $(OUTDIR_SLASH)CascadingNotification.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ASCII.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__CP437.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__EBCDIC.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO10646_to_UTF16BE.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO10646_to_UTF8.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_1.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_10.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_11.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_13.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_14.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_15.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_16.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_2.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_3.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_4.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_5.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_6.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_7.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_8.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__KOI8_R.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__MS_Ansi.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__MS_Arabic.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__MS_Baltic.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__MS_Cyrillic.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__MS_EastEuropean.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__MS_Greek.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__MS_Hebrew.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__MS_Symbol.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__MS_Turkish.$(O) \
    $(OUTDIR_SLASH)ClassDescription.$(O) \
    $(OUTDIR_SLASH)Complex.$(O) \
    $(OUTDIR_SLASH)ControlRequest.$(O) \
    $(OUTDIR_SLASH)Dictionary.$(O) \
    $(OUTDIR_SLASH)EncodedStream.$(O) \
    $(OUTDIR_SLASH)EndOfStreamNotification.$(O) \
    $(OUTDIR_SLASH)Error.$(O) \
    $(OUTDIR_SLASH)ExternalFunctionCallback.$(O) \
    $(OUTDIR_SLASH)ExternalLibraryFunction.$(O) \
    $(OUTDIR_SLASH)HaltInterrupt.$(O) \
    $(OUTDIR_SLASH)IdentitySet.$(O) \
    $(OUTDIR_SLASH)LinkedList.$(O) \
    $(OUTDIR_SLASH)MD5Stream.$(O) \
    $(OUTDIR_SLASH)Method.$(O) \
    $(OUTDIR_SLASH)MethodDictionary.$(O) \
    $(OUTDIR_SLASH)Number.$(O) \
    $(OUTDIR_SLASH)OSFileHandle.$(O) \
    $(OUTDIR_SLASH)ObjectCoder.$(O) \
    $(OUTDIR_SLASH)OrderedCollection.$(O) \
    $(OUTDIR_SLASH)OrderedSet.$(O) \
    $(OUTDIR_SLASH)Point.$(O) \
    $(OUTDIR_SLASH)PositionableStream.$(O) \
    $(OUTDIR_SLASH)ProceedingNotification.$(O) \
    $(OUTDIR_SLASH)Query.$(O) \
    $(OUTDIR_SLASH)ReadOnlySequenceableCollection.$(O) \
    $(OUTDIR_SLASH)RecursiveStoreError.$(O) \
    $(OUTDIR_SLASH)SHA1Stream.$(O) \
    $(OUTDIR_SLASH)Time.$(O) \
    $(OUTDIR_SLASH)TimeoutNotification.$(O) \
    $(OUTDIR_SLASH)Timestamp.$(O) \
    $(OUTDIR_SLASH)UserConfirmation.$(O) \
    $(OUTDIR_SLASH)UserInterrupt.$(O) \
    $(OUTDIR_SLASH)UserNotification.$(O) \
    $(OUTDIR_SLASH)YesToAllConfirmation.$(O) \
    $(OUTDIR_SLASH)stx_libbasic.$(O) \
    $(OUTDIR_SLASH)AbortAllOperationRequest.$(O) \
    $(OUTDIR_SLASH)AbortAllOperationWantedQuery.$(O) \
    $(OUTDIR_SLASH)AbstractSourceFileWriter.$(O) \
    $(OUTDIR_SLASH)ActivityNotification.$(O) \
    $(OUTDIR_SLASH)Array.$(O) \
    $(OUTDIR_SLASH)BreakPointInterrupt.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO10646_to_UTF16LE.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__ISO8859_9.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderImplementations__KOI8_U.$(O) \
    $(OUTDIR_SLASH)CheapBlock.$(O) \
    $(OUTDIR_SLASH)ClassBuildError.$(O) \
    $(OUTDIR_SLASH)ElementBoundsError.$(O) \
    $(OUTDIR_SLASH)FileDirectory.$(O) \
    $(OUTDIR_SLASH)Fraction.$(O) \
    $(OUTDIR_SLASH)GetOpt.$(O) \
    $(OUTDIR_SLASH)IdentityDictionary.$(O) \
    $(OUTDIR_SLASH)InlineObjectClassDescription.$(O) \
    $(OUTDIR_SLASH)Integer.$(O) \
    $(OUTDIR_SLASH)Interval.$(O) \
    $(OUTDIR_SLASH)IsDebuggingQuery.$(O) \
    $(OUTDIR_SLASH)LimitedPrecisionReal.$(O) \
    $(OUTDIR_SLASH)MeasurementValue.$(O) \
    $(OUTDIR_SLASH)MetaNumber.$(O) \
    $(OUTDIR_SLASH)Metaclass.$(O) \
    $(OUTDIR_SLASH)MethodWithBreakpoints.$(O) \
    $(OUTDIR_SLASH)OrderedDictionary.$(O) \
    $(OUTDIR_SLASH)OsError.$(O) \
    $(OUTDIR_SLASH)PluginSupport.$(O) \
    $(OUTDIR_SLASH)ProceedableError.$(O) \
    $(OUTDIR_SLASH)QueryWithoutDefault.$(O) \
    $(OUTDIR_SLASH)ReadStream.$(O) \
    $(OUTDIR_SLASH)RecursionError.$(O) \
    $(OUTDIR_SLASH)RecursiveExceptionError.$(O) \
    $(OUTDIR_SLASH)RestartProcessRequest.$(O) \
    $(OUTDIR_SLASH)SameForAllNotification.$(O) \
    $(OUTDIR_SLASH)SemaphoreSet.$(O) \
    $(OUTDIR_SLASH)SignalSet.$(O) \
    $(OUTDIR_SLASH)SnapshotError.$(O) \
    $(OUTDIR_SLASH)SortedCollection.$(O) \
    $(OUTDIR_SLASH)StringCollection.$(O) \
    $(OUTDIR_SLASH)TerminateProcessRequest.$(O) \
    $(OUTDIR_SLASH)UninterpretedBytes.$(O) \
    $(OUTDIR_SLASH)UserInformation.$(O) \
    $(OUTDIR_SLASH)UtcTimestamp.$(O) \
    $(OUTDIR_SLASH)VMInternalError.$(O) \
    $(OUTDIR_SLASH)VarArgBlock.$(O) \
    $(OUTDIR_SLASH)Warning.$(O) \
    $(OUTDIR_SLASH)WeakArray.$(O) \
    $(OUTDIR_SLASH)WeakIdentitySet.$(O) \
    $(OUTDIR_SLASH)WeakValueDictionary.$(O) \
    $(OUTDIR_SLASH)WriteStream.$(O) \
    $(OUTDIR_SLASH)AbortOperationRequest.$(O) \
    $(OUTDIR_SLASH)AbstractNumberVector.$(O) \
    $(OUTDIR_SLASH)AllocationFailure.$(O) \
    $(OUTDIR_SLASH)AmbiguousMessage.$(O) \
    $(OUTDIR_SLASH)ArithmeticError.$(O) \
    $(OUTDIR_SLASH)AssertionFailedError.$(O) \
    $(OUTDIR_SLASH)AutoloadMetaclass.$(O) \
    $(OUTDIR_SLASH)ByteArray.$(O) \
    $(OUTDIR_SLASH)CharacterArray.$(O) \
    $(OUTDIR_SLASH)CharacterWriteStream.$(O) \
    $(OUTDIR_SLASH)Class.$(O) \
    $(OUTDIR_SLASH)ContextError.$(O) \
    $(OUTDIR_SLASH)ConversionError.$(O) \
    $(OUTDIR_SLASH)DeepCopyError.$(O) \
    $(OUTDIR_SLASH)ExceptionHandlerSet.$(O) \
    $(OUTDIR_SLASH)ExecutionError.$(O) \
    $(OUTDIR_SLASH)ExternalBytes.$(O) \
    $(OUTDIR_SLASH)FixedPoint.$(O) \
    $(OUTDIR_SLASH)Float.$(O) \
    $(OUTDIR_SLASH)ImmutableArray.$(O) \
    $(OUTDIR_SLASH)Infinity.$(O) \
    $(OUTDIR_SLASH)InvalidPatchError.$(O) \
    $(OUTDIR_SLASH)LargeInteger.$(O) \
    $(OUTDIR_SLASH)LongFloat.$(O) \
    $(OUTDIR_SLASH)MessageNotUnderstood.$(O) \
    $(OUTDIR_SLASH)NoModificationError.$(O) \
    $(OUTDIR_SLASH)NotFoundError.$(O) \
    $(OUTDIR_SLASH)OSSignalInterrupt.$(O) \
    $(OUTDIR_SLASH)OsIllegalOperation.$(O) \
    $(OUTDIR_SLASH)OsInaccessibleError.$(O) \
    $(OUTDIR_SLASH)OsInvalidArgumentsError.$(O) \
    $(OUTDIR_SLASH)OsNeedRetryError.$(O) \
    $(OUTDIR_SLASH)OsNoResourcesError.$(O) \
    $(OUTDIR_SLASH)OsNotification.$(O) \
    $(OUTDIR_SLASH)OsTransferFaultError.$(O) \
    $(OUTDIR_SLASH)PrivateMetaclass.$(O) \
    $(OUTDIR_SLASH)ProceedError.$(O) \
    $(OUTDIR_SLASH)ReadWriteStream.$(O) \
    $(OUTDIR_SLASH)ShortFloat.$(O) \
    $(OUTDIR_SLASH)SignalError.$(O) \
    $(OUTDIR_SLASH)SmallInteger.$(O) \
    $(OUTDIR_SLASH)SmalltalkChunkFileSourceWriter.$(O) \
    $(OUTDIR_SLASH)SomeNumber.$(O) \
    $(OUTDIR_SLASH)StreamError.$(O) \
    $(OUTDIR_SLASH)SubclassResponsibilityError.$(O) \
    $(OUTDIR_SLASH)TimeoutError.$(O) \
    $(OUTDIR_SLASH)UnimplementedFunctionalityError.$(O) \
    $(OUTDIR_SLASH)UserPreferences.$(O) \
    $(OUTDIR_SLASH)VarArgCheapBlock.$(O) \
    $(OUTDIR_SLASH)WeakIdentityDictionary.$(O) \
    $(OUTDIR_SLASH)ArgumentError.$(O) \
    $(OUTDIR_SLASH)CannotResumeError.$(O) \
    $(OUTDIR_SLASH)CannotReturnError.$(O) \
    $(OUTDIR_SLASH)CharacterEncoderError.$(O) \
    $(OUTDIR_SLASH)DateConversionError.$(O) \
    $(OUTDIR_SLASH)DomainError.$(O) \
    $(OUTDIR_SLASH)DoubleArray.$(O) \
    $(OUTDIR_SLASH)EndOfStreamError.$(O) \
    $(OUTDIR_SLASH)ExternalStream.$(O) \
    $(OUTDIR_SLASH)ExternalStructure.$(O) \
    $(OUTDIR_SLASH)FloatArray.$(O) \
    $(OUTDIR_SLASH)ImmutableByteArray.$(O) \
    $(OUTDIR_SLASH)IncompleteNextCountError.$(O) \
    $(OUTDIR_SLASH)IndexNotFoundError.$(O) \
    $(OUTDIR_SLASH)InvalidCodeError.$(O) \
    $(OUTDIR_SLASH)InvalidModeError.$(O) \
    $(OUTDIR_SLASH)InvalidOperationError.$(O) \
    $(OUTDIR_SLASH)InvalidTypeError.$(O) \
    $(OUTDIR_SLASH)KeyNotFoundError.$(O) \
    $(OUTDIR_SLASH)MallocFailure.$(O) \
    $(OUTDIR_SLASH)MethodNotAppropriateError.$(O) \
    $(OUTDIR_SLASH)NonBooleanReceiverError.$(O) \
    $(OUTDIR_SLASH)OpenError.$(O) \
    $(OUTDIR_SLASH)PositionError.$(O) \
    $(OUTDIR_SLASH)PositionOutOfBoundsError.$(O) \
    $(OUTDIR_SLASH)PrimitiveFailure.$(O) \
    $(OUTDIR_SLASH)RangeError.$(O) \
    $(OUTDIR_SLASH)ReadError.$(O) \
    $(OUTDIR_SLASH)StreamIOError.$(O) \
    $(OUTDIR_SLASH)StreamNotOpenError.$(O) \
    $(OUTDIR_SLASH)String.$(O) \
    $(OUTDIR_SLASH)TimeConversionError.$(O) \
    $(OUTDIR_SLASH)TwoByteString.$(O) \
    $(OUTDIR_SLASH)UnorderedNumbersError.$(O) \
    $(OUTDIR_SLASH)UnprotectedExternalBytes.$(O) \
    $(OUTDIR_SLASH)WeakDependencyDictionary.$(O) \
    $(OUTDIR_SLASH)WriteError.$(O) \
    $(OUTDIR_SLASH)WrongProceedabilityError.$(O) \
    $(OUTDIR_SLASH)AbstractClassInstantiationError.$(O) \
    $(OUTDIR_SLASH)BadLiteralsError.$(O) \
    $(OUTDIR_SLASH)DecodingError.$(O) \
    $(OUTDIR_SLASH)EncodingError.$(O) \
    $(OUTDIR_SLASH)FileDoesNotExistException.$(O) \
    $(OUTDIR_SLASH)FileStream.$(O) \
    $(OUTDIR_SLASH)ImmutableString.$(O) \
    $(OUTDIR_SLASH)InvalidByteCodeError.$(O) \
    $(OUTDIR_SLASH)InvalidInstructionError.$(O) \
    $(OUTDIR_SLASH)InvalidReadError.$(O) \
    $(OUTDIR_SLASH)InvalidWriteError.$(O) \
    $(OUTDIR_SLASH)NoByteCodeError.$(O) \
    $(OUTDIR_SLASH)NonIntegerIndexError.$(O) \
    $(OUTDIR_SLASH)NonPositionableExternalStream.$(O) \
    $(OUTDIR_SLASH)OverflowError.$(O) \
    $(OUTDIR_SLASH)SubscriptOutOfBoundsError.$(O) \
    $(OUTDIR_SLASH)Symbol.$(O) \
    $(OUTDIR_SLASH)UnderflowError.$(O) \
    $(OUTDIR_SLASH)Unicode16String.$(O) \
    $(OUTDIR_SLASH)WrongNumberOfArgumentsError.$(O) \
    $(OUTDIR_SLASH)ZeroDivide.$(O) \
    $(OUTDIR_SLASH)CharacterRangeError.$(O) \
    $(OUTDIR_SLASH)DirectoryStream.$(O) \
    $(OUTDIR_SLASH)InvalidEncodingError.$(O) \
    $(OUTDIR_SLASH)PipeStream.$(O) \

WIN32_OBJS= \
    $(OUTDIR_SLASH)PCFilename.$(O) \
    $(OUTDIR_SLASH)Win32Constants.$(O) \
    $(OUTDIR_SLASH)Win32FILEHandle.$(O) \
    $(OUTDIR_SLASH)Win32Handle.$(O) \
    $(OUTDIR_SLASH)Win32OperatingSystem.$(O) \
    $(OUTDIR_SLASH)Win32Process.$(O) \