Make.spec
changeset 2593 2eb2739d35c9
parent 2587 e149cfcded61
child 2604 6936feadad8e
equal deleted inserted replaced
2592:ab8fa64095c3 2593:2eb2739d35c9
     1 # $Header: /cvs/stx/stx/libbasic2/Make.spec,v 1.79 2011-08-02 17:48:55 cg Exp $
     1 # $Header: /cvs/stx/stx/libbasic2/Make.spec,v 1.80 2011-08-03 19:23:15 stefan Exp $
     2 #
     2 #
     3 # DO NOT EDIT
     3 # DO NOT EDIT
     4 # automagically generated from the projectDefinition: stx_libbasic2.
     4 # automagically generated from the projectDefinition: stx_libbasic2.
     5 #
     5 #
     6 # Warning: once you modify this file, do not rerun
     6 # Warning: once you modify this file, do not rerun
    50 STCWARNINGS=-warnNonStandard
    50 STCWARNINGS=-warnNonStandard
    51 
    51 
    52 COMMON_CLASSES= \
    52 COMMON_CLASSES= \
    53 	ActorStream \
    53 	ActorStream \
    54 	Archiver \
    54 	Archiver \
       
    55 	BTree \
       
    56 	BackgroundJob \
    55 	BaseNCoder \
    57 	BaseNCoder \
    56 	Bezier \
    58 	Bezier \
    57 	BinaryTree \
    59 	BinaryTree \
    58 	BinaryTreeNode \
    60 	BinaryTreeNode \
    59 	BitArray \
    61 	BitArray \
    60 	BooleanArray \
       
    61 	CRC32Stream \
    62 	CRC32Stream \
    62 	CacheDictionary \
    63 	CacheDictionary \
       
    64 	CharacterSet \
    63 	Circle \
    65 	Circle \
       
    66 	CollectingReadStream \
    64 	CompressionStream \
    67 	CompressionStream \
    65 	Curve \
    68 	Curve \
    66 	DirectoryContents \
    69 	DirectoryContents \
    67 	EllipticalArc \
    70 	EllipticalArc \
    68 	ExternalLong \
    71 	ExternalLong \
    69 	FileSorter \
    72 	FileSorter \
       
    73 	FilteringStream \
    70 	FourByteString \
    74 	FourByteString \
       
    75 	Future \
       
    76 	HTMLUtilities \
       
    77 	Heap \
       
    78 	IncrementNotification \
    71 	InterestConverterWithParameters \
    79 	InterestConverterWithParameters \
    72 	Iterator \
    80 	Iterator \
    73 	JISEncodedString \
    81 	JISEncodedString \
       
    82 	Lazy \
    74 	LineSegment \
    83 	LineSegment \
    75 	Bezier2Segment \
       
    76 	List \
    84 	List \
    77 	MappedCollection \
    85 	MappedCollection \
    78 	Monitor \
    86 	Monitor \
       
    87 	MultiReadStream \
    79 	NameLookupError \
    88 	NameLookupError \
    80 	OrderedDictionary \
    89 	OrderedDictionary \
    81 	OrderedSet \
    90 	OrderedSet \
       
    91 	PhoneticStringUtilities \
    82 	Polygon \
    92 	Polygon \
    83 	PrinterStream \
    93 	PrinterStream \
    84 	PrintfScanf \
    94 	PrintfScanf \
    85 	Promise \
    95 	Promise \
    86 	Queue \
    96 	Queue \
    87 	Random \
    97 	Random \
    88 	RandomGenerator \
    98 	RandomGenerator \
    89 	ReindexedCollection \
    99 	ReindexedCollection \
    90 	RunArray \
   100 	RunArray \
       
   101 	SelectingReadStream \
    91 	SequenceWithSentinel \
   102 	SequenceWithSentinel \
    92 	SharedCollection \
   103 	SharedCollection \
    93 	Singleton \
   104 	Singleton \
    94 	Socket \
   105 	Socket \
    95 	SocketAddress \
   106 	SocketAddress \
    96 	SocketAddressInfo \
   107 	SocketAddressInfo \
    97 	SoundStream \
   108 	SoundStream \
    98 	Spline \
   109 	Spline \
    99 	ArrowedSpline \
       
   100 	Stack \
   110 	Stack \
       
   111 	StringUtilities \
       
   112 	TSTree \
   101 	Text \
   113 	Text \
   102 	TextStream \
   114 	TextStream \
   103 	TimeDuration \
   115 	TimeDuration \
       
   116 	TreeSet \
   104 	URI \
   117 	URI \
   105 	UUID \
   118 	UUID \
   106 	UnboxedIntegerArray \
   119 	UnboxedIntegerArray \
   107 	UndoSupport \
   120 	UndoSupport \
   108 	UnitConverter \
   121 	UnitConverter \
       
   122 	ZipArchiveConstants \
   109 	stx_libbasic2 \
   123 	stx_libbasic2 \
       
   124 	AATree \
       
   125 	AATreeNode \
   110 	Arrow \
   126 	Arrow \
       
   127 	ArrowedSpline \
       
   128 	BackgroundQueueProcessingJob \
   111 	Base32Coder \
   129 	Base32Coder \
   112 	Base64Coder \
   130 	Base64Coder \
       
   131 	Bezier2Segment \
       
   132 	BooleanArray \
   113 	CacheDictionaryWithFactory \
   133 	CacheDictionaryWithFactory \
       
   134 	FilteringLineStream \
   114 	HierarchicalURI \
   135 	HierarchicalURI \
   115 	HostAddressLookupError \
   136 	HostAddressLookupError \
   116 	HostNameLookupError \
   137 	HostNameLookupError \
   117 	IPSocketAddress \
   138 	IPSocketAddress \
   118 	IntegerArray \
   139 	IntegerArray \
       
   140 	LineNumberReadStream \
   119 	LongIntegerArray \
   141 	LongIntegerArray \
   120 	PostscriptPrinterStream \
   142 	PostscriptPrinterStream \
   121 	SharedQueue \
   143 	SharedQueue \
   122 	SignedIntegerArray \
   144 	SignedIntegerArray \
   123 	SignedLongIntegerArray \
   145 	SignedLongIntegerArray \
   124 	SignedWordArray \
   146 	SignedWordArray \
   125 	TimedPromise \
   147 	TimedPromise \
   126 	UDSocketAddress \
   148 	UDSocketAddress \
   127 	Unicode32String \
   149 	Unicode32String \
   128 	WordArray \
   150 	WordArray \
       
   151 	ZipArchive \
   129 	ZipStream \
   152 	ZipStream \
   130 	FileURI \
   153 	FileURI \
   131 	FtpURI \
   154 	FtpURI \
   132 	HttpURI \
   155 	HttpURI \
   133 	IPv6SocketAddress \
   156 	IPv6SocketAddress \
   134 	ZipArchiveConstants \
       
   135 	HTMLUtilities \
       
   136 	IncrementNotification \
       
   137 	PhoneticStringUtilities \
       
   138 	StringUtilities \
       
   139 	AATree \
       
   140 	AATreeNode \
       
   141 	BTree \
       
   142 	TSTree \
       
   143 	TreeSet \
       
   144 	Lazy \
       
   145 	Future \
       
   146 	Heap \
       
   147 	SelectingReadStream \
       
   148 	CollectingReadStream \
       
   149 	FilteringStream \
       
   150 	LineNumberReadStream \
       
   151 	FilteringLineStream \
       
   152 	MultiReadStream \
       
   153 	SftpURI \
   157 	SftpURI \
   154 	ZipArchive \
       
   155 	CharacterSet \
       
   156 	BackgroundJob \
       
   157 	BackgroundQueueProcessingJob \
       
   158 
       
   159 
       
   160 WIN32_CLASSES= \
       
   161 	SerialPort \
       
   162 
   158 
   163 
   159 
   164 
   160 
   165 
   161 
   166 COMMON_OBJS= \
   162 COMMON_OBJS= \
   167     $(OUTDIR)ActorStream.$(O) \
   163     $(OUTDIR)ActorStream.$(O) \
   168     $(OUTDIR)Archiver.$(O) \
   164     $(OUTDIR)Archiver.$(O) \
       
   165     $(OUTDIR)BTree.$(O) \
       
   166     $(OUTDIR)BackgroundJob.$(O) \
   169     $(OUTDIR)BaseNCoder.$(O) \
   167     $(OUTDIR)BaseNCoder.$(O) \
   170     $(OUTDIR)Bezier.$(O) \
   168     $(OUTDIR)Bezier.$(O) \
   171     $(OUTDIR)BinaryTree.$(O) \
   169     $(OUTDIR)BinaryTree.$(O) \
   172     $(OUTDIR)BinaryTreeNode.$(O) \
   170     $(OUTDIR)BinaryTreeNode.$(O) \
   173     $(OUTDIR)BitArray.$(O) \
   171     $(OUTDIR)BitArray.$(O) \
   174     $(OUTDIR)BooleanArray.$(O) \
       
   175     $(OUTDIR)CRC32Stream.$(O) \
   172     $(OUTDIR)CRC32Stream.$(O) \
   176     $(OUTDIR)CacheDictionary.$(O) \
   173     $(OUTDIR)CacheDictionary.$(O) \
       
   174     $(OUTDIR)CharacterSet.$(O) \
   177     $(OUTDIR)Circle.$(O) \
   175     $(OUTDIR)Circle.$(O) \
       
   176     $(OUTDIR)CollectingReadStream.$(O) \
   178     $(OUTDIR)CompressionStream.$(O) \
   177     $(OUTDIR)CompressionStream.$(O) \
   179     $(OUTDIR)Curve.$(O) \
   178     $(OUTDIR)Curve.$(O) \
   180     $(OUTDIR)DirectoryContents.$(O) \
   179     $(OUTDIR)DirectoryContents.$(O) \
   181     $(OUTDIR)EllipticalArc.$(O) \
   180     $(OUTDIR)EllipticalArc.$(O) \
   182     $(OUTDIR)ExternalLong.$(O) \
   181     $(OUTDIR)ExternalLong.$(O) \
   183     $(OUTDIR)FileSorter.$(O) \
   182     $(OUTDIR)FileSorter.$(O) \
       
   183     $(OUTDIR)FilteringStream.$(O) \
   184     $(OUTDIR)FourByteString.$(O) \
   184     $(OUTDIR)FourByteString.$(O) \
       
   185     $(OUTDIR)Future.$(O) \
       
   186     $(OUTDIR)HTMLUtilities.$(O) \
       
   187     $(OUTDIR)Heap.$(O) \
       
   188     $(OUTDIR)IncrementNotification.$(O) \
   185     $(OUTDIR)InterestConverterWithParameters.$(O) \
   189     $(OUTDIR)InterestConverterWithParameters.$(O) \
   186     $(OUTDIR)Iterator.$(O) \
   190     $(OUTDIR)Iterator.$(O) \
   187     $(OUTDIR)JISEncodedString.$(O) \
   191     $(OUTDIR)JISEncodedString.$(O) \
       
   192     $(OUTDIR)Lazy.$(O) \
   188     $(OUTDIR)LineSegment.$(O) \
   193     $(OUTDIR)LineSegment.$(O) \
   189     $(OUTDIR)Bezier2Segment.$(O) \
       
   190     $(OUTDIR)List.$(O) \
   194     $(OUTDIR)List.$(O) \
   191     $(OUTDIR)MappedCollection.$(O) \
   195     $(OUTDIR)MappedCollection.$(O) \
   192     $(OUTDIR)Monitor.$(O) \
   196     $(OUTDIR)Monitor.$(O) \
       
   197     $(OUTDIR)MultiReadStream.$(O) \
   193     $(OUTDIR)NameLookupError.$(O) \
   198     $(OUTDIR)NameLookupError.$(O) \
   194     $(OUTDIR)OrderedDictionary.$(O) \
   199     $(OUTDIR)OrderedDictionary.$(O) \
   195     $(OUTDIR)OrderedSet.$(O) \
   200     $(OUTDIR)OrderedSet.$(O) \
       
   201     $(OUTDIR)PhoneticStringUtilities.$(O) \
   196     $(OUTDIR)Polygon.$(O) \
   202     $(OUTDIR)Polygon.$(O) \
   197     $(OUTDIR)PrinterStream.$(O) \
   203     $(OUTDIR)PrinterStream.$(O) \
   198     $(OUTDIR)PrintfScanf.$(O) \
   204     $(OUTDIR)PrintfScanf.$(O) \
   199     $(OUTDIR)Promise.$(O) \
   205     $(OUTDIR)Promise.$(O) \
   200     $(OUTDIR)Queue.$(O) \
   206     $(OUTDIR)Queue.$(O) \
   201     $(OUTDIR)Random.$(O) \
   207     $(OUTDIR)Random.$(O) \
   202     $(OUTDIR)RandomGenerator.$(O) \
   208     $(OUTDIR)RandomGenerator.$(O) \
   203     $(OUTDIR)ReindexedCollection.$(O) \
   209     $(OUTDIR)ReindexedCollection.$(O) \
   204     $(OUTDIR)RunArray.$(O) \
   210     $(OUTDIR)RunArray.$(O) \
       
   211     $(OUTDIR)SelectingReadStream.$(O) \
   205     $(OUTDIR)SequenceWithSentinel.$(O) \
   212     $(OUTDIR)SequenceWithSentinel.$(O) \
   206     $(OUTDIR)SharedCollection.$(O) \
   213     $(OUTDIR)SharedCollection.$(O) \
   207     $(OUTDIR)Singleton.$(O) \
   214     $(OUTDIR)Singleton.$(O) \
   208     $(OUTDIR)Socket.$(O) \
   215     $(OUTDIR)Socket.$(O) \
   209     $(OUTDIR)SocketAddress.$(O) \
   216     $(OUTDIR)SocketAddress.$(O) \
   210     $(OUTDIR)SocketAddressInfo.$(O) \
   217     $(OUTDIR)SocketAddressInfo.$(O) \
   211     $(OUTDIR)SoundStream.$(O) \
   218     $(OUTDIR)SoundStream.$(O) \
   212     $(OUTDIR)Spline.$(O) \
   219     $(OUTDIR)Spline.$(O) \
   213     $(OUTDIR)ArrowedSpline.$(O) \
       
   214     $(OUTDIR)Stack.$(O) \
   220     $(OUTDIR)Stack.$(O) \
       
   221     $(OUTDIR)StringUtilities.$(O) \
       
   222     $(OUTDIR)TSTree.$(O) \
   215     $(OUTDIR)Text.$(O) \
   223     $(OUTDIR)Text.$(O) \
   216     $(OUTDIR)TextStream.$(O) \
   224     $(OUTDIR)TextStream.$(O) \
   217     $(OUTDIR)TimeDuration.$(O) \
   225     $(OUTDIR)TimeDuration.$(O) \
       
   226     $(OUTDIR)TreeSet.$(O) \
   218     $(OUTDIR)URI.$(O) \
   227     $(OUTDIR)URI.$(O) \
   219     $(OUTDIR)UUID.$(O) \
   228     $(OUTDIR)UUID.$(O) \
   220     $(OUTDIR)UnboxedIntegerArray.$(O) \
   229     $(OUTDIR)UnboxedIntegerArray.$(O) \
   221     $(OUTDIR)UndoSupport.$(O) \
   230     $(OUTDIR)UndoSupport.$(O) \
   222     $(OUTDIR)UnitConverter.$(O) \
   231     $(OUTDIR)UnitConverter.$(O) \
       
   232     $(OUTDIR)ZipArchiveConstants.$(O) \
   223     $(OUTDIR)stx_libbasic2.$(O) \
   233     $(OUTDIR)stx_libbasic2.$(O) \
       
   234     $(OUTDIR)AATree.$(O) \
       
   235     $(OUTDIR)AATreeNode.$(O) \
   224     $(OUTDIR)Arrow.$(O) \
   236     $(OUTDIR)Arrow.$(O) \
       
   237     $(OUTDIR)ArrowedSpline.$(O) \
       
   238     $(OUTDIR)BackgroundQueueProcessingJob.$(O) \
   225     $(OUTDIR)Base32Coder.$(O) \
   239     $(OUTDIR)Base32Coder.$(O) \
   226     $(OUTDIR)Base64Coder.$(O) \
   240     $(OUTDIR)Base64Coder.$(O) \
       
   241     $(OUTDIR)Bezier2Segment.$(O) \
       
   242     $(OUTDIR)BooleanArray.$(O) \
   227     $(OUTDIR)CacheDictionaryWithFactory.$(O) \
   243     $(OUTDIR)CacheDictionaryWithFactory.$(O) \
       
   244     $(OUTDIR)FilteringLineStream.$(O) \
   228     $(OUTDIR)HierarchicalURI.$(O) \
   245     $(OUTDIR)HierarchicalURI.$(O) \
   229     $(OUTDIR)HostAddressLookupError.$(O) \
   246     $(OUTDIR)HostAddressLookupError.$(O) \
   230     $(OUTDIR)HostNameLookupError.$(O) \
   247     $(OUTDIR)HostNameLookupError.$(O) \
   231     $(OUTDIR)IPSocketAddress.$(O) \
   248     $(OUTDIR)IPSocketAddress.$(O) \
   232     $(OUTDIR)IntegerArray.$(O) \
   249     $(OUTDIR)IntegerArray.$(O) \
       
   250     $(OUTDIR)LineNumberReadStream.$(O) \
   233     $(OUTDIR)LongIntegerArray.$(O) \
   251     $(OUTDIR)LongIntegerArray.$(O) \
   234     $(OUTDIR)PostscriptPrinterStream.$(O) \
   252     $(OUTDIR)PostscriptPrinterStream.$(O) \
   235     $(OUTDIR)SharedQueue.$(O) \
   253     $(OUTDIR)SharedQueue.$(O) \
   236     $(OUTDIR)SignedIntegerArray.$(O) \
   254     $(OUTDIR)SignedIntegerArray.$(O) \
   237     $(OUTDIR)SignedLongIntegerArray.$(O) \
   255     $(OUTDIR)SignedLongIntegerArray.$(O) \
   238     $(OUTDIR)SignedWordArray.$(O) \
   256     $(OUTDIR)SignedWordArray.$(O) \
   239     $(OUTDIR)TimedPromise.$(O) \
   257     $(OUTDIR)TimedPromise.$(O) \
   240     $(OUTDIR)UDSocketAddress.$(O) \
   258     $(OUTDIR)UDSocketAddress.$(O) \
   241     $(OUTDIR)Unicode32String.$(O) \
   259     $(OUTDIR)Unicode32String.$(O) \
   242     $(OUTDIR)WordArray.$(O) \
   260     $(OUTDIR)WordArray.$(O) \
       
   261     $(OUTDIR)ZipArchive.$(O) \
   243     $(OUTDIR)ZipStream.$(O) \
   262     $(OUTDIR)ZipStream.$(O) \
   244     $(OUTDIR)FileURI.$(O) \
   263     $(OUTDIR)FileURI.$(O) \
   245     $(OUTDIR)FtpURI.$(O) \
   264     $(OUTDIR)FtpURI.$(O) \
   246     $(OUTDIR)HttpURI.$(O) \
   265     $(OUTDIR)HttpURI.$(O) \
   247     $(OUTDIR)IPv6SocketAddress.$(O) \
   266     $(OUTDIR)IPv6SocketAddress.$(O) \
   248     $(OUTDIR)ZipArchiveConstants.$(O) \
       
   249     $(OUTDIR)HTMLUtilities.$(O) \
       
   250     $(OUTDIR)IncrementNotification.$(O) \
       
   251     $(OUTDIR)PhoneticStringUtilities.$(O) \
       
   252     $(OUTDIR)StringUtilities.$(O) \
       
   253     $(OUTDIR)AATree.$(O) \
       
   254     $(OUTDIR)AATreeNode.$(O) \
       
   255     $(OUTDIR)BTree.$(O) \
       
   256     $(OUTDIR)TSTree.$(O) \
       
   257     $(OUTDIR)TreeSet.$(O) \
       
   258     $(OUTDIR)Lazy.$(O) \
       
   259     $(OUTDIR)Future.$(O) \
       
   260     $(OUTDIR)Heap.$(O) \
       
   261     $(OUTDIR)SelectingReadStream.$(O) \
       
   262     $(OUTDIR)CollectingReadStream.$(O) \
       
   263     $(OUTDIR)FilteringStream.$(O) \
       
   264     $(OUTDIR)LineNumberReadStream.$(O) \
       
   265     $(OUTDIR)FilteringLineStream.$(O) \
       
   266     $(OUTDIR)MultiReadStream.$(O) \
       
   267     $(OUTDIR)SftpURI.$(O) \
   267     $(OUTDIR)SftpURI.$(O) \
   268     $(OUTDIR)ZipArchive.$(O) \
       
   269     $(OUTDIR)CharacterSet.$(O) \
       
   270     $(OUTDIR)BackgroundJob.$(O) \
       
   271     $(OUTDIR)BackgroundQueueProcessingJob.$(O) \
       
   272     $(OUTDIR)extensions.$(O) \
   268     $(OUTDIR)extensions.$(O) \
   273 
   269 
   274 WIN32_OBJS= \
   270 
   275     $(OUTDIR)SerialPort.$(O) \
   271