Make.spec
changeset 2408 4f2d4727d92e
parent 2400 3e1ef51fdae8
child 2454 542d24c56f6a
equal deleted inserted replaced
2407:d06be0e7114d 2408:4f2d4727d92e
     1 # $Header: /cvs/stx/stx/libbasic2/Make.spec,v 1.72 2009-12-11 10:03:29 cg Exp $
     1 # $Header: /cvs/stx/stx/libbasic2/Make.spec,v 1.73 2009-12-14 14:20:10 cg Exp $
     2 #
     2 #
     3 # DO NOT EDIT 
     3 # DO NOT EDIT 
     4 # automagically generated from the projectDefinition: stx_libbasic2.
     4 # automagically generated from the projectDefinition: stx_libbasic2.
     5 #
     5 #
     6 # Warning: once you modify this file, do not rerun
     6 # Warning: once you modify this file, do not rerun
    52 COMMON_CLASSES= \
    52 COMMON_CLASSES= \
    53 	ActorStream \
    53 	ActorStream \
    54 	Archiver \
    54 	Archiver \
    55 	BaseNCoder \
    55 	BaseNCoder \
    56 	Bezier \
    56 	Bezier \
    57 	Bezier2Segment \
       
    58 	BinaryTree \
    57 	BinaryTree \
    59 	BinaryTreeNode \
    58 	BinaryTreeNode \
    60 	BitArray \
    59 	BitArray \
    61 	BooleanArray \
    60 	BooleanArray \
    62 	CRC32Stream \
    61 	CRC32Stream \
    71 	FourByteString \
    70 	FourByteString \
    72 	InterestConverterWithParameters \
    71 	InterestConverterWithParameters \
    73 	Iterator \
    72 	Iterator \
    74 	JISEncodedString \
    73 	JISEncodedString \
    75 	LineSegment \
    74 	LineSegment \
       
    75 	Bezier2Segment \
    76 	List \
    76 	List \
    77 	MappedCollection \
    77 	MappedCollection \
    78 	Monitor \
    78 	Monitor \
    79 	NameLookupError \
    79 	NameLookupError \
    80 	OrderedDictionary \
    80 	OrderedDictionary \
   137 	PhoneticStringUtilities \
   137 	PhoneticStringUtilities \
   138 	StringUtilities \
   138 	StringUtilities \
   139 	AATree \
   139 	AATree \
   140 	AATreeNode \
   140 	AATreeNode \
   141 	BTree \
   141 	BTree \
       
   142 	TSTree \
       
   143 	TreeSet \
   142 	Lazy \
   144 	Lazy \
   143 	Future \
   145 	Future \
   144 	Heap \
   146 	Heap \
   145 	SelectingReadStream \
   147 	SelectingReadStream \
   146 	CollectingReadStream \
   148 	CollectingReadStream \
   157 COMMON_OBJS= \
   159 COMMON_OBJS= \
   158     $(OUTDIR)ActorStream.$(O) \
   160     $(OUTDIR)ActorStream.$(O) \
   159     $(OUTDIR)Archiver.$(O) \
   161     $(OUTDIR)Archiver.$(O) \
   160     $(OUTDIR)BaseNCoder.$(O) \
   162     $(OUTDIR)BaseNCoder.$(O) \
   161     $(OUTDIR)Bezier.$(O) \
   163     $(OUTDIR)Bezier.$(O) \
   162     $(OUTDIR)Bezier2Segment.$(O) \
       
   163     $(OUTDIR)BinaryTree.$(O) \
   164     $(OUTDIR)BinaryTree.$(O) \
   164     $(OUTDIR)BinaryTreeNode.$(O) \
   165     $(OUTDIR)BinaryTreeNode.$(O) \
   165     $(OUTDIR)BitArray.$(O) \
   166     $(OUTDIR)BitArray.$(O) \
   166     $(OUTDIR)BooleanArray.$(O) \
   167     $(OUTDIR)BooleanArray.$(O) \
   167     $(OUTDIR)CRC32Stream.$(O) \
   168     $(OUTDIR)CRC32Stream.$(O) \
   176     $(OUTDIR)FourByteString.$(O) \
   177     $(OUTDIR)FourByteString.$(O) \
   177     $(OUTDIR)InterestConverterWithParameters.$(O) \
   178     $(OUTDIR)InterestConverterWithParameters.$(O) \
   178     $(OUTDIR)Iterator.$(O) \
   179     $(OUTDIR)Iterator.$(O) \
   179     $(OUTDIR)JISEncodedString.$(O) \
   180     $(OUTDIR)JISEncodedString.$(O) \
   180     $(OUTDIR)LineSegment.$(O) \
   181     $(OUTDIR)LineSegment.$(O) \
       
   182     $(OUTDIR)Bezier2Segment.$(O) \
   181     $(OUTDIR)List.$(O) \
   183     $(OUTDIR)List.$(O) \
   182     $(OUTDIR)MappedCollection.$(O) \
   184     $(OUTDIR)MappedCollection.$(O) \
   183     $(OUTDIR)Monitor.$(O) \
   185     $(OUTDIR)Monitor.$(O) \
   184     $(OUTDIR)NameLookupError.$(O) \
   186     $(OUTDIR)NameLookupError.$(O) \
   185     $(OUTDIR)OrderedDictionary.$(O) \
   187     $(OUTDIR)OrderedDictionary.$(O) \
   242     $(OUTDIR)PhoneticStringUtilities.$(O) \
   244     $(OUTDIR)PhoneticStringUtilities.$(O) \
   243     $(OUTDIR)StringUtilities.$(O) \
   245     $(OUTDIR)StringUtilities.$(O) \
   244     $(OUTDIR)AATree.$(O) \
   246     $(OUTDIR)AATree.$(O) \
   245     $(OUTDIR)AATreeNode.$(O) \
   247     $(OUTDIR)AATreeNode.$(O) \
   246     $(OUTDIR)BTree.$(O) \
   248     $(OUTDIR)BTree.$(O) \
       
   249     $(OUTDIR)TSTree.$(O) \
       
   250     $(OUTDIR)TreeSet.$(O) \
   247     $(OUTDIR)Lazy.$(O) \
   251     $(OUTDIR)Lazy.$(O) \
   248     $(OUTDIR)Future.$(O) \
   252     $(OUTDIR)Future.$(O) \
   249     $(OUTDIR)Heap.$(O) \
   253     $(OUTDIR)Heap.$(O) \
   250     $(OUTDIR)SelectingReadStream.$(O) \
   254     $(OUTDIR)SelectingReadStream.$(O) \
   251     $(OUTDIR)CollectingReadStream.$(O) \
   255     $(OUTDIR)CollectingReadStream.$(O) \