Make.spec
author Claus Gittinger <cg@exept.de>
Tue, 26 Feb 2008 11:29:14 +0100
changeset 1930 935b2870be2e
parent 1868 30e4a9c53a66
child 1947 7941b13566e9
permissions -rw-r--r--
arrow points reusable (class protocol)

# $Header: /cvs/stx/stx/libbasic2/Make.spec,v 1.47 2007-03-28 12:16:32 cg Exp $
#
# DO NOT EDIT 
# automagically generated from the projectDefinition: stx_libbasic2.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libbasic2
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -H.         : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace2


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

WIN32_OBJS= \
    $(OUTDIR)SerialPort.$(O) \


COMMON_OBJS= \
    $(OUTDIR)ActorStream.$(O) \
    $(OUTDIR)Archiver.$(O) \
    $(OUTDIR)Base64Coder.$(O) \
    $(OUTDIR)BooleanArray.$(O) \
    $(OUTDIR)CacheDictionary.$(O) \
    $(OUTDIR)CompressionStream.$(O) \
    $(OUTDIR)DirectoryContents.$(O) \
    $(OUTDIR)ExternalLong.$(O) \
    $(OUTDIR)FileSorter.$(O) \
    $(OUTDIR)FourByteString.$(O) \
    $(OUTDIR)InterestConverterWithParameters.$(O) \
    $(OUTDIR)Iterator.$(O) \
    $(OUTDIR)List.$(O) \
    $(OUTDIR)MappedCollection.$(O) \
    $(OUTDIR)Monitor.$(O) \
    $(OUTDIR)NameLookupError.$(O) \
    $(OUTDIR)OrderedDictionary.$(O) \
    $(OUTDIR)OrderedSet.$(O) \
    $(OUTDIR)Polygon.$(O) \
    $(OUTDIR)PrinterStream.$(O) \
    $(OUTDIR)Promise.$(O) \
    $(OUTDIR)Queue.$(O) \
    $(OUTDIR)Random.$(O) \
    $(OUTDIR)RandomGenerator.$(O) \
    $(OUTDIR)ReindexedCollection.$(O) \
    $(OUTDIR)RunArray.$(O) \
    $(OUTDIR)SharedCollection.$(O) \
    $(OUTDIR)Singleton.$(O) \
    $(OUTDIR)Socket.$(O) \
    $(OUTDIR)SocketAddress.$(O) \
    $(OUTDIR)SocketAddressInfo.$(O) \
    $(OUTDIR)SoundStream.$(O) \
    $(OUTDIR)Stack.$(O) \
    $(OUTDIR)Text.$(O) \
    $(OUTDIR)TextStream.$(O) \
    $(OUTDIR)TimeDuration.$(O) \
    $(OUTDIR)URI.$(O) \
    $(OUTDIR)UUID.$(O) \
    $(OUTDIR)UnboxedIntegerArray.$(O) \
    $(OUTDIR)UndoSupport.$(O) \
    $(OUTDIR)UnitConverter.$(O) \
    $(OUTDIR)ZipArchive.$(O) \
    $(OUTDIR)ZipStream.$(O) \
    $(OUTDIR)stx_libbasic2.$(O) \
    $(OUTDIR)BitArray.$(O) \
    $(OUTDIR)CacheDictionaryWithFactory.$(O) \
    $(OUTDIR)HierarchicalURI.$(O) \
    $(OUTDIR)HostAddressLookupError.$(O) \
    $(OUTDIR)HostNameLookupError.$(O) \
    $(OUTDIR)IPSocketAddress.$(O) \
    $(OUTDIR)IntegerArray.$(O) \
    $(OUTDIR)JISEncodedString.$(O) \
    $(OUTDIR)LongIntegerArray.$(O) \
    $(OUTDIR)PostscriptPrinterStream.$(O) \
    $(OUTDIR)SharedQueue.$(O) \
    $(OUTDIR)SignedIntegerArray.$(O) \
    $(OUTDIR)SignedLongIntegerArray.$(O) \
    $(OUTDIR)SignedWordArray.$(O) \
    $(OUTDIR)TimedPromise.$(O) \
    $(OUTDIR)UDSocketAddress.$(O) \
    $(OUTDIR)Unicode32String.$(O) \
    $(OUTDIR)WordArray.$(O) \
    $(OUTDIR)FileURI.$(O) \
    $(OUTDIR)FtpURI.$(O) \
    $(OUTDIR)HttpURI.$(O) \
    $(OUTDIR)IPv6SocketAddress.$(O) \
    $(OUTDIR)SequenceWithSentinel.$(O) \
    $(OUTDIR)extensions.$(O) \