Make.spec
author Claus Gittinger <cg@exept.de>
Wed, 23 Aug 2006 11:08:26 +0200
changeset 1658 d85c2f344d08
parent 1654 eb2d904aa2ca
child 1672 463ee28f18fe
permissions -rw-r--r--
automatically generated by browser

# $Header: /cvs/stx/stx/libbasic2/Make.spec,v 1.25 2006-08-23 09:08:26 cg Exp $
#
# DO NOT EDIT 
# automagically generated from the projectDefinition: stx_libbasic2.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libbasic2
PACKAGE=$(MODULE):$(MODULE_DIR)
LIBNAME=libstx_libbasic2


# Argument(s) to the stc compiler (stc --usage).
#  -H.         : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace2 -warnNonStandard


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=

UNIX_OBJS= \
    Archiver.$(O) \
    BZip2Stream.$(O) \
    ZipStream.$(O) \


WIN32_OBJS= \
    SerialPort.$(O) \


COMMON_OBJS= \
    ActorStream.$(O) \
    Base64Coder.$(O) \
    BooleanArray.$(O) \
    BitArray.$(O) \
    CacheDictionary.$(O) \
    CacheDictionaryWithFactory.$(O) \
    CompressionStream.$(O) \
    DirectoryContents.$(O) \
    FileSorter.$(O) \
    URI.$(O) \
    FourByteString.$(O) \
    HierarchicalURI.$(O) \
    FtpURI.$(O) \
    NameLookupError.$(O) \
    HostNameLookupError.$(O) \
    HttpURI.$(O) \
    SocketAddress.$(O) \
    IPSocketAddress.$(O) \
    UnboxedIntegerArray.$(O) \
    Iterator.$(O) \
    TwoByteString.$(O) \
    List.$(O) \
    LongIntegerArray.$(O) \
    MappedCollection.$(O) \
    Monitor.$(O) \
    HostAddressLookupError.$(O) \
    OrderedDictionary.$(O) \
    OrderedSet.$(O) \
    Polygon.$(O) \
    PrinterStream.$(O) \
    PostscriptPrinterStream.$(O) \
    Promise.$(O) \
    Queue.$(O) \
    Random.$(O) \
    RandomGenerator.$(O) \
    RunArray.$(O) \
    SharedCollection.$(O) \
    SharedQueue.$(O) \
    SignedIntegerArray.$(O) \
    SignedLongIntegerArray.$(O) \
    SignedWordArray.$(O) \
    Singleton.$(O) \
    Socket.$(O) \
    IPv6SocketAddress.$(O) \
    SocketAddressInfo.$(O) \
    SoundStream.$(O) \
    Stack.$(O) \
    Text.$(O) \
    TextStream.$(O) \
    TimeDuration.$(O) \
    TimedPromise.$(O) \
    JISEncodedString.$(O) \
    UDSocketAddress.$(O) \
    FileURI.$(O) \
    UUID.$(O) \
    IntegerArray.$(O) \
    UndoSupport.$(O) \
    Unicode16String.$(O) \
    Unicode32String.$(O) \
    UnitConverter.$(O) \
    WordArray.$(O) \
    ZipArchive.$(O) \
    stx_libbasic2.$(O) \