Make.spec
changeset 1537 067f1da00fef
parent 1535 f3b48b389221
child 1544 dd91b9633beb
--- a/Make.spec	Thu Aug 17 21:41:57 2006 +0200
+++ b/Make.spec	Thu Aug 17 21:42:00 2006 +0200
@@ -1,81 +1,152 @@
-# $Header: /cvs/stx/stx/libbasic3/Make.spec,v 1.6 2006-08-17 15:27:45 cg Exp $
+#
+# DO NOT EDIT 
+# automagically generated from the projectDefinition: stx_libbasic3.
+#
+# Warning: once you modify this file, do not rerun
+# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
+#
+# This file contains specifications which are common to all platforms.
+#
+# This file contains definitions for Unix based platforms.
 #
 
 
+
+
+# module and directory-in-module;
+# these should correspond to the directory hierarchy
+# location (otherwise, ST/X will have a hard time to
+# find out the packages location from its packageID)
 MODULE=stx
 MODULE_DIR=libbasic3
-LIBNAME=libbasic3
-THIS_IS_A_BASE_LIBRARY="yes"
-PACKAGE=$(MODULE):$(LIBNAME)
+
+
+# the name of your classLibrary:
+# ********** REQUIRED: CHECK the next line ***
+LIBNAME=stx_libbasic3
+
+
+# the package is stored as an ID in classes and methods
+# to identify code belonging to this project.
+# It also specifies the position in the source repository
+# and directory tree, when packages are loaded by packageID.
+# ********** REQUIRED: CHECK the next line ***
+PACKAGE=$(MODULE):$(MODULE_DIR)
 
-#
-# these are uncritical - save some bytes by compiling with optspace
+
+# Argument(s) to the stc compiler.
+#  -H.         : create header files locally
+#                (if removed, they will be created as common
+#  -Pxxx       : defines the package
+#  -Zxxx       : a prefix for variables within the classLib
+#  -Dxxx       : defines passed to to CC for inline C-code
+#  -Ixxx       : include path passed to CC for inline C-code
+#  +optspace   : optimized for space
+#  +optspace2  : optimized more for space
+#  +optspace3  : optimized even more for space
+#  +optinline  : generate inline code for some ST constructs
+#  +inlineNew  : additionally inline new
+#  +inlineMath : additionally inline some floatPnt math stuff
 #
-UNCRITICALOBJS=                                  \
-	$(OUTDIR)Change.$(O)                              \
-	  $(OUTDIR)ClassChange.$(O)                       \
-	    $(OUTDIR)ClassCommentChange.$(O)              \
-	    $(OUTDIR)ClassDefinitionChange.$(O)           \
-	    $(OUTDIR)ClassPrimitiveChange.$(O)            \
-	    $(OUTDIR)ClassInstVarDefinitionChange.$(O)    \
-	    $(OUTDIR)ClassOtherChange.$(O)                \
-	    $(OUTDIR)ClassPrimitiveDefinitionsChange.$(O) \
-	    $(OUTDIR)ClassPrimitiveFunctionsChange.$(O)   \
-	    $(OUTDIR)ClassPrimitiveVariablesChange.$(O)   \
-	    $(OUTDIR)ClassRemoveChange.$(O)   \
-	    $(OUTDIR)ClassRenameChange.$(O)   \
-	  $(OUTDIR)MethodChange.$(O)            \
-	    $(OUTDIR)MethodCategoryChange.$(O)  \
-	    $(OUTDIR)MethodCategoryRenameChange.$(O)  \
-	    $(OUTDIR)MethodDefinitionChange.$(O) \
-	    $(OUTDIR)MethodPrivacyChange.$(O)   \
-	    $(OUTDIR)MethodRemoveChange.$(O)    \
-	  $(OUTDIR)NameSpaceCreationChange.$(O) \
-	  $(OUTDIR)DoItChange.$(O)              \
-	  $(OUTDIR)OtherChange.$(O)             \
-	$(OUTDIR)ChangeSet.$(O)                 \
-	$(OUTDIR)HistoryManager.$(O)            \
-	$(OUTDIR)SourceCodeManagerError.$(O)    \
-	$(OUTDIR)AbstractSourceCodeManager.$(O) \
-	  $(OUTDIR)CVSSourceCodeManager.$(O)    \
-	$(OUTDIR)SourceCodeManagerUtilities.$(O) \
-	$(OUTDIR)HTMLDocGenerator.$(O) \
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
+# STCLOCALOPTIMIZATIONS=+optspace3
+STCLOCALOPTIMIZATIONS=+optspace3
 
 
-OBJS=                                            \
-	$(OUTDIR)Change.$(O)                              \
-	  $(OUTDIR)ClassChange.$(O)                       \
-	    $(OUTDIR)ClassCommentChange.$(O)              \
-	    $(OUTDIR)ClassDefinitionChange.$(O)           \
-	    $(OUTDIR)ClassPrimitiveChange.$(O)            \
-	    $(OUTDIR)ClassInstVarDefinitionChange.$(O)    \
-	    $(OUTDIR)ClassOtherChange.$(O)                \
-	    $(OUTDIR)ClassPrimitiveDefinitionsChange.$(O) \
-	    $(OUTDIR)ClassPrimitiveFunctionsChange.$(O)   \
-	    $(OUTDIR)ClassPrimitiveVariablesChange.$(O)   \
-	    $(OUTDIR)ClassRemoveChange.$(O)   \
-	    $(OUTDIR)ClassRenameChange.$(O)   \
-	  $(OUTDIR)MethodChange.$(O)            \
-	    $(OUTDIR)MethodCategoryChange.$(O)  \
-	    $(OUTDIR)MethodCategoryRenameChange.$(O)  \
-	    $(OUTDIR)MethodDefinitionChange.$(O) \
-	    $(OUTDIR)MethodPrivacyChange.$(O)   \
-	    $(OUTDIR)MethodRemoveChange.$(O)    \
-	  $(OUTDIR)NameSpaceCreationChange.$(O) \
-	  $(OUTDIR)DoItChange.$(O)              \
-	  $(OUTDIR)OtherChange.$(O)             \
-	$(OUTDIR)ChangeSet.$(O)                 \
-	$(OUTDIR)HistoryManager.$(O)            \
-	$(OUTDIR)MessageTally.$(O)              \
-	$(OUTDIR)CallChain.$(O)                 \
-	$(OUTDIR)ProfileTree.$(O)               \
-	$(OUTDIR)MessageTracer.$(O)             \
-	$(OUTDIR)WrappedMethod.$(O)             \
-	$(OUTDIR)SourceCodeManagerError.$(O)    \
-	$(OUTDIR)AbstractSourceCodeManager.$(O) \
-	  $(OUTDIR)CVSSourceCodeManager.$(O)    \
-	$(OUTDIR)SourceCodeManagerUtilities.$(O) \
-	$(OUTDIR)HTMLDocGenerator.$(O) \
-        $(OUTDIR)ProjectDefinition.$(O) \
-          $(OUTDIR)LibraryDefinition.$(O) \
-          $(OUTDIR)ApplicationDefinition.$(O) \
+# Argument(s) to the stc compiler.
+#  -warn            : no warnings
+#  -warnNonStandard : no warnings about ST/X extensions
+#  -warnEOLComments : no warnings about EOL comment extension
+#  -warnPrivacy     : no warnings about privateClass extension
+#
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCWARNINGS=-warn
+# STCWARNINGS=-warnNonStandard
+# STCWARNINGS=-warnEOLComments
+STCWARNINGS=
+
+OBJS= \
+    HistoryManager.$(O) \
+    ProjectDefinition.$(O) \
+    Change.$(O) \
+    AbstractTestCases.$(O) \
+    StxPackageFileReader.$(O) \
+    ClassChange.$(O) \
+    ClassDefinitionChange.$(O) \
+    PackagesInstalled.$(O) \
+    NameSpaceCreationChange.$(O) \
+    AbstractPackageBrowser.$(O) \
+    SourceCodeManagerUtilities.$(O) \
+    AbstractPackageNotebookApplication.$(O) \
+    PackageNotification.$(O) \
+    PrerequisiteCollection.$(O) \
+    MethodChange.$(O) \
+    PackageOpener.$(O) \
+    MethodPrivacyChange.$(O) \
+    ClassClassVariableChange.$(O) \
+    SourceCodeManagerError.$(O) \
+    AbstractSourceCodeManager.$(O) \
+    AbstractPackageManager.$(O) \
+    MethodFinder.$(O) \
+    DoItChange.$(O) \
+    Prerequisite.$(O) \
+    LibraryDefinition.$(O) \
+    StoreSourceCodeManager.$(O) \
+    CVSSourceCodeManager.$(O) \
+    ClassOtherChange.$(O) \
+    ClassPrimitiveChange.$(O) \
+    ClassPrimitiveVariablesChange.$(O) \
+    ChangeFaker.$(O) \
+    PackageHandler.$(O) \
+    AbstractPackageDetails.$(O) \
+    PackageDetails.$(O) \
+    ClassPrerequisite.$(O) \
+    PackagePrerequisite.$(O) \
+    NonVersioningSourceCodeManager.$(O) \
+    PackageTestCases.$(O) \
+    PackageManager.$(O) \
+    StxPackageFileHandler.$(O) \
+    FlatDirectorySourceCodeManager.$(O) \
+    OtherChange.$(O) \
+    TimestampChange.$(O) \
+    WrappedMethod.$(O) \
+    RCSSourceCodeManager.$(O) \
+    PackageSelector.$(O) \
+    HTMLDocGenerator.$(O) \
+    ClassPrimitiveDefinitionsChange.$(O) \
+    ClassInstVarDefinitionChange.$(O) \
+    ClassCommentChange.$(O) \
+    ClassRemoveChange.$(O) \
+    ChangesHelper.$(O) \
+    stx_libbasic3.$(O) \
+    PackageProperties.$(O) \
+    StxPackageFileWriter.$(O) \
+    AbstractPackage.$(O) \
+    ClassOrganizer.$(O) \
+    VersionHistory.$(O) \
+    ClassCategoryChange.$(O) \
+    MethodCategoryRenameChange.$(O) \
+    Package.$(O) \
+    DefaultPackage.$(O) \
+    MethodDefinitionChange.$(O) \
+    ClassRenameChange.$(O) \
+    PackageManagerTests.$(O) \
+    PackageSaver.$(O) \
+    DictionaryStack.$(O) \
+    MessageTally.$(O) \
+    SystemOrganizer.$(O) \
+    MethodCategoryChange.$(O) \
+    HierarchicalDirectorySourceCodeManager.$(O) \
+    ClassPrimitiveFunctionsChange.$(O) \
+    MessageTracer.$(O) \
+    PackageSmalltalkManipulationTestCases.$(O) \
+    ApplicationDefinition.$(O) \
+    CallChain.$(O) \
+    ProfileTree.$(O) \
+    PackageError.$(O) \
+    VersionNumber.$(O) \
+    ChangeSet.$(O) \
+    PackageBrowser.$(O) \
+    MethodRemoveChange.$(O) \
+