Make.spec
changeset 1554 07eec26041b6
parent 1544 dd91b9633beb
child 1561 de8350000d3c
--- a/Make.spec	Fri Aug 18 13:19:06 2006 +0200
+++ b/Make.spec	Fri Aug 18 13:19:09 2006 +0200
@@ -1,3 +1,4 @@
+# $Header: /cvs/stx/stx/libbasic3/Make.spec,v 1.9 2006-08-18 11:19:09 cg Exp $
 #
 # DO NOT EDIT 
 # automagically generated from the projectDefinition: stx_libbasic3.
@@ -7,34 +8,17 @@
 #
 # This file contains specifications which are common to all platforms.
 #
-# This file contains definitions for Unix based platforms.
-#
 
-
-
-
-# module and directory-in-module;
-# these should correspond to the directory hierarchy
-# location (otherwise, ST/X will have a hard time to
-# find out the packages location from its packageID)
+# Do NOT CHANGE THESE DEFINITIONS
+# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
+#  to find the source code of a class and to find the library for a package)
 MODULE=stx
 MODULE_DIR=libbasic3
-
-
-# the name of your classLibrary:
-# ********** REQUIRED: CHECK the next line ***
-LIBNAME=stx_libbasic3
-
-
-# the package is stored as an ID in classes and methods
-# to identify code belonging to this project.
-# It also specifies the position in the source repository
-# and directory tree, when packages are loaded by packageID.
-# ********** REQUIRED: CHECK the next line ***
+LIBNAME=libstx_libbasic3
 PACKAGE=$(MODULE):$(MODULE_DIR)
 
 
-# Argument(s) to the stc compiler.
+# Argument(s) to the stc compiler (stc --usage).
 #  -H.         : create header files locally
 #                (if removed, they will be created as common
 #  -Pxxx       : defines the package
@@ -54,7 +38,7 @@
 STCLOCALOPTIMIZATIONS=+optspace3
 
 
-# Argument(s) to the stc compiler.
+# Argument(s) to the stc compiler (stc --usage).
 #  -warn            : no warnings
 #  -warnNonStandard : no warnings about ST/X extensions
 #  -warnEOLComments : no warnings about EOL comment extension
@@ -66,6 +50,7 @@
 # STCWARNINGS=-warnEOLComments
 STCWARNINGS=
 
+
 OBJS= \
     HistoryManager.$(O) \
     ProjectDefinition.$(O) \
@@ -74,10 +59,11 @@
     ClassDefinitionChange.$(O) \
     NameSpaceCreationChange.$(O) \
     SourceCodeManagerUtilities.$(O) \
+    PackageId.$(O) \
     MethodChange.$(O) \
-    MethodPrivacyChange.$(O) \
+    MethodDefinitionChange.$(O) \
+    SourceCodeManagerError.$(O) \
     ClassClassVariableChange.$(O) \
-    SourceCodeManagerError.$(O) \
     AbstractSourceCodeManager.$(O) \
     MethodFinder.$(O) \
     DoItChange.$(O) \
@@ -102,7 +88,7 @@
     ClassOrganizer.$(O) \
     ClassCategoryChange.$(O) \
     MethodCategoryRenameChange.$(O) \
-    MethodDefinitionChange.$(O) \
+    MethodPrivacyChange.$(O) \
     ClassRenameChange.$(O) \
     MessageTally.$(O) \
     SystemOrganizer.$(O) \