experiments/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Sat, 16 Feb 2013 16:15:51 +0000
branchdevelopment
changeset 2077 31f8b995905e
parent 2069 75d40b7b986f
child 2380 9195eccdcbd9
permissions -rw-r--r--
Package stx:libjava/experiments cleanup. Few methods moved to stx:libjava (as they are used by stx:libjava code) Few methods removed - they are no longer used!

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libjava_experiments.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libjava/experiments
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	NoReflectionObject \
	stx_libjava_experiments \
	JavaMethodWrapperCompiler \
	PersonSample \
	SampleHandler \
	SetSample \
	JavaByteCodeInterpreter \
	JavaByteCodeSteppableInterpreter \
	JavaCompiler \




COMMON_OBJS= \
    $(OUTDIR_SLASH)NoReflectionObject.$(O) \
    $(OUTDIR_SLASH)stx_libjava_experiments.$(O) \
    $(OUTDIR_SLASH)JavaMethodWrapperCompiler.$(O) \
    $(OUTDIR_SLASH)PersonSample.$(O) \
    $(OUTDIR_SLASH)SampleHandler.$(O) \
    $(OUTDIR_SLASH)SetSample.$(O) \
    $(OUTDIR_SLASH)JavaByteCodeInterpreter.$(O) \
    $(OUTDIR_SLASH)JavaByteCodeSteppableInterpreter.$(O) \
    $(OUTDIR_SLASH)JavaCompiler.$(O) \