tools/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Tue, 07 May 2013 12:39:09 +0100
branchdevelopment
changeset 2588 58b1e0fd20e7
parent 2546 46baf5ad2310
child 2641 79395ea8b58f
permissions -rw-r--r--
Changed JavaVM>>classForName: to faster JavaVM>>classForName:definedBy:

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libjava_tools.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libjava/tools
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3 -inlinenot


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	JavaCodeBundleEditor \
	JavaCodeLibraryEditor \
	JavaCompilerProblemHighlighter \
	JavaCompilerProblemService \
	JavaListInspectorView \
	JavaMapInspectorView \
	JavaParseNode \
	JavaParseNodeBuilder \
	JavaParserI \
	JavaParser_Eclipse \
	JavaScannerBase \
	JavaSetInspectorView \
	JavaSettingsApplication \
	JavaSourcePartition \
	JavaSourceReference \
	stx_libjava_tools \
	JavaDeclarationWithJavadodNode \
	JavaImportDeclarationNode \
	JavaLiteralNode \
	JavaPackageDeclarationNode \
	JavaParserII \
	JavaScanner \
	JavaSourceFile \
	JavaMethodLikeDeclarationNode \
	JavaParser \
	JavaTypeDeclarationNode \
	JavaAnnotationDeclarationNode \
	JavaClassDeclarationNode \
	JavaConstructorDeclarationNode \
	JavaEnumDeclarationNode \
	JavaInterfaceDeclarationNode \
	JavaSyntaxHighlighter \




COMMON_OBJS= \
    $(OUTDIR_SLASH)JavaCodeBundleEditor.$(O) \
    $(OUTDIR_SLASH)JavaCodeLibraryEditor.$(O) \
    $(OUTDIR_SLASH)JavaCompilerProblemHighlighter.$(O) \
    $(OUTDIR_SLASH)JavaCompilerProblemService.$(O) \
    $(OUTDIR_SLASH)JavaListInspectorView.$(O) \
    $(OUTDIR_SLASH)JavaMapInspectorView.$(O) \
    $(OUTDIR_SLASH)JavaParseNode.$(O) \
    $(OUTDIR_SLASH)JavaParseNodeBuilder.$(O) \
    $(OUTDIR_SLASH)JavaParserI.$(O) \
    $(OUTDIR_SLASH)JavaParser_Eclipse.$(O) \
    $(OUTDIR_SLASH)JavaScannerBase.$(O) \
    $(OUTDIR_SLASH)JavaSetInspectorView.$(O) \
    $(OUTDIR_SLASH)JavaSettingsApplication.$(O) \
    $(OUTDIR_SLASH)JavaSourcePartition.$(O) \
    $(OUTDIR_SLASH)JavaSourceReference.$(O) \
    $(OUTDIR_SLASH)stx_libjava_tools.$(O) \
    $(OUTDIR_SLASH)JavaDeclarationWithJavadodNode.$(O) \
    $(OUTDIR_SLASH)JavaImportDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaLiteralNode.$(O) \
    $(OUTDIR_SLASH)JavaPackageDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaParserII.$(O) \
    $(OUTDIR_SLASH)JavaScanner.$(O) \
    $(OUTDIR_SLASH)JavaSourceFile.$(O) \
    $(OUTDIR_SLASH)JavaMethodLikeDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaParser.$(O) \
    $(OUTDIR_SLASH)JavaTypeDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaAnnotationDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaClassDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaConstructorDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaEnumDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaInterfaceDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaSyntaxHighlighter.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \