tools/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Thu, 31 Jan 2013 15:18:47 +0000
branchrefactoring-vmdata
changeset 2021 75e48299fc2d
parent 2004 160dfe552938
child 2380 9195eccdcbd9
permissions -rw-r--r--
Added a number of unimplemented native methods.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libjava_tools.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libjava/tools
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3 -inlinenot


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	JavaListInspectorView \
	JavaMapInspectorView \
	JavaParseNode \
	JavaParseNodeBuilder \
	JavaParser_Eclipse \
	JavaSetInspectorView \
	stx_libjava_tools \
	JavaCommentNode \
	JavaFormalParameterNode \
	JavaMethodDeclaratorNode \
	JavaMethodNode \
	JavaParserI \
	JavaTypeNode \
	JavaArrayTypeNode \
	JavaBooleanTypeNode \
	JavaCharTypeNode \
	JavaClassOrInterfaceTypeNode \
	JavaDocNode \
	JavaDoubleTypeNode \
	JavaFloatTypeNode \
	JavaIntTypeNode \
	JavaLongTypeNode \
	JavaParserII \
	JavaVoidTypeNode \
	JavaParser \
	JavaScannerBase \
	JavaScanner \
	JavaSyntaxHighlighter \
	JavaSettingsApplication \
	JavaSourceReference \
	JavaCodeBundleEditor \
	JavaCodeLibraryEditor \




COMMON_OBJS= \
    $(OUTDIR_SLASH)JavaListInspectorView.$(O) \
    $(OUTDIR_SLASH)JavaMapInspectorView.$(O) \
    $(OUTDIR_SLASH)JavaParseNode.$(O) \
    $(OUTDIR_SLASH)JavaParseNodeBuilder.$(O) \
    $(OUTDIR_SLASH)JavaParser_Eclipse.$(O) \
    $(OUTDIR_SLASH)JavaSetInspectorView.$(O) \
    $(OUTDIR_SLASH)stx_libjava_tools.$(O) \
    $(OUTDIR_SLASH)JavaCommentNode.$(O) \
    $(OUTDIR_SLASH)JavaFormalParameterNode.$(O) \
    $(OUTDIR_SLASH)JavaMethodDeclaratorNode.$(O) \
    $(OUTDIR_SLASH)JavaMethodNode.$(O) \
    $(OUTDIR_SLASH)JavaParserI.$(O) \
    $(OUTDIR_SLASH)JavaTypeNode.$(O) \
    $(OUTDIR_SLASH)JavaArrayTypeNode.$(O) \
    $(OUTDIR_SLASH)JavaBooleanTypeNode.$(O) \
    $(OUTDIR_SLASH)JavaCharTypeNode.$(O) \
    $(OUTDIR_SLASH)JavaClassOrInterfaceTypeNode.$(O) \
    $(OUTDIR_SLASH)JavaDocNode.$(O) \
    $(OUTDIR_SLASH)JavaDoubleTypeNode.$(O) \
    $(OUTDIR_SLASH)JavaFloatTypeNode.$(O) \
    $(OUTDIR_SLASH)JavaIntTypeNode.$(O) \
    $(OUTDIR_SLASH)JavaLongTypeNode.$(O) \
    $(OUTDIR_SLASH)JavaParserII.$(O) \
    $(OUTDIR_SLASH)JavaVoidTypeNode.$(O) \
    $(OUTDIR_SLASH)JavaParser.$(O) \
    $(OUTDIR_SLASH)JavaScannerBase.$(O) \
    $(OUTDIR_SLASH)JavaScanner.$(O) \
    $(OUTDIR_SLASH)JavaSyntaxHighlighter.$(O) \
    $(OUTDIR_SLASH)JavaSettingsApplication.$(O) \
    $(OUTDIR_SLASH)JavaSourceReference.$(O) \
    $(OUTDIR_SLASH)JavaCodeBundleEditor.$(O) \
    $(OUTDIR_SLASH)JavaCodeLibraryEditor.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \