tools/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Sat, 14 Sep 2013 15:48:03 +0100
branchdevelopment
changeset 2729 ac412f6ea6d4
parent 2717 16564a7101b8
child 2732 7d1a1fb5b01a
permissions -rw-r--r--
More support for method's source display. Not yet working. The behaviour can (whether to show full class source or just method's source) be now controlled by JavaMethod class>>showFullSource: More work has to be done to fully support this.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libjava_tools.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libjava/tools
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3 -inlinenot


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	JavaCodeBundleEditor \
	JavaCodeLibraryEditor \
	JavaCompilerProblemHighlighter \
	JavaCompilerProblemPopup \
	JavaCompilerProblemService \
	JavaListInspectorView \
	JavaMapInspectorView \
	JavaParseNode \
	JavaParseNodeBuilder \
	JavaParserI \
	JavaParser_Eclipse \
	JavaScannerBase \
	JavaSetInspectorView \
	JavaSettingsApplication \
	JavaSourceDocument \
	JavaSourcePartition \
	JavaSourceRef \
	JavaToolbox \
	stx_libjava_tools \
	JavaDeclarationNode \
	JavaImportDeclarationNode \
	JavaLiteralNode \
	JavaPackageDeclarationNode \
	JavaParserII \
	JavaScanner \
	JavaSourceFile \
	JavaCompiler \
	JavaMethodLikeDeclarationNode \
	JavaParser \
	JavaSourceHighlighter \
	JavaTypeDeclarationNode \
	JavaVariableDeclarationNode \
	JavaAnnotationDeclarationNode \
	JavaClassDeclarationNode \
	JavaConstructorDeclarationNode \
	JavaEnumDeclarationNode \
	JavaInterfaceDeclarationNode \
	JavaMethodDeclarationNode \




COMMON_OBJS= \
    $(OUTDIR_SLASH)JavaCodeBundleEditor.$(O) \
    $(OUTDIR_SLASH)JavaCodeLibraryEditor.$(O) \
    $(OUTDIR_SLASH)JavaCompilerProblemHighlighter.$(O) \
    $(OUTDIR_SLASH)JavaCompilerProblemPopup.$(O) \
    $(OUTDIR_SLASH)JavaCompilerProblemService.$(O) \
    $(OUTDIR_SLASH)JavaListInspectorView.$(O) \
    $(OUTDIR_SLASH)JavaMapInspectorView.$(O) \
    $(OUTDIR_SLASH)JavaParseNode.$(O) \
    $(OUTDIR_SLASH)JavaParseNodeBuilder.$(O) \
    $(OUTDIR_SLASH)JavaParserI.$(O) \
    $(OUTDIR_SLASH)JavaParser_Eclipse.$(O) \
    $(OUTDIR_SLASH)JavaScannerBase.$(O) \
    $(OUTDIR_SLASH)JavaSetInspectorView.$(O) \
    $(OUTDIR_SLASH)JavaSettingsApplication.$(O) \
    $(OUTDIR_SLASH)JavaSourceDocument.$(O) \
    $(OUTDIR_SLASH)JavaSourcePartition.$(O) \
    $(OUTDIR_SLASH)JavaSourceRef.$(O) \
    $(OUTDIR_SLASH)JavaToolbox.$(O) \
    $(OUTDIR_SLASH)stx_libjava_tools.$(O) \
    $(OUTDIR_SLASH)JavaDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaImportDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaLiteralNode.$(O) \
    $(OUTDIR_SLASH)JavaPackageDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaParserII.$(O) \
    $(OUTDIR_SLASH)JavaScanner.$(O) \
    $(OUTDIR_SLASH)JavaSourceFile.$(O) \
    $(OUTDIR_SLASH)JavaCompiler.$(O) \
    $(OUTDIR_SLASH)JavaMethodLikeDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaParser.$(O) \
    $(OUTDIR_SLASH)JavaSourceHighlighter.$(O) \
    $(OUTDIR_SLASH)JavaTypeDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaVariableDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaAnnotationDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaClassDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaConstructorDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaEnumDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaInterfaceDeclarationNode.$(O) \
    $(OUTDIR_SLASH)JavaMethodDeclarationNode.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \