benchmarks/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Sat, 15 Dec 2012 23:25:19 +0100
branchdevelopment
changeset 1883 b36e52129040
parent 1818 2e5ed72e7dfd
child 2014 9fa66342102b
permissions -rw-r--r--
Initial implementation of JavaCompiler using Oracle javac toolbox. Not yet finished.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libjava_benchmarks.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libjava/benchmarks
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	JavaBenchmark \
	Ackerman \
	Ary \
	CrossLanguageInvocation \
	Groovy \
	Hash \
	MethodInvocation \
	OverloadedMethods \
	OverloadedMethods2 \
	Saxon \
	Jasper \
	Strcat \
	Threadring \
	stx_libjava_benchmarks \
	JavaBenchmarkRunner \
	ObjectArguments \
	PrimitiveArguments \
	WrappedArguments \




COMMON_OBJS= \
    $(OUTDIR)JavaBenchmark.$(O) \
    $(OUTDIR)Ackerman.$(O) \
    $(OUTDIR)Ary.$(O) \
    $(OUTDIR)CrossLanguageInvocation.$(O) \
    $(OUTDIR)Groovy.$(O) \
    $(OUTDIR)Hash.$(O) \
    $(OUTDIR)MethodInvocation.$(O) \
    $(OUTDIR)OverloadedMethods.$(O) \
    $(OUTDIR)OverloadedMethods2.$(O) \
    $(OUTDIR)Saxon.$(O) \
    $(OUTDIR)Jasper.$(O) \
    $(OUTDIR)Strcat.$(O) \
    $(OUTDIR)Threadring.$(O) \
    $(OUTDIR)stx_libjava_benchmarks.$(O) \
    $(OUTDIR)JavaBenchmarkRunner.$(O) \
    $(OUTDIR)ObjectArguments.$(O) \
    $(OUTDIR)PrimitiveArguments.$(O) \
    $(OUTDIR)WrappedArguments.$(O) \
    $(OUTDIR)extensions.$(O) \