benchmarks/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Wed, 22 May 2013 21:15:02 +0100
branchbuiltin-class-support
changeset 2618 e7757e5d593c
parent 2573 59aeefc96cf4
child 2709 7c8aeacae13e
permissions -rw-r--r--
Initial attempt to generalized builtin class support.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libjava_benchmarks.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libjava/benchmarks
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	JavaBenchmark \
	JavaBenchmarkRunner \
	stx_libjava_benchmarks \
	Ackerman \
	Ary \
	CrossLanguageInvocation \
	Groovy \
	Hash \
	Jasper \
	MethodInvocation \
	ObjectArguments \
	OverloadedMethods \
	OverloadedMethods2 \
	PrimitiveArguments \
	Saxon \
	Strcat \
	Threadring \
	WrappedArguments \




COMMON_OBJS= \
    $(OUTDIR_SLASH)JavaBenchmark.$(O) \
    $(OUTDIR_SLASH)JavaBenchmarkRunner.$(O) \
    $(OUTDIR_SLASH)stx_libjava_benchmarks.$(O) \
    $(OUTDIR_SLASH)Ackerman.$(O) \
    $(OUTDIR_SLASH)Ary.$(O) \
    $(OUTDIR_SLASH)CrossLanguageInvocation.$(O) \
    $(OUTDIR_SLASH)Groovy.$(O) \
    $(OUTDIR_SLASH)Hash.$(O) \
    $(OUTDIR_SLASH)Jasper.$(O) \
    $(OUTDIR_SLASH)MethodInvocation.$(O) \
    $(OUTDIR_SLASH)ObjectArguments.$(O) \
    $(OUTDIR_SLASH)OverloadedMethods.$(O) \
    $(OUTDIR_SLASH)OverloadedMethods2.$(O) \
    $(OUTDIR_SLASH)PrimitiveArguments.$(O) \
    $(OUTDIR_SLASH)Saxon.$(O) \
    $(OUTDIR_SLASH)Strcat.$(O) \
    $(OUTDIR_SLASH)Threadring.$(O) \
    $(OUTDIR_SLASH)WrappedArguments.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \