Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Tue, 24 Sep 2013 23:18:24 +0200
branchinitialV
changeset 1180 01c6be61f29c
parent 702 24213550ccd8
child 761 0c60924971c1
permissions -rw-r--r--
checkin from stx browser

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libjavascript.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libjavascript
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	HTMLDocGeneratorForJavaScript \
	JavaScriptClass \
	JavaScriptClassNode \
	JavaScriptCompletionEngine \
	JavaScriptEnvironment \
	JavaScriptFunction \
	JavaScriptFunctionNode \
	JavaScriptMetaclass \
	JavaScriptObject \
	JavaScriptScanner \
	JavaScriptSourceFileWriter \
	JavaScriptSourceReader \
	JavaScriptVariable \
	JavaScriptVariableNode \
	Math \
	STXJavaScriptLanguage \
	stx_libjavascript \
	JavaScriptFunctionWithBreakpoints \
	JavaScriptInnerFunctionNode \
	JavaScriptParser \
	JavaScriptCompiler \
	JavaScriptCompletionParser \
	JavaScriptSyntaxHighlighter \
	JavaScriptCompilerWithBreakpointSupport \




COMMON_OBJS= \
    $(OUTDIR_SLASH)HTMLDocGeneratorForJavaScript.$(O) \
    $(OUTDIR_SLASH)JavaScriptClass.$(O) \
    $(OUTDIR_SLASH)JavaScriptClassNode.$(O) \
    $(OUTDIR_SLASH)JavaScriptCompletionEngine.$(O) \
    $(OUTDIR_SLASH)JavaScriptEnvironment.$(O) \
    $(OUTDIR_SLASH)JavaScriptFunction.$(O) \
    $(OUTDIR_SLASH)JavaScriptFunctionNode.$(O) \
    $(OUTDIR_SLASH)JavaScriptMetaclass.$(O) \
    $(OUTDIR_SLASH)JavaScriptObject.$(O) \
    $(OUTDIR_SLASH)JavaScriptScanner.$(O) \
    $(OUTDIR_SLASH)JavaScriptSourceFileWriter.$(O) \
    $(OUTDIR_SLASH)JavaScriptSourceReader.$(O) \
    $(OUTDIR_SLASH)JavaScriptVariable.$(O) \
    $(OUTDIR_SLASH)JavaScriptVariableNode.$(O) \
    $(OUTDIR_SLASH)Math.$(O) \
    $(OUTDIR_SLASH)STXJavaScriptLanguage.$(O) \
    $(OUTDIR_SLASH)stx_libjavascript.$(O) \
    $(OUTDIR_SLASH)JavaScriptFunctionWithBreakpoints.$(O) \
    $(OUTDIR_SLASH)JavaScriptInnerFunctionNode.$(O) \
    $(OUTDIR_SLASH)JavaScriptParser.$(O) \
    $(OUTDIR_SLASH)JavaScriptCompiler.$(O) \
    $(OUTDIR_SLASH)JavaScriptCompletionParser.$(O) \
    $(OUTDIR_SLASH)JavaScriptSyntaxHighlighter.$(O) \
    $(OUTDIR_SLASH)JavaScriptCompilerWithBreakpointSupport.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \