mercurial/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Fri, 07 Dec 2012 16:36:27 -0800
changeset 146 1015b8f6dc1c
parent 145 1b8652185a8f
child 150 1813913f6106
permissions -rw-r--r--
Added check for author signature before commit. If author is not specified when commiting, an HGCommitError is raise. Commit dialog checks in advance and shows warning.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libscm_mercurial.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libscm/mercurial
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	HGCommand \
	HGCommandParser \
	HGRepositoryObject \
	HGRepository \
	HGWorkingCopyFile \
	stx_libscm_mercurial \
	HGBranch \
	HGWorkingCopy \
	HGChangesetId \
	HGStatus \
	HGError \
	HGRepositoryError \
	HGCommandError \
	HGChangeset \
	HGPackageModel \
	HGCommitDialog \
	HGIconLibrary \
	HGPackageModelRegistry \
	HGSourceCodeManagementSettingsAppl \
	HGSourceCodeManager \
	HGAuthorQuery \
	HGCommandParseError \
	HGCommitTask \
	HGChangesetFile \
	HGRevisionInfo \
	HGRevisionAnnotation \
	HGNoSuchBranchError \
	HGChange \
	HGConfig \
	HGCommitError \




COMMON_OBJS= \
    $(OUTDIR)HGCommand.$(O) \
    $(OUTDIR)HGCommandParser.$(O) \
    $(OUTDIR)HGRepositoryObject.$(O) \
    $(OUTDIR)HGRepository.$(O) \
    $(OUTDIR)HGWorkingCopyFile.$(O) \
    $(OUTDIR)stx_libscm_mercurial.$(O) \
    $(OUTDIR)HGBranch.$(O) \
    $(OUTDIR)HGWorkingCopy.$(O) \
    $(OUTDIR)HGChangesetId.$(O) \
    $(OUTDIR)HGStatus.$(O) \
    $(OUTDIR)HGError.$(O) \
    $(OUTDIR)HGRepositoryError.$(O) \
    $(OUTDIR)HGCommandError.$(O) \
    $(OUTDIR)HGChangeset.$(O) \
    $(OUTDIR)HGPackageModel.$(O) \
    $(OUTDIR)HGCommitDialog.$(O) \
    $(OUTDIR)HGIconLibrary.$(O) \
    $(OUTDIR)HGPackageModelRegistry.$(O) \
    $(OUTDIR)HGSourceCodeManagementSettingsAppl.$(O) \
    $(OUTDIR)HGSourceCodeManager.$(O) \
    $(OUTDIR)HGAuthorQuery.$(O) \
    $(OUTDIR)HGCommandParseError.$(O) \
    $(OUTDIR)HGCommitTask.$(O) \
    $(OUTDIR)HGChangesetFile.$(O) \
    $(OUTDIR)HGRevisionInfo.$(O) \
    $(OUTDIR)HGRevisionAnnotation.$(O) \
    $(OUTDIR)HGNoSuchBranchError.$(O) \
    $(OUTDIR)HGChange.$(O) \
    $(OUTDIR)HGConfig.$(O) \
    $(OUTDIR)HGCommitError.$(O) \
    $(OUTDIR)extensions.$(O) \