mercurial/Make.spec
author Jan Vrany <jan.vrany@fit.cvut.cz>
Tue, 11 Mar 2014 22:13:44 +0000
changeset 398 65dc8645e496
parent 395 fc0607653d8a
child 399 abafe12d47d6
permissions -rw-r--r--
Added HGChangesetList, a pluggable component to display list of changesets. It takes a repository and a revset and displays all changesets. Selected changeset is kept in a holder.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libscm_mercurial.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libscm/mercurial
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	HG2CVS \
	HGAuthorQuery \
	HGCachedFileData \
	HGChange \
	HGChangesetFile \
	HGChangesetId \
	HGChangesetList \
	HGCommandParser \
	HGCommitDialog \
	HGCommitTask \
	HGDebugFlags \
	HGError \
	HGIconLibrary \
	HGMergeInfo \
	HGMergeTool \
	HGNotification \
	HGPackageModel \
	HGPackageModelRegistry \
	HGPushPullInfo \
	HGRepositoryObject \
	HGRevisionAnnotation \
	HGRevisionInfo \
	HGRevset \
	HGSourceCodeManagementSettingsAppl \
	HGSourceCodeManager \
	HGStatus \
	HGWarning \
	HGWorkingCopyFile \
	stx_libscm_mercurial \
	HGBranch \
	HGChangeset \
	HGCommand \
	HGCommandError \
	HGCommandServer \
	HGCommitError \
	HGConfig \
	HGNoSuchBranchError \
	HGRemote \
	HGRepository \
	HGRepositoryError \
	HGWorkingCopy \
	HGCommandParseError \
	HGInvalidExecutableError \
	HGInvalidVersionError \
	HGPushError \
	HGUnknownRevisionError \
	HGPushWouldCreateNewHeadError \




COMMON_OBJS= \
    $(OUTDIR_SLASH)HG2CVS.$(O) \
    $(OUTDIR_SLASH)HGAuthorQuery.$(O) \
    $(OUTDIR_SLASH)HGCachedFileData.$(O) \
    $(OUTDIR_SLASH)HGChange.$(O) \
    $(OUTDIR_SLASH)HGChangesetFile.$(O) \
    $(OUTDIR_SLASH)HGChangesetId.$(O) \
    $(OUTDIR_SLASH)HGChangesetList.$(O) \
    $(OUTDIR_SLASH)HGCommandParser.$(O) \
    $(OUTDIR_SLASH)HGCommitDialog.$(O) \
    $(OUTDIR_SLASH)HGCommitTask.$(O) \
    $(OUTDIR_SLASH)HGDebugFlags.$(O) \
    $(OUTDIR_SLASH)HGError.$(O) \
    $(OUTDIR_SLASH)HGIconLibrary.$(O) \
    $(OUTDIR_SLASH)HGMergeInfo.$(O) \
    $(OUTDIR_SLASH)HGMergeTool.$(O) \
    $(OUTDIR_SLASH)HGNotification.$(O) \
    $(OUTDIR_SLASH)HGPackageModel.$(O) \
    $(OUTDIR_SLASH)HGPackageModelRegistry.$(O) \
    $(OUTDIR_SLASH)HGPushPullInfo.$(O) \
    $(OUTDIR_SLASH)HGRepositoryObject.$(O) \
    $(OUTDIR_SLASH)HGRevisionAnnotation.$(O) \
    $(OUTDIR_SLASH)HGRevisionInfo.$(O) \
    $(OUTDIR_SLASH)HGRevset.$(O) \
    $(OUTDIR_SLASH)HGSourceCodeManagementSettingsAppl.$(O) \
    $(OUTDIR_SLASH)HGSourceCodeManager.$(O) \
    $(OUTDIR_SLASH)HGStatus.$(O) \
    $(OUTDIR_SLASH)HGWarning.$(O) \
    $(OUTDIR_SLASH)HGWorkingCopyFile.$(O) \
    $(OUTDIR_SLASH)stx_libscm_mercurial.$(O) \
    $(OUTDIR_SLASH)HGBranch.$(O) \
    $(OUTDIR_SLASH)HGChangeset.$(O) \
    $(OUTDIR_SLASH)HGCommand.$(O) \
    $(OUTDIR_SLASH)HGCommandError.$(O) \
    $(OUTDIR_SLASH)HGCommandServer.$(O) \
    $(OUTDIR_SLASH)HGCommitError.$(O) \
    $(OUTDIR_SLASH)HGConfig.$(O) \
    $(OUTDIR_SLASH)HGNoSuchBranchError.$(O) \
    $(OUTDIR_SLASH)HGRemote.$(O) \
    $(OUTDIR_SLASH)HGRepository.$(O) \
    $(OUTDIR_SLASH)HGRepositoryError.$(O) \
    $(OUTDIR_SLASH)HGWorkingCopy.$(O) \
    $(OUTDIR_SLASH)HGCommandParseError.$(O) \
    $(OUTDIR_SLASH)HGInvalidExecutableError.$(O) \
    $(OUTDIR_SLASH)HGInvalidVersionError.$(O) \
    $(OUTDIR_SLASH)HGPushError.$(O) \
    $(OUTDIR_SLASH)HGUnknownRevisionError.$(O) \
    $(OUTDIR_SLASH)HGPushWouldCreateNewHeadError.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \