common/Make.spec
author Jan Vrany <jan.vrany@labware.com>
Fri, 03 Dec 2021 11:40:55 +0000
changeset 934 84b7d3b8f3a6
parent 909 993b38cb97dd
permissions -rw-r--r--
Add comment `HGWorkingCopy >> statusesOf:` ...to ease debugging when assertion fails.

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libscm_common.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libscm/common
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#  -warnUnused      : no warnings about unused variables
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	SCMAbstractDialog \
	SCMAbstractPackageModel \
	SCMAbstractPackageWorkingCopyRegistry \
	SCMAbstractRevisionInfo \
	SCMAbstractSourceCodeManager \
	SCMAbstractTask \
	SCMCodeMonitor \
	SCMCommonPackageModelGroup \
	SCMCommonSourceCodeManagerUtilities \
	SCMCompatModeQuery \
	SCMCopyrightLine \
	SCMCopyrightUpdater \
	SCMError \
	SCMMergeTool \
	SCMMergeToolStartup \
	SCMWarning \
	stx_libscm_common \
	SCMAbstractCommitDialog \
	SCMAbstractFileoutLikeTask \
	SCMAbstractPackageRevision \
	SCMAbstractPackageWorkingCopy \
	SCMPackageModelError \
	SCMPackageModelWarning \
	SCMAbstractCommitTask \




COMMON_OBJS= \
    $(OUTDIR)SCMAbstractDialog.$(O) \
    $(OUTDIR)SCMAbstractPackageModel.$(O) \
    $(OUTDIR)SCMAbstractPackageWorkingCopyRegistry.$(O) \
    $(OUTDIR)SCMAbstractRevisionInfo.$(O) \
    $(OUTDIR)SCMAbstractSourceCodeManager.$(O) \
    $(OUTDIR)SCMAbstractTask.$(O) \
    $(OUTDIR)SCMCodeMonitor.$(O) \
    $(OUTDIR)SCMCommonPackageModelGroup.$(O) \
    $(OUTDIR)SCMCommonSourceCodeManagerUtilities.$(O) \
    $(OUTDIR)SCMCompatModeQuery.$(O) \
    $(OUTDIR)SCMCopyrightLine.$(O) \
    $(OUTDIR)SCMCopyrightUpdater.$(O) \
    $(OUTDIR)SCMError.$(O) \
    $(OUTDIR)SCMMergeTool.$(O) \
    $(OUTDIR)SCMMergeToolStartup.$(O) \
    $(OUTDIR)SCMWarning.$(O) \
    $(OUTDIR)stx_libscm_common.$(O) \
    $(OUTDIR)SCMAbstractCommitDialog.$(O) \
    $(OUTDIR)SCMAbstractFileoutLikeTask.$(O) \
    $(OUTDIR)SCMAbstractPackageRevision.$(O) \
    $(OUTDIR)SCMAbstractPackageWorkingCopy.$(O) \
    $(OUTDIR)SCMPackageModelError.$(O) \
    $(OUTDIR)SCMPackageModelWarning.$(O) \
    $(OUTDIR)SCMAbstractCommitTask.$(O) \
    $(OUTDIR)extensions.$(O) \