mercurial/Make.spec
author vranyj1@bd9d3459-6c23-4dd9-91de-98eeebb81177
Wed, 14 Nov 2012 19:46:42 +0000
changeset 49 ffb879bfafe7
parent 46 d5a192b11a1a
child 51 61700cf82743
permissions -rw-r--r--
- stx_libscm_mercurial changed: #classNamesAndAttributes #extensionMethodNames #preRequisites - HGAuthorQuery added: #version_SVN - HGTests changed: #performTest #test_01a - HGSourceCodeManagementSettingsAppl variable renamed in: #basicReadSettings #basicSaveSettings #hasUnsavedChanges

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libscm_mercurial.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libscm/mercurial
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	HGCommand \
	HGCommandParser \
	HGRepositoryObject \
	HGRepositoryError \
	HGRepository \
	HGWorkingCopyFile \
	stx_libscm_mercurial \
	HGBranch \
	HGWorkingCopy \
	HGNodeId \
	HGStatus \
	HGError \
	HGCommandError \
	HGChangeset \
	HGPackageModel \
	HGCommitDialog \
	HGIconLibrary \
	HGPackageModelRegistry \
	HGSourceCodeManagementSettingsAppl \
	HGSourceCodeManager \
	HGAuthorQuery \




COMMON_OBJS= \
    $(OUTDIR)HGCommand.$(O) \
    $(OUTDIR)HGCommandParser.$(O) \
    $(OUTDIR)HGRepositoryObject.$(O) \
    $(OUTDIR)HGRepositoryError.$(O) \
    $(OUTDIR)HGRepository.$(O) \
    $(OUTDIR)HGWorkingCopyFile.$(O) \
    $(OUTDIR)stx_libscm_mercurial.$(O) \
    $(OUTDIR)HGBranch.$(O) \
    $(OUTDIR)HGWorkingCopy.$(O) \
    $(OUTDIR)HGNodeId.$(O) \
    $(OUTDIR)HGStatus.$(O) \
    $(OUTDIR)HGError.$(O) \
    $(OUTDIR)HGCommandError.$(O) \
    $(OUTDIR)HGChangeset.$(O) \
    $(OUTDIR)HGPackageModel.$(O) \
    $(OUTDIR)HGCommitDialog.$(O) \
    $(OUTDIR)HGIconLibrary.$(O) \
    $(OUTDIR)HGPackageModelRegistry.$(O) \
    $(OUTDIR)HGSourceCodeManagementSettingsAppl.$(O) \
    $(OUTDIR)HGSourceCodeManager.$(O) \
    $(OUTDIR)HGAuthorQuery.$(O) \