Make.spec
branchjv
changeset 16797 4f240085a622
parent 16571 cf319f2e56d0
parent 16790 9d0de5647332
child 16845 4fe165efc72c
equal deleted inserted replaced
16775:8387cd7b2f22 16797:4f240085a622
    20 # Argument(s) to the stc compiler (stc --usage).
    20 # Argument(s) to the stc compiler (stc --usage).
    21 #  -headerDir=. : create header files locally
    21 #  -headerDir=. : create header files locally
    22 #                (if removed, they will be created as common
    22 #                (if removed, they will be created as common
    23 #  -Pxxx       : defines the package
    23 #  -Pxxx       : defines the package
    24 #  -Zxxx       : a prefix for variables within the classLib
    24 #  -Zxxx       : a prefix for variables within the classLib
    25 #  -Dxxx       : defines passed to to CC for inline C-code
    25 #  -Dxxx       : defines passed to CC for inline C-code
    26 #  -Ixxx       : include path passed to CC for inline C-code
    26 #  -Ixxx       : include path passed to CC for inline C-code
    27 #  +optspace   : optimized for space
    27 #  +optspace   : optimized for space
    28 #  +optspace2  : optimized more for space
    28 #  +optspace2  : optimized more for space
    29 #  +optspace3  : optimized even more for space
    29 #  +optspace3  : optimized even more for space
    30 #  +optinline  : generate inline code for some ST constructs
    30 #  +optinline  : generate inline code for some ST constructs
    76 	Diff3Hunk \
    76 	Diff3Hunk \
    77 	Diff3InclusiveVisitor \
    77 	Diff3InclusiveVisitor \
    78 	Diff3TextView \
    78 	Diff3TextView \
    79 	DiffListUtility \
    79 	DiffListUtility \
    80 	DiffTextView \
    80 	DiffTextView \
       
    81 	DisplayObjectView \
    81 	EditFieldWithCompletion \
    82 	EditFieldWithCompletion \
    82 	EditFieldWithCompletionSpec \
    83 	EditFieldWithCompletionSpec \
    83 	FileBrowser \
    84 	FileBrowser \
    84 	FileBrowserV2PanelView \
    85 	FileBrowserV2PanelView \
    85 	FileBrowserV2UISpecifications \
    86 	FileBrowserV2UISpecifications \
   264     $(OUTDIR_SLASH)Diff3Hunk.$(O) \
   265     $(OUTDIR_SLASH)Diff3Hunk.$(O) \
   265     $(OUTDIR_SLASH)Diff3InclusiveVisitor.$(O) \
   266     $(OUTDIR_SLASH)Diff3InclusiveVisitor.$(O) \
   266     $(OUTDIR_SLASH)Diff3TextView.$(O) \
   267     $(OUTDIR_SLASH)Diff3TextView.$(O) \
   267     $(OUTDIR_SLASH)DiffListUtility.$(O) \
   268     $(OUTDIR_SLASH)DiffListUtility.$(O) \
   268     $(OUTDIR_SLASH)DiffTextView.$(O) \
   269     $(OUTDIR_SLASH)DiffTextView.$(O) \
       
   270     $(OUTDIR_SLASH)DisplayObjectView.$(O) \
   269     $(OUTDIR_SLASH)EditFieldWithCompletion.$(O) \
   271     $(OUTDIR_SLASH)EditFieldWithCompletion.$(O) \
   270     $(OUTDIR_SLASH)EditFieldWithCompletionSpec.$(O) \
   272     $(OUTDIR_SLASH)EditFieldWithCompletionSpec.$(O) \
   271     $(OUTDIR_SLASH)FileBrowser.$(O) \
   273     $(OUTDIR_SLASH)FileBrowser.$(O) \
   272     $(OUTDIR_SLASH)FileBrowserV2PanelView.$(O) \
   274     $(OUTDIR_SLASH)FileBrowserV2PanelView.$(O) \
   273     $(OUTDIR_SLASH)FileBrowserV2UISpecifications.$(O) \
   275     $(OUTDIR_SLASH)FileBrowserV2UISpecifications.$(O) \