Make.spec
changeset 5853 00e9ceec47ea
parent 5820 c8ef4c0afb9c
child 5873 5eb04ba6a127
equal deleted inserted replaced
5852:bfd4bf3803bf 5853:00e9ceec47ea
     1 # $Header: /cvs/stx/stx/libview/Make.spec,v 1.50 2011-09-27 16:25:35 cg Exp $
     1 # $Header: /cvs/stx/stx/libview/Make.spec,v 1.51 2012-03-06 13:55:32 stefan Exp $
     2 #
     2 #
     3 # DO NOT EDIT
     3 # DO NOT EDIT
     4 # automagically generated from the projectDefinition: stx_libview.
     4 # automagically generated from the projectDefinition: stx_libview at 2012-03-06 14:55:23.624.
     5 #
     5 #
     6 # Warning: once you modify this file, do not rerun
     6 # Warning: once you modify this file, do not rerun
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
     8 #
     8 #
     9 # This file contains specifications which are common to all platforms.
     9 # This file contains specifications which are common to all platforms.
    16 MODULE_DIR=libview
    16 MODULE_DIR=libview
    17 PACKAGE=$(MODULE):$(MODULE_DIR)
    17 PACKAGE=$(MODULE):$(MODULE_DIR)
    18 
    18 
    19 
    19 
    20 # Argument(s) to the stc compiler (stc --usage).
    20 # Argument(s) to the stc compiler (stc --usage).
    21 #  -H.         : create header files locally
    21 #  -headerDir=. : create header files locally
    22 #                (if removed, they will be created as common
    22 #                (if removed, they will be created as common
    23 #  -Pxxx       : defines the package
    23 #  -Pxxx       : defines the package
    24 #  -Zxxx       : a prefix for variables within the classLib
    24 #  -Zxxx       : a prefix for variables within the classLib
    25 #  -Dxxx       : defines passed to to CC for inline C-code
    25 #  -Dxxx       : defines passed to to CC for inline C-code
    26 #  -Ixxx       : include path passed to CC for inline C-code
    26 #  -Ixxx       : include path passed to CC for inline C-code
    51 
    51 
    52 UNIX_CLASSES= \
    52 UNIX_CLASSES= \
    53 	XEmbedContainerView \
    53 	XEmbedContainerView \
    54 
    54 
    55 COMMON_CLASSES= \
    55 COMMON_CLASSES= \
       
    56 	FontDescription \
    56 	AbstractBorder \
    57 	AbstractBorder \
    57 	Color \
    58 	Color \
    58 	Colormap \
    59 	Colormap \
    59 	ColorPalette \
    60 	ColorPalette \
       
    61 	CompoundFont \
    60 	Controller \
    62 	Controller \
    61 	Cursor \
    63 	Cursor \
    62 	Image \
    64 	Image \
    63 	Depth1Image \
    65 	Depth1Image \
    64 	Depth24Image \
    66 	Depth24Image \
    69 	GraphicsContext \
    71 	GraphicsContext \
    70 	DeviceHandle \
    72 	DeviceHandle \
    71 	GraphicsDevice \
    73 	GraphicsDevice \
    72 	DeviceGraphicsContext \
    74 	DeviceGraphicsContext \
    73 	GraphicsMedium \
    75 	GraphicsMedium \
    74 	FontDescription \
       
    75 	Font \
    76 	Font \
       
    77 	BitmapFont \
    76 	Form \
    78 	Form \
    77 	DisplaySurface \
    79 	DisplaySurface \
    78 	HostGraphicsDevice \
    80 	HostGraphicsDevice \
    79 	DisplayRootView \
    81 	DisplayRootView \
    80 	DeviceWorkstation \
    82 	DeviceWorkstation \
   121 
   123 
   122 UNIX_OBJS= \
   124 UNIX_OBJS= \
   123     $(OUTDIR)XEmbedContainerView.$(O) \
   125     $(OUTDIR)XEmbedContainerView.$(O) \
   124 
   126 
   125 COMMON_OBJS= \
   127 COMMON_OBJS= \
       
   128     $(OUTDIR)FontDescription.$(O) \
   126     $(OUTDIR)AbstractBorder.$(O) \
   129     $(OUTDIR)AbstractBorder.$(O) \
   127     $(OUTDIR)Color.$(O) \
   130     $(OUTDIR)Color.$(O) \
   128     $(OUTDIR)Colormap.$(O) \
   131     $(OUTDIR)Colormap.$(O) \
   129     $(OUTDIR)ColorPalette.$(O) \
   132     $(OUTDIR)ColorPalette.$(O) \
       
   133     $(OUTDIR)CompoundFont.$(O) \
   130     $(OUTDIR)Controller.$(O) \
   134     $(OUTDIR)Controller.$(O) \
   131     $(OUTDIR)Cursor.$(O) \
   135     $(OUTDIR)Cursor.$(O) \
   132     $(OUTDIR)Image.$(O) \
   136     $(OUTDIR)Image.$(O) \
   133     $(OUTDIR)Depth1Image.$(O) \
   137     $(OUTDIR)Depth1Image.$(O) \
   134     $(OUTDIR)Depth24Image.$(O) \
   138     $(OUTDIR)Depth24Image.$(O) \
   139     $(OUTDIR)GraphicsContext.$(O) \
   143     $(OUTDIR)GraphicsContext.$(O) \
   140     $(OUTDIR)DeviceHandle.$(O) \
   144     $(OUTDIR)DeviceHandle.$(O) \
   141     $(OUTDIR)GraphicsDevice.$(O) \
   145     $(OUTDIR)GraphicsDevice.$(O) \
   142     $(OUTDIR)DeviceGraphicsContext.$(O) \
   146     $(OUTDIR)DeviceGraphicsContext.$(O) \
   143     $(OUTDIR)GraphicsMedium.$(O) \
   147     $(OUTDIR)GraphicsMedium.$(O) \
   144     $(OUTDIR)FontDescription.$(O) \
       
   145     $(OUTDIR)Font.$(O) \
   148     $(OUTDIR)Font.$(O) \
       
   149     $(OUTDIR)BitmapFont.$(O) \
   146     $(OUTDIR)Form.$(O) \
   150     $(OUTDIR)Form.$(O) \
   147     $(OUTDIR)DisplaySurface.$(O) \
   151     $(OUTDIR)DisplaySurface.$(O) \
   148     $(OUTDIR)HostGraphicsDevice.$(O) \
   152     $(OUTDIR)HostGraphicsDevice.$(O) \
   149     $(OUTDIR)DisplayRootView.$(O) \
   153     $(OUTDIR)DisplayRootView.$(O) \
   150     $(OUTDIR)DeviceWorkstation.$(O) \
   154     $(OUTDIR)DeviceWorkstation.$(O) \