Make.spec
changeset 4586 1faf4e605274
parent 4581 c001dc3a07b3
child 4595 e6e0d117826d
--- a/Make.spec	Thu Sep 14 16:12:05 2006 +0200
+++ b/Make.spec	Thu Sep 14 16:12:06 2006 +0200
@@ -1,90 +1,111 @@
-# $Header: /cvs/stx/stx/libview/Make.spec,v 1.8 2006-09-14 08:28:06 cg Exp $
+# $Header: /cvs/stx/stx/libview/Make.spec,v 1.9 2006-09-14 14:12:06 cg Exp $
+#
+# DO NOT EDIT 
+# automagically generated from the projectDefinition: stx_libview.
+#
+# Warning: once you modify this file, do not rerun
+# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
+#
+# This file contains specifications which are common to all platforms.
 #
 
+# Do NOT CHANGE THESE DEFINITIONS
+# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
+#  to find the source code of a class and to find the library for a package)
 MODULE=stx
 MODULE_DIR=libview
-LIBNAME=libstx_libview
-THIS_IS_A_BASE_LIBRARY="yes"
 PACKAGE=$(MODULE):$(MODULE_DIR)
 
+
+# Argument(s) to the stc compiler (stc --usage).
+#  -H.         : create header files locally
+#                (if removed, they will be created as common
+#  -Pxxx       : defines the package
+#  -Zxxx       : a prefix for variables within the classLib
+#  -Dxxx       : defines passed to to CC for inline C-code
+#  -Ixxx       : include path passed to CC for inline C-code
+#  +optspace   : optimized for space
+#  +optspace2  : optimized more for space
+#  +optspace3  : optimized even more for space
+#  +optinline  : generate inline code for some ST constructs
+#  +inlineNew  : additionally inline new
+#  +inlineMath : additionally inline some floatPnt math stuff
 #
-# although WinWorkstation is a WIN32-Obj, its not included in libview.dll
-# However, XWorkstation is used in both versions.
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
+# STCLOCALOPTIMIZATIONS=+optspace3
+STCLOCALOPTIMIZATIONS=+optspace3
 
 
+# Argument(s) to the stc compiler (stc --usage).
+#  -warn            : no warnings
+#  -warnNonStandard : no warnings about ST/X extensions
+#  -warnEOLComments : no warnings about EOL comment extension
+#  -warnPrivacy     : no warnings about privateClass extension
+#
+# ********** OPTIONAL: MODIFY the next line(s) ***
+# STCWARNINGS=-warn
+# STCWARNINGS=-warnNonStandard
+# STCWARNINGS=-warnEOLComments
+STCWARNINGS=-warnNonStandard
+
 WIN32_OBJS= \
-	$(OUTDIR)WinWorkstation.$(O)                 \
-	$(OUTDIR)WinPrinter.$(O)
+    $(OUTDIR)WinPrinter.$(O) \
+    $(OUTDIR)WinWorkstation.$(O) \
+
 
 UNIX_OBJS= \
-	$(OUTDIR)XWorkstation.$(O)                   \
-	$(OUTDIR)GLXWorkstation.$(O)
-
-REQUIREDOBJS= \
-	    $(OUTDIR)GraphicsDevice.$(O)             \
-	    $(OUTDIR)HostGraphicsDevice.$(O)         \
-	    $(OUTDIR)DeviceWorkstation.$(O)          \
-	    $(OUTDIR)Image.$(O)                      \
-	      $(OUTDIR)Depth1Image.$(O)              \
-	      $(OUTDIR)Depth2Image.$(O)              \
-	      $(OUTDIR)Depth4Image.$(O)              \
-	      $(OUTDIR)Depth8Image.$(O)              \
-	      $(OUTDIR)Depth24Image.$(O)             \
-	    $(OUTDIR)ImageReader.$(O)
-
-SMALLOBJFILES= \
-	    $(REQUIREDOBJS)
-
-#
-# those can be compiled for space - not time critical
-#
-UNCRITICALOBJS= \
-	  $(OUTDIR)DisplayRootView.$(O)              \
-	  $(OUTDIR)AlphaMask.$(O)
-
-OPENGLOBJS= \
-	  $(OUTDIR)OpenGLConstants.$(O)
+    $(OUTDIR)GLXWorkstation.$(O) \
+    $(OUTDIR)XWorkstation.$(O) \
 
 
-LIBOBJS= \
-	  $(REQUIREDOBJS)                            \
-	    $(OUTDIR)Color.$(O)                      \
-	    $(OUTDIR)Colormap.$(O)                   \
-	      $(OUTDIR)ColorPalette.$(O)             \
-	      $(OUTDIR)MappedPalette.$(O)            \
-	      $(OUTDIR)MonoMappedPalette.$(O)        \
-	    $(OUTDIR)FontDescription.$(O)            \
-	      $(OUTDIR)Font.$(O)                     \
-	    $(OUTDIR)Cursor.$(O)                     \
-	    $(OUTDIR)DeviceHandle.$(O)               \
-	    $(OUTDIR)GraphicsContext.$(O)            \
-	      $(OUTDIR)DeviceGraphicsContext.$(O)    \
-	      $(OUTDIR)GraphicsMedium.$(O)           \
-		  $(OUTDIR)Form.$(O)                 \
-		  $(OUTDIR)DisplaySurface.$(O)       \
-		    $(OUTDIR)SimpleView.$(O)         \
-		      $(OUTDIR)View.$(O)             \
-			$(OUTDIR)TopView.$(O)        \
-			  $(OUTDIR)StandardSystemView.$(O) \
-			    $(OUTDIR)ModalBox.$(O)   \
-			  $(OUTDIR)PopUpView.$(O)    \
-			$(OUTDIR)ShadowView.$(O)     \
-		      $(OUTDIR)DisplayRootView.$(O)  \
-	    $(OUTDIR)Controller.$(O)                 \
-	    $(OUTDIR)WindowingTransformation.$(O)    \
-	    $(OUTDIR)WindowEvent.$(O)                \
-	    $(OUTDIR)WindowGroup.$(O)                \
-	    $(OUTDIR)WindowSensor.$(O)               \
-	      $(OUTDIR)SynchronousWindowSensor.$(O)  \
-	    $(OUTDIR)KeyboardForwarder.$(O)          \
-	    $(OUTDIR)KeyboardMap.$(O)                \
-	    $(OUTDIR)ResourcePack.$(O)               \
-	      $(OUTDIR)ViewStyle.$(O)                \
-	    $(OUTDIR)Depth16Image.$(O)               \
-	    $(OUTDIR)Depth32Image.$(O)               \
-	    $(OUTDIR)ImageMask.$(O)
+COMMON_OBJS= \
+    $(OUTDIR)Color.$(O) \
+    $(OUTDIR)Colormap.$(O) \
+    $(OUTDIR)ColorPalette.$(O) \
+    $(OUTDIR)Controller.$(O) \
+    $(OUTDIR)Cursor.$(O) \
+    $(OUTDIR)Image.$(O) \
+    $(OUTDIR)Depth1Image.$(O) \
+    $(OUTDIR)Depth24Image.$(O) \
+    $(OUTDIR)Depth2Image.$(O) \
+    $(OUTDIR)Depth32Image.$(O) \
+    $(OUTDIR)Depth4Image.$(O) \
+    $(OUTDIR)Depth8Image.$(O) \
+    $(OUTDIR)GraphicsContext.$(O) \
+    $(OUTDIR)DeviceHandle.$(O) \
+    $(OUTDIR)GraphicsDevice.$(O) \
+    $(OUTDIR)DeviceGraphicsContext.$(O) \
+    $(OUTDIR)GraphicsMedium.$(O) \
+    $(OUTDIR)FontDescription.$(O) \
+    $(OUTDIR)Font.$(O) \
+    $(OUTDIR)Form.$(O) \
+    $(OUTDIR)DisplaySurface.$(O) \
+    $(OUTDIR)HostGraphicsDevice.$(O) \
+    $(OUTDIR)DisplayRootView.$(O) \
+    $(OUTDIR)DeviceWorkstation.$(O) \
+    $(OUTDIR)Depth16Image.$(O) \
+    $(OUTDIR)ImageMask.$(O) \
+    $(OUTDIR)ImageReader.$(O) \
+    $(OUTDIR)KeyboardForwarder.$(O) \
+    $(OUTDIR)KeyboardMap.$(O) \
+    $(OUTDIR)MappedPalette.$(O) \
+    $(OUTDIR)SimpleView.$(O) \
+    $(OUTDIR)MonoMappedPalette.$(O) \
+    $(OUTDIR)OpenGLConstants.$(O) \
+    $(OUTDIR)View.$(O) \
+    $(OUTDIR)ResourcePack.$(O) \
+    $(OUTDIR)ShadowView.$(O) \
+    $(OUTDIR)TopView.$(O) \
+    $(OUTDIR)StandardSystemView.$(O) \
+    $(OUTDIR)WindowSensor.$(O) \
+    $(OUTDIR)ModalBox.$(O) \
+    $(OUTDIR)PopUpView.$(O) \
+    $(OUTDIR)ViewStyle.$(O) \
+    $(OUTDIR)WindowEvent.$(O) \
+    $(OUTDIR)WindowGroup.$(O) \
+    $(OUTDIR)SynchronousWindowSensor.$(O) \
+    $(OUTDIR)WindowingTransformation.$(O) \
+    $(OUTDIR)stx_libview.$(O) \
 
-COMMON_OBJS = \
-	  $(LIBOBJS)            \
-	  $(MOREOBJS)           \
-	  $(OPENGLOBJS)
+