Make.spec
author Claus Gittinger <cg@exept.de>
Thu, 05 Nov 2009 18:08:06 +0100
changeset 5488 ec7f28a10660
parent 5400 e7417dc7cdb0
child 5497 bfe534cfe463
permissions -rw-r--r--
automatically generated by browser

# $Header: /cvs/stx/stx/libview/Make.spec,v 1.38 2009-11-05 17:08:06 cg Exp $
#
# DO NOT EDIT 
# automagically generated from the projectDefinition: stx_libview.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libview
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -H.         : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optinline +optinline2


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

WIN32_OBJS= \
    $(OUTDIR)WinWorkstation.$(O) \


COMMON_OBJS= \
    $(OUTDIR)AbstractBorder.$(O) \
    $(OUTDIR)Color.$(O) \
    $(OUTDIR)Colormap.$(O) \
    $(OUTDIR)ColorPalette.$(O) \
    $(OUTDIR)Controller.$(O) \
    $(OUTDIR)Cursor.$(O) \
    $(OUTDIR)Image.$(O) \
    $(OUTDIR)Depth1Image.$(O) \
    $(OUTDIR)Depth24Image.$(O) \
    $(OUTDIR)Depth2Image.$(O) \
    $(OUTDIR)Depth32Image.$(O) \
    $(OUTDIR)Depth4Image.$(O) \
    $(OUTDIR)Depth8Image.$(O) \
    $(OUTDIR)GraphicsContext.$(O) \
    $(OUTDIR)DeviceHandle.$(O) \
    $(OUTDIR)GraphicsDevice.$(O) \
    $(OUTDIR)DeviceGraphicsContext.$(O) \
    $(OUTDIR)GraphicsMedium.$(O) \
    $(OUTDIR)FontDescription.$(O) \
    $(OUTDIR)Font.$(O) \
    $(OUTDIR)Form.$(O) \
    $(OUTDIR)DisplaySurface.$(O) \
    $(OUTDIR)HostGraphicsDevice.$(O) \
    $(OUTDIR)DisplayRootView.$(O) \
    $(OUTDIR)DeviceWorkstation.$(O) \
    $(OUTDIR)Depth16Image.$(O) \
    $(OUTDIR)ImageMask.$(O) \
    $(OUTDIR)ImageReader.$(O) \
    $(OUTDIR)KeyboardForwarder.$(O) \
    $(OUTDIR)KeyboardMap.$(O) \
    $(OUTDIR)MappedPalette.$(O) \
    $(OUTDIR)SimpleView.$(O) \
    $(OUTDIR)MonoMappedPalette.$(O) \
    $(OUTDIR)View.$(O) \
    $(OUTDIR)ResourcePack.$(O) \
    $(OUTDIR)ShadowView.$(O) \
    $(OUTDIR)TopView.$(O) \
    $(OUTDIR)StandardSystemView.$(O) \
    $(OUTDIR)WindowSensor.$(O) \
    $(OUTDIR)ModalBox.$(O) \
    $(OUTDIR)PopUpView.$(O) \
    $(OUTDIR)ViewStyle.$(O) \
    $(OUTDIR)Event.$(O) \
    $(OUTDIR)WindowEvent.$(O) \
    $(OUTDIR)WindowGroup.$(O) \
    $(OUTDIR)SynchronousWindowSensor.$(O) \
    $(OUTDIR)WindowingTransformation.$(O) \
    $(OUTDIR)stx_libview.$(O) \
    $(OUTDIR)Depth48Image.$(O) \
    $(OUTDIR)Depth64Image.$(O) \
    $(OUTDIR)Border.$(O) \
    $(OUTDIR)SimpleBorder.$(O) \
    $(OUTDIR)BeveledBorder.$(O) \
    $(OUTDIR)AbstractBackground.$(O) \
    $(OUTDIR)ImageBackground.$(O) \
    $(OUTDIR)SolidBackground.$(O) \
    $(OUTDIR)NoBackground.$(O) \