Make.spec
changeset 2172 792ca7bf67b2
parent 2167 1585be771e9e
child 2179 61aea51f63ff
equal deleted inserted replaced
2171:82bee47647bd 2172:792ca7bf67b2
    12 # Do NOT CHANGE THESE DEFINITIONS
    12 # Do NOT CHANGE THESE DEFINITIONS
    13 # (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
    13 # (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
    14 #  to find the source code of a class and to find the library for a package)
    14 #  to find the source code of a class and to find the library for a package)
    15 MODULE=stx
    15 MODULE=stx
    16 MODULE_DIR=libview2
    16 MODULE_DIR=libview2
       
    17 PACKAGE=$(MODULE):$(MODULE_DIR)
    17 LIBNAME=libstx_libview2
    18 LIBNAME=libstx_libview2
    18 
    19 
    19 
    20 
    20 # Argument(s) to the stc compiler (stc --usage).
    21 # Argument(s) to the stc compiler (stc --usage).
    21 #  -H.         : create header files locally
    22 #  -H.         : create header files locally
    32 #  +inlineMath : additionally inline some floatPnt math stuff
    33 #  +inlineMath : additionally inline some floatPnt math stuff
    33 #
    34 #
    34 # ********** OPTIONAL: MODIFY the next line(s) ***
    35 # ********** OPTIONAL: MODIFY the next line(s) ***
    35 # STCLOCALOPTIMIZATIONS=+optinline +inlineNew
    36 # STCLOCALOPTIMIZATIONS=+optinline +inlineNew
    36 # STCLOCALOPTIMIZATIONS=+optspace3
    37 # STCLOCALOPTIMIZATIONS=+optspace3
    37 STCLOCALOPTIMIZATIONS=+optspace3
    38 STCLOCALOPTIMIZATIONS=+optspace2 -warnNonStandard
    38 
    39 
    39 
    40 
    40 # Argument(s) to the stc compiler (stc --usage).
    41 # Argument(s) to the stc compiler (stc --usage).
    41 #  -warn            : no warnings
    42 #  -warn            : no warnings
    42 #  -warnNonStandard : no warnings about ST/X extensions
    43 #  -warnNonStandard : no warnings about ST/X extensions
    48 # STCWARNINGS=-warnNonStandard
    49 # STCWARNINGS=-warnNonStandard
    49 # STCWARNINGS=-warnEOLComments
    50 # STCWARNINGS=-warnEOLComments
    50 STCWARNINGS=
    51 STCWARNINGS=
    51 
    52 
    52 COMMON_OBJS= \
    53 COMMON_OBJS= \
    53     EventListener.$(O) \
    54     $(OUTDIR)EventListener.$(O) \
    54     ActiveHelpView.$(O) \
    55     $(OUTDIR)ActiveHelpView.$(O) \
    55     Layout.$(O) \
    56     $(OUTDIR)Layout.$(O) \
    56     Model.$(O) \
    57     $(OUTDIR)Model.$(O) \
    57     ApplicationSubView.$(O) \
    58     $(OUTDIR)ApplicationSubView.$(O) \
    58     ApplicationWindow.$(O) \
    59     $(OUTDIR)ApplicationWindow.$(O) \
    59     ValueModel.$(O) \
    60     $(OUTDIR)ValueModel.$(O) \
    60     BlockValue.$(O) \
    61     $(OUTDIR)BlockValue.$(O) \
    61     ValueHolder.$(O) \
    62     $(OUTDIR)ValueHolder.$(O) \
    62     ColorValue.$(O) \
    63     $(OUTDIR)ColorValue.$(O) \
    63     DisplayObject.$(O) \
    64     $(OUTDIR)DisplayObject.$(O) \
    64     DragAndDropManager.$(O) \
    65     $(OUTDIR)DragAndDropManager.$(O) \
    65     DragHandler.$(O) \
    66     $(OUTDIR)DragHandler.$(O) \
    66     DropContext.$(O) \
    67     $(OUTDIR)DropContext.$(O) \
    67     DropObject.$(O) \
    68     $(OUTDIR)DropObject.$(O) \
    68     DropSource.$(O) \
    69     $(OUTDIR)DropSource.$(O) \
    69     DropTarget.$(O) \
    70     $(OUTDIR)DropTarget.$(O) \
    70     ActiveHelp.$(O) \
    71     $(OUTDIR)ActiveHelp.$(O) \
    71     ExternalTopView.$(O) \
    72     $(OUTDIR)ExternalTopView.$(O) \
    72     FlyByHelp.$(O) \
    73     $(OUTDIR)FlyByHelp.$(O) \
    73     GIFReader.$(O) \
    74     $(OUTDIR)GIFReader.$(O) \
    74     Icon.$(O) \
    75     $(OUTDIR)Icon.$(O) \
    75     IndirectValue.$(O) \
    76     $(OUTDIR)IndirectValue.$(O) \
    76     InputView.$(O) \
    77     $(OUTDIR)InputView.$(O) \
    77     JPEGReader.$(O) \
    78     $(OUTDIR)JPEGReader.$(O) \
    78     KeyboardProcessor.$(O) \
    79     $(OUTDIR)KeyboardProcessor.$(O) \
    79     LayoutOrigin.$(O) \
    80     $(OUTDIR)LayoutOrigin.$(O) \
    80     LayoutFrame.$(O) \
    81     $(OUTDIR)LayoutFrame.$(O) \
    81     AlignmentOrigin.$(O) \
    82     $(OUTDIR)AlignmentOrigin.$(O) \
    82     MIMETypeIconLibrary.$(O) \
    83     $(OUTDIR)MIMETypeIconLibrary.$(O) \
    83     MIMETypes.$(O) \
    84     $(OUTDIR)MIMETypes.$(O) \
    84     Menu.$(O) \
    85     $(OUTDIR)Menu.$(O) \
    85     MenuItem.$(O) \
    86     $(OUTDIR)MenuItem.$(O) \
    86     ApplicationModel.$(O) \
    87     $(OUTDIR)ApplicationModel.$(O) \
    87     MultiImage.$(O) \
    88     $(OUTDIR)MultiImage.$(O) \
    88     Plug.$(O) \
    89     $(OUTDIR)Plug.$(O) \
    89     PluggableAdaptor.$(O) \
    90     $(OUTDIR)PluggableAdaptor.$(O) \
    90     PopUpBanner.$(O) \
    91     $(OUTDIR)PopUpBanner.$(O) \
    91     PrintConverter.$(O) \
    92     $(OUTDIR)PrintConverter.$(O) \
    92     PrinterContext.$(O) \
    93     $(OUTDIR)PrinterContext.$(O) \
    93     PropertyListDictionary.$(O) \
    94     $(OUTDIR)PropertyListDictionary.$(O) \
    94     ProtocolAdaptor.$(O) \
    95     $(OUTDIR)ProtocolAdaptor.$(O) \
    95     ResourceRetriever.$(O) \
    96     $(OUTDIR)ResourceRetriever.$(O) \
    96     ToolApplicationModel.$(O) \
    97     $(OUTDIR)ToolApplicationModel.$(O) \
    97     SimpleDialog.$(O) \
    98     $(OUTDIR)SimpleDialog.$(O) \
    98     StandardSystemController.$(O) \
    99     $(OUTDIR)StandardSystemController.$(O) \
    99     TIFFReader.$(O) \
   100     $(OUTDIR)TIFFReader.$(O) \
   100     ResourceSpecEditor.$(O) \
   101     $(OUTDIR)ResourceSpecEditor.$(O) \
   101     TransparentBox.$(O) \
   102     $(OUTDIR)TransparentBox.$(O) \
   102     TriggerValue.$(O) \
   103     $(OUTDIR)TriggerValue.$(O) \
   103     TypeConverter.$(O) \
   104     $(OUTDIR)TypeConverter.$(O) \
   104     WindowBuilder.$(O) \
   105     $(OUTDIR)WindowBuilder.$(O) \
   105     BufferedValueHolder.$(O) \
   106     $(OUTDIR)BufferedValueHolder.$(O) \
   106     ValueHolderWithWeakDependents.$(O) \
   107     $(OUTDIR)ValueHolderWithWeakDependents.$(O) \
   107     AspectAdaptor.$(O) \
   108     $(OUTDIR)AspectAdaptor.$(O) \
   108     VisualRegion.$(O) \
   109     $(OUTDIR)VisualRegion.$(O) \
   109     UIBuilder.$(O) \
   110     $(OUTDIR)UIBuilder.$(O) \
   110     XBMReader.$(O) \
   111     $(OUTDIR)XBMReader.$(O) \
   111     XPMReader.$(O) \
   112     $(OUTDIR)XPMReader.$(O) \
   112     stx_libview2.$(O) \
   113     $(OUTDIR)stx_libview2.$(O) \
       
   114     extensions.$(O) \
   113 
   115 
   114 
   116