Make.spec
author Claus Gittinger <cg@exept.de>
Wed, 23 Aug 2006 00:07:43 +0200
changeset 2154 0fed4a2bb0fc
parent 2148 cfff8a04d2e6
child 2162 a5f7168f63f0
permissions -rw-r--r--
automatically generated by browser

# $Header$
#
# DO NOT EDIT 
# automagically generated from the projectDefinition: stx_libview2.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libview2
LIBNAME=libstx_libview2


# Argument(s) to the stc compiler (stc --usage).
#  -H.         : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=

COMMON_OBJS= \
    EventListener.$(O) \
    ActiveHelpView.$(O) \
    Layout.$(O) \
    Model.$(O) \
    ApplicationSubView.$(O) \
    ApplicationWindow.$(O) \
    ValueModel.$(O) \
    BlockValue.$(O) \
    ValueHolder.$(O) \
    ColorValue.$(O) \
    DisplayObject.$(O) \
    DragAndDropManager.$(O) \
    DragHandler.$(O) \
    DropContext.$(O) \
    DropObject.$(O) \
    DropSource.$(O) \
    DropTarget.$(O) \
    ActiveHelp.$(O) \
    ExternalTopView.$(O) \
    FlyByHelp.$(O) \
    GIFReader.$(O) \
    Icon.$(O) \
    IndirectValue.$(O) \
    InputView.$(O) \
    JPEGReader.$(O) \
    KeyboardProcessor.$(O) \
    LayoutOrigin.$(O) \
    LayoutFrame.$(O) \
    AlignmentOrigin.$(O) \
    MIMETypeIconLibrary.$(O) \
    MIMETypes.$(O) \
    Menu.$(O) \
    MenuItem.$(O) \
    ApplicationModel.$(O) \
    MultiImage.$(O) \
    Plug.$(O) \
    PluggableAdaptor.$(O) \
    PopUpBanner.$(O) \
    PrintConverter.$(O) \
    PrinterContext.$(O) \
    PropertyListDictionary.$(O) \
    ProtocolAdaptor.$(O) \
    ResourceRetriever.$(O) \
    ToolApplicationModel.$(O) \
    SimpleDialog.$(O) \
    StandardSystemController.$(O) \
    TIFFReader.$(O) \
    ResourceSpecEditor.$(O) \
    TransparentBox.$(O) \
    TriggerValue.$(O) \
    TypeConverter.$(O) \
    WindowBuilder.$(O) \
    BufferedValueHolder.$(O) \
    ValueHolderWithWeakDependents.$(O) \
    AspectAdaptor.$(O) \
    VisualRegion.$(O) \
    UIBuilder.$(O) \
    XBMReader.$(O) \
    XPMReader.$(O) \
    stx_libview2.$(O) \