Make.spec
author Claus Gittinger <cg@exept.de>
Tue, 18 Mar 2014 16:14:17 +0100
changeset 3314 552383bb5952
parent 3272 02a881946bac
child 3369 aaad6901b173
permissions -rw-r--r--
class: ActiveHelpView comment/format in: #for:onDevice:

# $Header$
#
# DO NOT EDIT
# automagically generated from the projectDefinition: stx_libview2.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libview2
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -headerDir=. : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace2 -warnNonStandard


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_CLASSES= \
	ActiveHelpView \
	ApplicationSubView \
	ApplicationWindow \
	ColorValue \
	DisplayObject \
	DragAndDropManager \
	DragHandler \
	DrawAdaptor \
	DropContext \
	DropObject \
	DropSource \
	DropTarget \
	EventListener \
	ExternalTopView \
	GIFReader \
	Icon \
	ImageFrame \
	ImageSequence \
	InputView \
	JPEGReader \
	KeyboardProcessor \
	Layout \
	MIMETypeIconLibrary \
	MIMETypes \
	MacOSXIconReader \
	MenuItem \
	Model \
	MultiImage \
	PNGReader \
	PopUpBanner \
	PrintConverter \
	PrinterContext \
	PropertyListDictionary \
	ResourceRetriever \
	StandardSystemController \
	TIFFReader \
	TransparentBox \
	VisualRegion \
	WindowBuilder \
	WindowsIconReader \
	XBMReader \
	XPMReader \
	stx_libview2 \
	ActiveHelp \
	ApplicationModel \
	LayoutOrigin \
	Menu \
	Plug \
	UIBuilder \
	ValueModel \
	VisualComponent \
	AlignmentOrigin \
	ApplicationWithFileHistory \
	BlockValue \
	FlyByHelp \
	IndirectValue \
	LayoutFrame \
	PluggableAdaptor \
	ProtocolAdaptor \
	SimpleDialog \
	ToolApplicationModel \
	ValueHolder \
	VisualPart \
	AspectAdaptor \
	BooleanBlockValue \
	BooleanValueHolder \
	BufferedValueHolder \
	DictionaryAdaptor \
	RangeAdaptor \
	ResourceSpecEditor \
	TriggerValue \
	TypeConverter \
	ValueHolderWithRememberedPreviousValue \
	ValueHolderWithWeakDependents \
	AspectAdaptorWithDefault \

WIN32_CLASSES= \
	WinPrinterContext \
	WinPrinterStream \

UNIX_CLASSES= \
	ScreenLock \




COMMON_OBJS= \
    $(OUTDIR_SLASH)ActiveHelpView.$(O) \
    $(OUTDIR_SLASH)ApplicationSubView.$(O) \
    $(OUTDIR_SLASH)ApplicationWindow.$(O) \
    $(OUTDIR_SLASH)ColorValue.$(O) \
    $(OUTDIR_SLASH)DisplayObject.$(O) \
    $(OUTDIR_SLASH)DragAndDropManager.$(O) \
    $(OUTDIR_SLASH)DragHandler.$(O) \
    $(OUTDIR_SLASH)DrawAdaptor.$(O) \
    $(OUTDIR_SLASH)DropContext.$(O) \
    $(OUTDIR_SLASH)DropObject.$(O) \
    $(OUTDIR_SLASH)DropSource.$(O) \
    $(OUTDIR_SLASH)DropTarget.$(O) \
    $(OUTDIR_SLASH)EventListener.$(O) \
    $(OUTDIR_SLASH)ExternalTopView.$(O) \
    $(OUTDIR_SLASH)GIFReader.$(O) \
    $(OUTDIR_SLASH)Icon.$(O) \
    $(OUTDIR_SLASH)ImageFrame.$(O) \
    $(OUTDIR_SLASH)ImageSequence.$(O) \
    $(OUTDIR_SLASH)InputView.$(O) \
    $(OUTDIR_SLASH)JPEGReader.$(O) \
    $(OUTDIR_SLASH)KeyboardProcessor.$(O) \
    $(OUTDIR_SLASH)Layout.$(O) \
    $(OUTDIR_SLASH)MIMETypeIconLibrary.$(O) \
    $(OUTDIR_SLASH)MIMETypes.$(O) \
    $(OUTDIR_SLASH)MacOSXIconReader.$(O) \
    $(OUTDIR_SLASH)MenuItem.$(O) \
    $(OUTDIR_SLASH)Model.$(O) \
    $(OUTDIR_SLASH)MultiImage.$(O) \
    $(OUTDIR_SLASH)PNGReader.$(O) \
    $(OUTDIR_SLASH)PopUpBanner.$(O) \
    $(OUTDIR_SLASH)PrintConverter.$(O) \
    $(OUTDIR_SLASH)PrinterContext.$(O) \
    $(OUTDIR_SLASH)PropertyListDictionary.$(O) \
    $(OUTDIR_SLASH)ResourceRetriever.$(O) \
    $(OUTDIR_SLASH)StandardSystemController.$(O) \
    $(OUTDIR_SLASH)TIFFReader.$(O) \
    $(OUTDIR_SLASH)TransparentBox.$(O) \
    $(OUTDIR_SLASH)VisualRegion.$(O) \
    $(OUTDIR_SLASH)WindowBuilder.$(O) \
    $(OUTDIR_SLASH)WindowsIconReader.$(O) \
    $(OUTDIR_SLASH)XBMReader.$(O) \
    $(OUTDIR_SLASH)XPMReader.$(O) \
    $(OUTDIR_SLASH)stx_libview2.$(O) \
    $(OUTDIR_SLASH)ActiveHelp.$(O) \
    $(OUTDIR_SLASH)ApplicationModel.$(O) \
    $(OUTDIR_SLASH)LayoutOrigin.$(O) \
    $(OUTDIR_SLASH)Menu.$(O) \
    $(OUTDIR_SLASH)Plug.$(O) \
    $(OUTDIR_SLASH)UIBuilder.$(O) \
    $(OUTDIR_SLASH)ValueModel.$(O) \
    $(OUTDIR_SLASH)VisualComponent.$(O) \
    $(OUTDIR_SLASH)AlignmentOrigin.$(O) \
    $(OUTDIR_SLASH)ApplicationWithFileHistory.$(O) \
    $(OUTDIR_SLASH)BlockValue.$(O) \
    $(OUTDIR_SLASH)FlyByHelp.$(O) \
    $(OUTDIR_SLASH)IndirectValue.$(O) \
    $(OUTDIR_SLASH)LayoutFrame.$(O) \
    $(OUTDIR_SLASH)PluggableAdaptor.$(O) \
    $(OUTDIR_SLASH)ProtocolAdaptor.$(O) \
    $(OUTDIR_SLASH)SimpleDialog.$(O) \
    $(OUTDIR_SLASH)ToolApplicationModel.$(O) \
    $(OUTDIR_SLASH)ValueHolder.$(O) \
    $(OUTDIR_SLASH)VisualPart.$(O) \
    $(OUTDIR_SLASH)AspectAdaptor.$(O) \
    $(OUTDIR_SLASH)BooleanBlockValue.$(O) \
    $(OUTDIR_SLASH)BooleanValueHolder.$(O) \
    $(OUTDIR_SLASH)BufferedValueHolder.$(O) \
    $(OUTDIR_SLASH)DictionaryAdaptor.$(O) \
    $(OUTDIR_SLASH)RangeAdaptor.$(O) \
    $(OUTDIR_SLASH)ResourceSpecEditor.$(O) \
    $(OUTDIR_SLASH)TriggerValue.$(O) \
    $(OUTDIR_SLASH)TypeConverter.$(O) \
    $(OUTDIR_SLASH)ValueHolderWithRememberedPreviousValue.$(O) \
    $(OUTDIR_SLASH)ValueHolderWithWeakDependents.$(O) \
    $(OUTDIR_SLASH)AspectAdaptorWithDefault.$(O) \
    $(OUTDIR_SLASH)extensions.$(O) \

WIN32_OBJS= \
    $(OUTDIR_SLASH)WinPrinterContext.$(O) \
    $(OUTDIR_SLASH)WinPrinterStream.$(O) \

UNIX_OBJS= \
    $(OUTDIR_SLASH)ScreenLock.$(O) \