Make.spec
author Claus Gittinger <cg@exept.de>
Wed, 03 Dec 2008 13:01:23 +0100
changeset 2575 a6cf69a6c165
parent 2505 b479caa3539b
child 2639 6302469a896c
permissions -rw-r--r--
automatically generated by browser

# $Header$
#
# DO NOT EDIT 
# automagically generated from the projectDefinition: stx_libview2.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libview2
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -H.         : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace2 -warnNonStandard


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

WIN32_OBJS= \
    $(OUTDIR)WinPrinterStream.$(O) \
    $(OUTDIR)WinPrinterContext.$(O) \


COMMON_OBJS= \
    $(OUTDIR)ActiveHelpView.$(O) \
    $(OUTDIR)ApplicationSubView.$(O) \
    $(OUTDIR)ApplicationWindow.$(O) \
    $(OUTDIR)ColorValue.$(O) \
    $(OUTDIR)DisplayObject.$(O) \
    $(OUTDIR)DragAndDropManager.$(O) \
    $(OUTDIR)DragHandler.$(O) \
    $(OUTDIR)DropContext.$(O) \
    $(OUTDIR)DropObject.$(O) \
    $(OUTDIR)DropSource.$(O) \
    $(OUTDIR)DropTarget.$(O) \
    $(OUTDIR)EventListener.$(O) \
    $(OUTDIR)ExternalTopView.$(O) \
    $(OUTDIR)GIFReader.$(O) \
    $(OUTDIR)Icon.$(O) \
    $(OUTDIR)InputView.$(O) \
    $(OUTDIR)JPEGReader.$(O) \
    $(OUTDIR)KeyboardProcessor.$(O) \
    $(OUTDIR)Layout.$(O) \
    $(OUTDIR)MIMETypeIconLibrary.$(O) \
    $(OUTDIR)MIMETypes.$(O) \
    $(OUTDIR)Menu.$(O) \
    $(OUTDIR)MenuItem.$(O) \
    $(OUTDIR)Model.$(O) \
    $(OUTDIR)MultiImage.$(O) \
    $(OUTDIR)PopUpBanner.$(O) \
    $(OUTDIR)PrintConverter.$(O) \
    $(OUTDIR)PrinterContext.$(O) \
    $(OUTDIR)PropertyListDictionary.$(O) \
    $(OUTDIR)ResourceRetriever.$(O) \
    $(OUTDIR)StandardSystemController.$(O) \
    $(OUTDIR)TIFFReader.$(O) \
    $(OUTDIR)TransparentBox.$(O) \
    $(OUTDIR)VisualComponent.$(O) \
    $(OUTDIR)VisualRegion.$(O) \
    $(OUTDIR)WindowBuilder.$(O) \
    $(OUTDIR)WindowsIconReader.$(O) \
    $(OUTDIR)XBMReader.$(O) \
    $(OUTDIR)XPMReader.$(O) \
    $(OUTDIR)stx_libview2.$(O) \
    $(OUTDIR)ActiveHelp.$(O) \
    $(OUTDIR)ApplicationModel.$(O) \
    $(OUTDIR)LayoutOrigin.$(O) \
    $(OUTDIR)Plug.$(O) \
    $(OUTDIR)UIBuilder.$(O) \
    $(OUTDIR)ValueModel.$(O) \
    $(OUTDIR)VisualPart.$(O) \
    $(OUTDIR)AlignmentOrigin.$(O) \
    $(OUTDIR)BlockValue.$(O) \
    $(OUTDIR)FlyByHelp.$(O) \
    $(OUTDIR)IndirectValue.$(O) \
    $(OUTDIR)LayoutFrame.$(O) \
    $(OUTDIR)PluggableAdaptor.$(O) \
    $(OUTDIR)ProtocolAdaptor.$(O) \
    $(OUTDIR)SimpleDialog.$(O) \
    $(OUTDIR)ToolApplicationModel.$(O) \
    $(OUTDIR)ValueHolder.$(O) \
    $(OUTDIR)AspectAdaptor.$(O) \
    $(OUTDIR)BufferedValueHolder.$(O) \
    $(OUTDIR)DictionaryAdaptor.$(O) \
    $(OUTDIR)RangeAdaptor.$(O) \
    $(OUTDIR)ResourceSpecEditor.$(O) \
    $(OUTDIR)TriggerValue.$(O) \
    $(OUTDIR)TypeConverter.$(O) \
    $(OUTDIR)ValueHolderWithWeakDependents.$(O) \
    $(OUTDIR)BooleanValueHolder.$(O) \
    $(OUTDIR)BooleanBlockValue.$(O) \
    $(OUTDIR)DrawAdaptor.$(O) \