Make.spec
changeset 3946 ec46202b83bf
parent 3801 4d4e1f213927
child 4004 cf3f1c360f0a
equal deleted inserted replaced
3945:148fc9f5a883 3946:ec46202b83bf
     1 # $Header: /cvs/stx/stx/libwidg2/Make.spec,v 1.34 2009-10-20 14:13:44 cg Exp $
     1 # $Header: /cvs/stx/stx/libwidg2/Make.spec,v 1.35 2010-10-19 15:06:04 cg Exp $
     2 #
     2 #
     3 # DO NOT EDIT 
     3 # DO NOT EDIT 
     4 # automagically generated from the projectDefinition: stx_libwidg2.
     4 # automagically generated from the projectDefinition: stx_libwidg2.
     5 #
     5 #
     6 # Warning: once you modify this file, do not rerun
     6 # Warning: once you modify this file, do not rerun
    46 # ********** OPTIONAL: MODIFY the next line(s) ***
    46 # ********** OPTIONAL: MODIFY the next line(s) ***
    47 # STCWARNINGS=-warn
    47 # STCWARNINGS=-warn
    48 # STCWARNINGS=-warnNonStandard
    48 # STCWARNINGS=-warnNonStandard
    49 # STCWARNINGS=-warnEOLComments
    49 # STCWARNINGS=-warnEOLComments
    50 STCWARNINGS=-warnNonStandard
    50 STCWARNINGS=-warnNonStandard
       
    51 
       
    52 COMMON_CLASSES= \
       
    53 	CharacterSetView \
       
    54 	CheckBox \
       
    55 	MenuPanel \
       
    56 	ComboBoxButton \
       
    57 	ComboView \
       
    58 	ComboListView \
       
    59 	ComboBoxView \
       
    60 	DSVColumnView \
       
    61 	DSVLabelView \
       
    62 	DataSetColumn \
       
    63 	DataSetLabel \
       
    64 	DataSetView \
       
    65 	DoWhatIMeanSupport \
       
    66 	EnterBoxWithList \
       
    67 	ExtendedComboBox \
       
    68 	TreeItem \
       
    69 	SelectionInTreeView \
       
    70 	FilenameComboBoxView \
       
    71 	FilenameEditField \
       
    72 	FilenameEnterBox \
       
    73 	FontMenu \
       
    74 	GridBagConstraints \
       
    75 	GridBagLayoutInfo \
       
    76 	GridBagLayoutView \
       
    77 	HierarchicalItem \
       
    78 	HierarchicalList \
       
    79 	HierarchicalItemWithLabel \
       
    80 	HierarchicalItemWithLabelAndIcon \
       
    81 	HierarchicalItemWithLabelAndIconAndValue \
       
    82 	HierarchicalFileList \
       
    83 	ListModelView \
       
    84 	HierarchyNode \
       
    85 	Slider \
       
    86 	ImageView \
       
    87 	ImageEditView \
       
    88 	ListEntry \
       
    89 	LabelledEnterField \
       
    90 	ModelListEntry \
       
    91 	SelectionInListModelView \
       
    92 	ColorMenu \
       
    93 	LabelAndIcon \
       
    94 	MultiColListEntry \
       
    95 	MultipleItemSelectionWidget \
       
    96 	NoteBookView \
       
    97 	PrintAbortDialog \
       
    98 	PrintingDialog \
       
    99 	ProgressIndicator \
       
   100 	SelectionInHierarchy \
       
   101 	HierarchicalListView \
       
   102 	SelectionInTree \
       
   103 	FileSelectionTree \
       
   104 	Separator \
       
   105 	HorizontalSlider \
       
   106 	SubCanvas \
       
   107 	SyncedMultiColumnTextView \
       
   108 	TabItem \
       
   109 	TabSpecRuler \
       
   110 	TabView \
       
   111 	TabWidget \
       
   112 	TabulatorSpecification \
       
   113 	TextBox \
       
   114 	FileSelectionItem \
       
   115 	TreeItemWithImage \
       
   116 	TwoColumnTextView \
       
   117 	UpDownButton \
       
   118 	ViewScroller \
       
   119 	stx_libwidg2 \
       
   120 	FilenameWidgetWithHistory \
       
   121 	HierarchicalDropTargetController \
       
   122 	LinkButton \
       
   123 	LinkButtonController \
       
   124 	LabelAndTwoIcons \
       
   125 	AssistantApplication \
       
   126 	FilenameWidgetWithoutHistory \
       
   127 	LicenceBox \
       
   128 
       
   129 
       
   130 
    51 
   131 
    52 COMMON_OBJS= \
   132 COMMON_OBJS= \
    53     $(OUTDIR)CharacterSetView.$(O) \
   133     $(OUTDIR)CharacterSetView.$(O) \
    54     $(OUTDIR)CheckBox.$(O) \
   134     $(OUTDIR)CheckBox.$(O) \
    55     $(OUTDIR)MenuPanel.$(O) \
   135     $(OUTDIR)MenuPanel.$(O) \
   121     $(OUTDIR)HierarchicalDropTargetController.$(O) \
   201     $(OUTDIR)HierarchicalDropTargetController.$(O) \
   122     $(OUTDIR)LinkButton.$(O) \
   202     $(OUTDIR)LinkButton.$(O) \
   123     $(OUTDIR)LinkButtonController.$(O) \
   203     $(OUTDIR)LinkButtonController.$(O) \
   124     $(OUTDIR)LabelAndTwoIcons.$(O) \
   204     $(OUTDIR)LabelAndTwoIcons.$(O) \
   125     $(OUTDIR)AssistantApplication.$(O) \
   205     $(OUTDIR)AssistantApplication.$(O) \
       
   206     $(OUTDIR)FilenameWidgetWithoutHistory.$(O) \
   126     $(OUTDIR)LicenceBox.$(O) \
   207     $(OUTDIR)LicenceBox.$(O) \
   127 
   208 
   128 
   209 
       
   210