Make.spec
author Claus Gittinger <cg@exept.de>
Mon, 21 Aug 2006 19:34:58 +0200
changeset 3004 1f50e7980044
parent 2998 37f8e0d423be
child 3009 abbcdef4d0f4
permissions -rw-r--r--
automatically generated by browser

# $Header: /cvs/stx/stx/libwidg2/Make.spec,v 1.12 2006-08-21 17:34:58 cg Exp $
#
# DO NOT EDIT 
# automagically generated from the projectDefinition: stx_libwidg2.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libwidg2
LIBNAME=libstx_libwidg2


# Argument(s) to the stc compiler (stc --usage).
#  -H.         : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=

COMMON_OBJS= \
    CheckBox.$(O) \
    MenuPanel.$(O) \
    ComboBoxButton.$(O) \
    ComboView.$(O) \
    ComboListView.$(O) \
    ComboBoxView.$(O) \
    DSVColumnView.$(O) \
    DSVLabelView.$(O) \
    DataSetColumn.$(O) \
    DataSetLabel.$(O) \
    DataSetView.$(O) \
    DoWhatIMeanSupport.$(O) \
    EnterBoxWithList.$(O) \
    ExtendedComboBox.$(O) \
    TreeItem.$(O) \
    SelectionInTreeView.$(O) \
    FilenameComboBoxView.$(O) \
    FilenameEditField.$(O) \
    FilenameEnterBox.$(O) \
    FontMenu.$(O) \
    GridBagConstraints.$(O) \
    GridBagLayoutInfo.$(O) \
    GridBagLayoutView.$(O) \
    HierarchicalItem.$(O) \
    HierarchicalList.$(O) \
    HierarchicalItemWithLabel.$(O) \
    HierarchicalItemWithLabelAndIcon.$(O) \
    HierarchicalItemWithLabelAndIconAndValue.$(O) \
    HierarchicalFileList.$(O) \
    ListModelView.$(O) \
    HierarchyNode.$(O) \
    Slider.$(O) \
    ImageView.$(O) \
    ListEntry.$(O) \
    LabelledEnterField.$(O) \
    ModelListEntry.$(O) \
    SelectionInListModelView.$(O) \
    ColorMenu.$(O) \
    LabelAndIcon.$(O) \
    MultiColListEntry.$(O) \
    MultipleItemSelectionWidget.$(O) \
    NoteBookView.$(O) \
    PrintAbortDialog.$(O) \
    PrintingDialog.$(O) \
    ProgressIndicator.$(O) \
    SelectionInHierarchy.$(O) \
    HierarchicalListView.$(O) \
    SelectionInTree.$(O) \
    FileSelectionTree.$(O) \
    Separator.$(O) \
    HorizontalSlider.$(O) \
    SubCanvas.$(O) \
    SyncedMultiColumnTextView.$(O) \
    TabItem.$(O) \
    TabSpecRuler.$(O) \
    TabView.$(O) \
    TabWidget.$(O) \
    TabulatorSpecification.$(O) \
    TextBox.$(O) \
    FileSelectionItem.$(O) \
    TreeItemWithImage.$(O) \
    TwoColumnTextView.$(O) \
    UpDownButton.$(O) \
    ViewScroller.$(O) \
    stx_libwidg2.$(O) \