Make.spec
author Claus Gittinger <cg@exept.de>
Mon, 13 Nov 2006 17:25:39 +0100
changeset 3152 640676dec061
parent 3115 810cbbbdc62c
child 3254 d599ab4650c7
permissions -rw-r--r--
automatically generated by browser

# $Header: /cvs/stx/stx/libwidg2/Make.spec,v 1.26 2006-11-13 16:25:39 cg Exp $
#
# DO NOT EDIT 
# automagically generated from the projectDefinition: stx_libwidg2.
#
# Warning: once you modify this file, do not rerun
# stmkmp or projectDefinition-build again - otherwise, your changes are lost.
#
# This file contains specifications which are common to all platforms.
#

# Do NOT CHANGE THESE DEFINITIONS
# (otherwise, ST/X will have a hard time to find out the packages location from its packageID,
#  to find the source code of a class and to find the library for a package)
MODULE=stx
MODULE_DIR=libwidg2
PACKAGE=$(MODULE):$(MODULE_DIR)


# Argument(s) to the stc compiler (stc --usage).
#  -H.         : create header files locally
#                (if removed, they will be created as common
#  -Pxxx       : defines the package
#  -Zxxx       : a prefix for variables within the classLib
#  -Dxxx       : defines passed to to CC for inline C-code
#  -Ixxx       : include path passed to CC for inline C-code
#  +optspace   : optimized for space
#  +optspace2  : optimized more for space
#  +optspace3  : optimized even more for space
#  +optinline  : generate inline code for some ST constructs
#  +inlineNew  : additionally inline new
#  +inlineMath : additionally inline some floatPnt math stuff
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCLOCALOPTIMIZATIONS=+optinline +inlineNew
# STCLOCALOPTIMIZATIONS=+optspace3
STCLOCALOPTIMIZATIONS=+optspace3


# Argument(s) to the stc compiler (stc --usage).
#  -warn            : no warnings
#  -warnNonStandard : no warnings about ST/X extensions
#  -warnEOLComments : no warnings about EOL comment extension
#  -warnPrivacy     : no warnings about privateClass extension
#
# ********** OPTIONAL: MODIFY the next line(s) ***
# STCWARNINGS=-warn
# STCWARNINGS=-warnNonStandard
# STCWARNINGS=-warnEOLComments
STCWARNINGS=-warnNonStandard

COMMON_OBJS= \
    $(OUTDIR)CharacterSetView.$(O) \
    $(OUTDIR)CheckBox.$(O) \
    $(OUTDIR)MenuPanel.$(O) \
    $(OUTDIR)ComboBoxButton.$(O) \
    $(OUTDIR)ComboView.$(O) \
    $(OUTDIR)ComboListView.$(O) \
    $(OUTDIR)ComboBoxView.$(O) \
    $(OUTDIR)DSVColumnView.$(O) \
    $(OUTDIR)DSVLabelView.$(O) \
    $(OUTDIR)DataSetColumn.$(O) \
    $(OUTDIR)DataSetLabel.$(O) \
    $(OUTDIR)DataSetView.$(O) \
    $(OUTDIR)DoWhatIMeanSupport.$(O) \
    $(OUTDIR)EnterBoxWithList.$(O) \
    $(OUTDIR)ExtendedComboBox.$(O) \
    $(OUTDIR)TreeItem.$(O) \
    $(OUTDIR)SelectionInTreeView.$(O) \
    $(OUTDIR)FilenameComboBoxView.$(O) \
    $(OUTDIR)FilenameEditField.$(O) \
    $(OUTDIR)FilenameEnterBox.$(O) \
    $(OUTDIR)FontMenu.$(O) \
    $(OUTDIR)GridBagConstraints.$(O) \
    $(OUTDIR)GridBagLayoutInfo.$(O) \
    $(OUTDIR)GridBagLayoutView.$(O) \
    $(OUTDIR)HierarchicalItem.$(O) \
    $(OUTDIR)HierarchicalList.$(O) \
    $(OUTDIR)HierarchicalItemWithLabel.$(O) \
    $(OUTDIR)HierarchicalItemWithLabelAndIcon.$(O) \
    $(OUTDIR)HierarchicalItemWithLabelAndIconAndValue.$(O) \
    $(OUTDIR)HierarchicalFileList.$(O) \
    $(OUTDIR)ListModelView.$(O) \
    $(OUTDIR)HierarchyNode.$(O) \
    $(OUTDIR)Slider.$(O) \
    $(OUTDIR)ImageView.$(O) \
    $(OUTDIR)ImageEditView.$(O) \
    $(OUTDIR)ListEntry.$(O) \
    $(OUTDIR)LabelledEnterField.$(O) \
    $(OUTDIR)ModelListEntry.$(O) \
    $(OUTDIR)SelectionInListModelView.$(O) \
    $(OUTDIR)ColorMenu.$(O) \
    $(OUTDIR)LabelAndIcon.$(O) \
    $(OUTDIR)MultiColListEntry.$(O) \
    $(OUTDIR)MultipleItemSelectionWidget.$(O) \
    $(OUTDIR)NoteBookView.$(O) \
    $(OUTDIR)PrintAbortDialog.$(O) \
    $(OUTDIR)PrintingDialog.$(O) \
    $(OUTDIR)ProgressIndicator.$(O) \
    $(OUTDIR)SelectionInHierarchy.$(O) \
    $(OUTDIR)HierarchicalListView.$(O) \
    $(OUTDIR)SelectionInTree.$(O) \
    $(OUTDIR)FileSelectionTree.$(O) \
    $(OUTDIR)Separator.$(O) \
    $(OUTDIR)HorizontalSlider.$(O) \
    $(OUTDIR)SubCanvas.$(O) \
    $(OUTDIR)SyncedMultiColumnTextView.$(O) \
    $(OUTDIR)TabItem.$(O) \
    $(OUTDIR)TabSpecRuler.$(O) \
    $(OUTDIR)TabView.$(O) \
    $(OUTDIR)TabWidget.$(O) \
    $(OUTDIR)TabulatorSpecification.$(O) \
    $(OUTDIR)TextBox.$(O) \
    $(OUTDIR)FileSelectionItem.$(O) \
    $(OUTDIR)TreeItemWithImage.$(O) \
    $(OUTDIR)TwoColumnTextView.$(O) \
    $(OUTDIR)UpDownButton.$(O) \
    $(OUTDIR)ViewScroller.$(O) \
    $(OUTDIR)stx_libwidg2.$(O) \
    $(OUTDIR)LicenceBox.$(O) \