Make.spec
changeset 37 be8c2dd09dff
parent 34 4c372f8296b9
child 38 a64f4ad690f5
equal deleted inserted replaced
36:1bfd09c6b3d8 37:be8c2dd09dff
     1 # $Header$
     1 # $Header$
     2 #
     2 #
     3 # DO NOT EDIT 
     3 # DO NOT EDIT
     4 # automagically generated from the projectDefinition: cvut_stx_goodies_newcompiler.
     4 # automagically generated from the projectDefinition: cvut_stx_goodies_newcompiler at 2012-03-29 19:04:23.686.
     5 #
     5 #
     6 # Warning: once you modify this file, do not rerun
     6 # Warning: once you modify this file, do not rerun
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
     7 # stmkmp or projectDefinition-build again - otherwise, your changes are lost.
     8 #
     8 #
     9 # This file contains specifications which are common to all platforms.
     9 # This file contains specifications which are common to all platforms.
    16 MODULE_DIR=stx/goodies/newcompiler
    16 MODULE_DIR=stx/goodies/newcompiler
    17 PACKAGE=$(MODULE):$(MODULE_DIR)
    17 PACKAGE=$(MODULE):$(MODULE_DIR)
    18 
    18 
    19 
    19 
    20 # Argument(s) to the stc compiler (stc --usage).
    20 # Argument(s) to the stc compiler (stc --usage).
    21 #  -H.         : create header files locally
    21 #  -headerDir=. : create header files locally
    22 #                (if removed, they will be created as common
    22 #                (if removed, they will be created as common
    23 #  -Pxxx       : defines the package
    23 #  -Pxxx       : defines the package
    24 #  -Zxxx       : a prefix for variables within the classLib
    24 #  -Zxxx       : a prefix for variables within the classLib
    25 #  -Dxxx       : defines passed to to CC for inline C-code
    25 #  -Dxxx       : defines passed to to CC for inline C-code
    26 #  -Ixxx       : include path passed to CC for inline C-code
    26 #  -Ixxx       : include path passed to CC for inline C-code
    59 	IRStackCount \
    59 	IRStackCount \
    60 	cvut_stx_goodies_newcompiler \
    60 	cvut_stx_goodies_newcompiler \
    61 	IRAccess \
    61 	IRAccess \
    62 	IRClosure \
    62 	IRClosure \
    63 	IRConstant \
    63 	IRConstant \
       
    64 	IRDecompiler \
    64 	IRDup \
    65 	IRDup \
    65 	IRJump \
    66 	IRJump \
    66 	IRLine \
    67 	IRLine \
    67 	IRMethod \
    68 	IRMethod \
    68 	IRPop \
    69 	IRPop \
    96     $(OUTDIR)IRStackCount.$(O) \
    97     $(OUTDIR)IRStackCount.$(O) \
    97     $(OUTDIR)cvut_stx_goodies_newcompiler.$(O) \
    98     $(OUTDIR)cvut_stx_goodies_newcompiler.$(O) \
    98     $(OUTDIR)IRAccess.$(O) \
    99     $(OUTDIR)IRAccess.$(O) \
    99     $(OUTDIR)IRClosure.$(O) \
   100     $(OUTDIR)IRClosure.$(O) \
   100     $(OUTDIR)IRConstant.$(O) \
   101     $(OUTDIR)IRConstant.$(O) \
       
   102     $(OUTDIR)IRDecompiler.$(O) \
   101     $(OUTDIR)IRDup.$(O) \
   103     $(OUTDIR)IRDup.$(O) \
   102     $(OUTDIR)IRJump.$(O) \
   104     $(OUTDIR)IRJump.$(O) \
   103     $(OUTDIR)IRLine.$(O) \
   105     $(OUTDIR)IRLine.$(O) \
   104     $(OUTDIR)IRMethod.$(O) \
   106     $(OUTDIR)IRMethod.$(O) \
   105     $(OUTDIR)IRPop.$(O) \
   107     $(OUTDIR)IRPop.$(O) \