Make.spec
changeset 39 d361eb9419e6
parent 38 a64f4ad690f5
child 40 c99f058e2276
equal deleted inserted replaced
38:a64f4ad690f5 39:d361eb9419e6
    49 # STCWARNINGS=-warnEOLComments
    49 # STCWARNINGS=-warnEOLComments
    50 STCWARNINGS=-warnNonStandard
    50 STCWARNINGS=-warnNonStandard
    51 
    51 
    52 COMMON_CLASSES= \
    52 COMMON_CLASSES= \
    53 	IRBuilder \
    53 	IRBuilder \
       
    54 	IRBuilderTest \
    54 	IRBytecodeGenerator \
    55 	IRBytecodeGenerator \
    55 	IRFunction \
    56 	IRFunction \
    56 	IRInstruction \
    57 	IRInstruction \
    57 	IRInterpreter \
    58 	IRInterpreter \
    58 	IRSequence \
    59 	IRSequence \
    59 	IRStackCount \
    60 	IRStackCount \
       
    61 	IRTransformTest \
    60 	cvut_stx_goodies_newcompiler \
    62 	cvut_stx_goodies_newcompiler \
    61 	IRAccess \
    63 	IRAccess \
    62 	IRClosure \
    64 	IRClosure \
    63 	IRConstant \
    65 	IRConstant \
    64 	IRDecompiler \
    66 	IRDecompiler \
    87 
    89 
    88 
    90 
    89 
    91 
    90 COMMON_OBJS= \
    92 COMMON_OBJS= \
    91     $(OUTDIR)IRBuilder.$(O) \
    93     $(OUTDIR)IRBuilder.$(O) \
       
    94     $(OUTDIR)IRBuilderTest.$(O) \
    92     $(OUTDIR)IRBytecodeGenerator.$(O) \
    95     $(OUTDIR)IRBytecodeGenerator.$(O) \
    93     $(OUTDIR)IRFunction.$(O) \
    96     $(OUTDIR)IRFunction.$(O) \
    94     $(OUTDIR)IRInstruction.$(O) \
    97     $(OUTDIR)IRInstruction.$(O) \
    95     $(OUTDIR)IRInterpreter.$(O) \
    98     $(OUTDIR)IRInterpreter.$(O) \
    96     $(OUTDIR)IRSequence.$(O) \
    99     $(OUTDIR)IRSequence.$(O) \
    97     $(OUTDIR)IRStackCount.$(O) \
   100     $(OUTDIR)IRStackCount.$(O) \
       
   101     $(OUTDIR)IRTransformTest.$(O) \
    98     $(OUTDIR)cvut_stx_goodies_newcompiler.$(O) \
   102     $(OUTDIR)cvut_stx_goodies_newcompiler.$(O) \
    99     $(OUTDIR)IRAccess.$(O) \
   103     $(OUTDIR)IRAccess.$(O) \
   100     $(OUTDIR)IRClosure.$(O) \
   104     $(OUTDIR)IRClosure.$(O) \
   101     $(OUTDIR)IRConstant.$(O) \
   105     $(OUTDIR)IRConstant.$(O) \
   102     $(OUTDIR)IRDecompiler.$(O) \
   106     $(OUTDIR)IRDecompiler.$(O) \